* character is treated as a wildcard and is used to represent any acceptable
type or subtype value. A media type may not have wildcard type with a declared subtype. The
* character has no special meaning as part of a parameter. All values for type, subtype,
parameter attributes or parameter values must be valid according to RFCs 2045 and 2046.
All portions of the media type that are case-insensitive (type, subtype, parameter attributes)
are normalized to lowercase. The value of the charset parameter is normalized to
lowercase, but all others are left as-is.
Note that this specifically does not represent the value of the MIME Content-Type header and as such has no support for header-specific considerations such as line
folding and comments.
For media types that take a charset the predefined constants default to UTF-8 and have a
"_UTF_8" suffix. To get a version without a character set, use withoutParameters.
| Modifier and Type | Class and Description |
|---|---|
| private static class |
| Modifier and Type | Field and Description |
|---|---|
| public static final MediaType | AAC_AUDIO
Advanced Audio Coding. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | ANY_FONT_TYPE
Wildcard matching any "font" top-level media type. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | APPLICATION_BINARY
This is a non-standard media type, but is commonly used in serving hosted binary files as it is known not to trigger content sniffing in current browsers. |
| private static final String | |
| public static final MediaType | APPLICATION_XML_UTF_8
As described in RFC 3023, this constant
( |
| public static final MediaType | |
| private static final String | |
| public static final MediaType | BASIC_AUDIO
Basic Audio, as defined by RFC 2046. |
| public static final MediaType | BMP
Bitmap file format ( |
| public static final MediaType | |
| public static final MediaType | |
| private static final String | |
| public static final MediaType | CRW
The Canon Image File
Format ( |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | DART_UTF_8
Files in the dart programming language. |
| public static final MediaType | EOT
Embedded OpenType fonts. |
| public static final MediaType | EPUB
As described in the International Digital Publishing Forum EPUB is the distribution and interchange format standard for digital publications and documents. |
| public static final MediaType | FLV_VIDEO
Flash video. |
| public static final MediaType | FONT_COLLECTION
A collection of font outlines as defined by RFC 8081. |
| public static final MediaType | FONT_OTF
Open Type Font Format (OTF) as defined by RFC 8081. |
| public static final MediaType | |
| public static final MediaType | FONT_TTF
True Type Font Format (TTF) as defined by RFC 8081. |
| private static final String | |
| public static final MediaType | FONT_WOFF
Web Open Font Format (WOFF). |
| public static final MediaType | FONT_WOFF2
Web Open Font Format (WOFF2). |
| public static final MediaType | |
| public static final MediaType | GEO_JSON
Media type for the GeoJSON Format, a geospatial data interchange format based on JSON. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| private int | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| private static final String | |
| public static final MediaType | JAVASCRIPT_UTF_8
RFC 4329 declares this to be the
correct media type for JavaScript, but |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | KEY_ARCHIVE
As described in PKCS #12: Personal Information Exchange Syntax Standard, PKCS #12 defines an archive file format for storing many cryptography objects as a single file. |
| public static final MediaType | |
| public static final MediaType | KMZ
OGC KML (Keyhole Markup Language), compressed using the ZIP format into KMZ archives. |
| private static final Map | |
| public static final MediaType | |
| public static final MediaType | |
| private static final CharMatcher | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | MICROSOFT_EXCEL
Microsoft Excel spreadsheets. |
| public static final MediaType | |
| public static final MediaType | MICROSOFT_POWERPOINT
Microsoft Powerpoint presentations. |
| public static final MediaType | MICROSOFT_WORD
Microsoft Word documents. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | NACL_APPLICATION
NaCl applications. |
| public static final MediaType | NACL_PORTABLE_APPLICATION
NaCl portable applications. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | OPENSEARCH_DESCRIPTION_UTF_8
OpenSearch Description files are XML files that describe how a website can be used as a search engine by consumers (e.g. web browsers). |
| private static final Joiner. | |
| private final ImmutableListMultimap | |
| private Optional | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | PSD
The Photoshop File Format ( |
| public static final MediaType | |
| private static final CharMatcher | |
| public static final MediaType | RDF_XML_UTF_8
RDF/XML documents, which are XML serializations of Resource Description Framework graphs. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | SOAP_XML_UTF_8
As described in RFC 3902, this constant
( |
| private final String | |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | TEXT_JAVASCRIPT_UTF_8
RFC 4329 declares |
| private static final String | |
| public static final MediaType | THREE_GPP2_VIDEO
The 3G2 multimedia container format. |
| public static final MediaType | THREE_GPP_VIDEO
The 3GP multimedia container format. |
| public static final MediaType | |
| private static final CharMatcher | TOKEN_MATCHER
Matcher for type, subtype and attributes. |
| private String | |
| public static final MediaType | |
| private final String | |
| private static final ImmutableListMultimap | |
| public static final MediaType | |
| private static final String | |
| public static final MediaType | VND_REAL_AUDIO
Real Audio. |
| public static final MediaType | VND_WAVE_AUDIO
WAVE format, as defined by RFC 2361. |
| public static final MediaType | VORBIS_AUDIO
Vorbis Audio, as defined by RFC 5215. |
| public static final MediaType | VTT_UTF_8
As described in the VTT spec, this is used for Web Video Text Tracks (WebVTT) files, used with the HTML5 track element. |
| public static final MediaType | WASM_APPLICATION
WASM applications. |
| public static final MediaType | WAX_AUDIO
Windows Media metafiles. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | |
| private static final String | |
| public static final MediaType | WMA_AUDIO
Windows Media Audio. |
| public static final MediaType | WML_UTF_8
UTF-8 encoded Wireless Markup Language. |
| public static final MediaType | |
| public static final MediaType | |
| public static final MediaType | WOFF2
RFC 8081 declares |
| public static final MediaType | |
| public static final MediaType | XML_UTF_8
As described in RFC 3023, this constant
( |
| public static final MediaType | XRD_UTF_8
Extensible Resource Descriptors. |
| public static final MediaType |
| Access | Constructor and Description |
|---|---|
| private |
| Modifier and Type | Method and Description |
|---|---|
| private static MediaType | |
| public Optional | |
| private String | |
| public static MediaType | |
| private static MediaType | |
| pack-priv static MediaType | createApplicationType(String subtype)
Creates a media type with the "application" type and the given subtype. |
| pack-priv static MediaType | |
| private static MediaType | |
| private static MediaType | |
| pack-priv static MediaType | |
| pack-priv static MediaType | |
| pack-priv static MediaType | |
| pack-priv static MediaType | |
| public boolean | equals(Object
the reference object with which to compare. obj)Overrides java. |
| private static String | |
| public int | |
| public boolean | |
| public boolean | is(MediaType mediaTypeRange)
Returns
|
| private static String | |
| private static String | |
| public ImmutableListMultimap | |
| private Map | |
| public static MediaType | |
| public String | |
| public String | toString()
Overrides java. |
| public String | |
| public MediaType | withCharset(Charset charset)
Returns a new instance with the same type and subtype as this instance, with the |
| public MediaType | withoutParameters()
Returns a new instance with the same type and subtype as this instance, but without any parameters. |
| public MediaType | withParameter(String attribute, String value)
Replaces all parameters with the given attribute with a single parameter with the given value. |
| public MediaType | withParameters(Multimap<String, String> parameters)
Replaces all parameters with the given parameters. |
| public MediaType | withParameters(String attribute, Iterable<String> values)
Replaces all parameters with the given attribute with parameters using the given values. |