Top Description Fields Constructors Methods
io.netty.handler.codec.dns

public Class DnsOpCode

extends Object
implements Comparable<DnsOpCode>
Class Inheritance
All Implemented Interfaces
java.lang.Comparable
Annotations
@UnstableApi
Imports
io.netty.util.internal.UnstableApi

The DNS OpCode as defined in RFC2929.

Field Summary

Modifier and TypeField and Description
private final byte
public static final DnsOpCode
IQUERY

The 'IQuery' DNS OpCode, as defined in RFC1035.

private final String
public static final DnsOpCode
NOTIFY

The 'Notify' DNS OpCode, as defined in RFC1996.

public static final DnsOpCode
QUERY

The 'Query' DNS OpCode, as defined in RFC1035.

public static final DnsOpCode
STATUS

The 'Status' DNS OpCode, as defined in RFC1035.

private String
public static final DnsOpCode
UPDATE

The 'Update' DNS OpCode, as defined in RFC2136.

Constructor Summary

AccessConstructor and Description
private
DnsOpCode(int byteValue)

public
DnsOpCode(int byteValue, String name)

Method Summary

Modifier and TypeMethod and Description
public byte
public int
compareTo(DnsOpCode
the object to be compared.
o
)

Implements java.lang.Comparable.compareTo.

Compares this object with the specified object for order.
public boolean
equals(Object
the reference object with which to compare.
obj
)

Overrides java.lang.Object.equals.

Indicates whether some other object is "equal to" this one.
public int
hashCode()

Overrides java.lang.Object.hashCode.

Returns a hash code value for the object.
public String
toString()

Overrides java.lang.Object.toString.

Returns a string representation of the object.
public static DnsOpCode
valueOf(int b)

Returns the DnsOpCode instance of the specified byte value.

Inherited from java.lang.Object:
clonefinalizegetClassnotifynotifyAllwaitwaitwait

Field Detail

byteValueback to summary
private final byte byteValue
IQUERYback to summary
public static final DnsOpCode IQUERY

The 'IQuery' DNS OpCode, as defined in RFC1035.

nameback to summary
private final String name
NOTIFYback to summary
public static final DnsOpCode NOTIFY

The 'Notify' DNS OpCode, as defined in RFC1996.

QUERYback to summary
public static final DnsOpCode QUERY

The 'Query' DNS OpCode, as defined in RFC1035.

STATUSback to summary
public static final DnsOpCode STATUS

The 'Status' DNS OpCode, as defined in RFC1035.

textback to summary
private String text
UPDATEback to summary
public static final DnsOpCode UPDATE

The 'Update' DNS OpCode, as defined in RFC2136.

Constructor Detail

DnsOpCodeback to summary
private DnsOpCode(int byteValue)
DnsOpCodeback to summary
public DnsOpCode(int byteValue, String name)

Method Detail

byteValueback to summary
public byte byteValue()
compareToback to summary
public int compareTo(DnsOpCode o)

Implements java.lang.Comparable.compareTo.

Doc from java.lang.Comparable.compareTo.

Compares this object with the specified object for order. Returns a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

The implementor must ensure signum(x.compareTo(y)) == -signum(y.compareTo(x)) for all x and y. (This implies that x.compareTo(y) must throw an exception if and only if y.compareTo(x) throws an exception.)

The implementor must also ensure that the relation is transitive: (x.compareTo(y) > 0 && y.compareTo(z) > 0) implies x.compareTo(z) > 0.

Finally, the implementor must ensure that x.compareTo(y)==0 implies that signum(x.compareTo(z)) == signum(y.compareTo(z)), for all z.

Parameters
o:DnsOpCode

the object to be compared.

Returns:int

a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

Annotations
@Override
equalsback to summary
public boolean equals(Object obj)

Overrides java.lang.Object.equals.

Doc from java.lang.Object.equals.

Indicates whether some other object is "equal to" this one.

The equals method implements an equivalence relation on non-null object references:

  • It is reflexive: for any non-null reference value x, x.equals(x) should return true.
  • It is symmetric: for any non-null reference values x and y, x.equals(y) should return true if and only if y.equals(x) returns true.
  • It is transitive: for any non-null reference values x, y, and z, if x.equals(y) returns true and y.equals(z) returns true, then x.equals(z) should return true.
  • It is consistent: for any non-null reference values x and y, multiple invocations of x.equals(y) consistently return true or consistently return false, provided no information used in equals comparisons on the objects is modified.
  • For any non-null reference value x, x.equals(null) should return false.

An equivalence relation partitions the elements it operates on into equivalence classes; all the members of an equivalence class are equal to each other. Members of an equivalence class are substitutable for each other, at least for some purposes.

Parameters
obj:Object

the reference object with which to compare.

Returns:boolean

true if this object is the same as the obj argument; false otherwise.

Annotations
@Override
hashCodeback to summary
public int hashCode()

Overrides java.lang.Object.hashCode.

Doc from java.lang.Object.hashCode.

Returns a hash code value for the object. This method is supported for the benefit of hash tables such as those provided by java.util.HashMap.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.
Returns:int

a hash code value for this object.

Annotations
@Override
toStringback to summary
public String toString()

Overrides java.lang.Object.toString.

Doc from java.lang.Object.toString.

Returns a string representation of the object.

Returns:String

a string representation of the object.

Annotations
@Override
valueOfback to summary
public static DnsOpCode valueOf(int b)

Returns the DnsOpCode instance of the specified byte value.