RCODE, as defined in RFC2929.
| Modifier and Type | Field and Description |
|---|---|
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | BADVERS_OR_BADSIG
The 'BADVERS' or 'BADSIG' DNS RCODE (16), as defined in RFC2671 and RFC2845. |
| private final int | |
| public static final DnsResponseCode | |
| private final String | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode | |
| private String | |
| public static final DnsResponseCode | |
| public static final DnsResponseCode |
| Access | Constructor and Description |
|---|---|
| private | |
| public |
| Modifier and Type | Method and Description |
|---|---|
| public int | compareTo(DnsResponseCode
the object to be compared. o)Implements java. |
| public boolean | equals(Object
the reference object with which to compare. o)Overrides java. DnsResponseCode only depends on intValue().
|
| public int | |
| public int | |
| public String | toString()
Overrides java. DnsResponseCode.
|
| public static DnsResponseCode | Returns: the correspondingDnsResponseCodethe DNS RCODE responseCode)Returns the |
| BADALG | back to summary |
|---|---|
| public static final DnsResponseCode BADALG The 'BADALG' DNS RCODE (21), as defined in RFC2930. | |
| BADKEY | back to summary |
|---|---|
| public static final DnsResponseCode BADKEY The 'BADKEY' DNS RCODE (17), as defined in RFC2845. | |
| BADMODE | back to summary |
|---|---|
| public static final DnsResponseCode BADMODE The 'BADMODE' DNS RCODE (19), as defined in RFC2930. | |
| BADNAME | back to summary |
|---|---|
| public static final DnsResponseCode BADNAME The 'BADNAME' DNS RCODE (20), as defined in RFC2930. | |
| BADTIME | back to summary |
|---|---|
| public static final DnsResponseCode BADTIME The 'BADTIME' DNS RCODE (18), as defined in RFC2845. | |
| BADVERS_OR_BADSIG | back to summary |
|---|---|
| public static final DnsResponseCode BADVERS_OR_BADSIG The 'BADVERS' or 'BADSIG' DNS RCODE (16), as defined in RFC2671 and RFC2845. | |
| code | back to summary |
|---|---|
| private final int code | |
| FORMERR | back to summary |
|---|---|
| public static final DnsResponseCode FORMERR The 'FormErr' DNS RCODE (1), as defined in RFC1035. | |
| name | back to summary |
|---|---|
| private final String name | |
| NOERROR | back to summary |
|---|---|
| public static final DnsResponseCode NOERROR The 'NoError' DNS RCODE (0), as defined in RFC1035. | |
| NOTAUTH | back to summary |
|---|---|
| public static final DnsResponseCode NOTAUTH The 'NotAuth' DNS RCODE (9), as defined in RFC2136. | |
| NOTIMP | back to summary |
|---|---|
| public static final DnsResponseCode NOTIMP The 'NotImp' DNS RCODE (4), as defined in RFC1035. | |
| NOTZONE | back to summary |
|---|---|
| public static final DnsResponseCode NOTZONE The 'NotZone' DNS RCODE (10), as defined in RFC2136. | |
| NXDOMAIN | back to summary |
|---|---|
| public static final DnsResponseCode NXDOMAIN The 'NXDomain' DNS RCODE (3), as defined in RFC1035. | |
| NXRRSET | back to summary |
|---|---|
| public static final DnsResponseCode NXRRSET The 'NXRRSet' DNS RCODE (8), as defined in RFC2136. | |
| REFUSED | back to summary |
|---|---|
| public static final DnsResponseCode REFUSED The 'Refused' DNS RCODE (5), as defined in RFC1035. | |
| SERVFAIL | back to summary |
|---|---|
| public static final DnsResponseCode SERVFAIL The 'ServFail' DNS RCODE (2), as defined in RFC1035. | |
| text | back to summary |
|---|---|
| private String text | |
| YXDOMAIN | back to summary |
|---|---|
| public static final DnsResponseCode YXDOMAIN The 'YXDomain' DNS RCODE (6), as defined in RFC2136. | |
| YXRRSET | back to summary |
|---|---|
| public static final DnsResponseCode YXRRSET The 'YXRRSet' DNS RCODE (7), as defined in RFC2136. | |
| DnsResponseCode | back to summary |
|---|---|
| private DnsResponseCode(int code) | |
| DnsResponseCode | back to summary |
|---|---|
| public DnsResponseCode(int code, String name) | |
| compareTo | back to summary |
|---|---|
| public int compareTo(DnsResponseCode o) Implements java. Doc from java. Compares this object with the specified object for order. Returns a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object. The implementor must ensure The implementor must also ensure that the relation is transitive:
Finally, the implementor must ensure that
| |
| equals | back to summary |
|---|---|
| public boolean equals(Object o) Overrides java. Equality of
| |
| hashCode | back to summary |
|---|---|
| public int hashCode() Overrides java. Doc from java. Returns a hash code value for the object. This method is
supported for the benefit of hash tables such as those provided by
The general contract of
| |
| intValue | back to summary |
|---|---|
| public int intValue() Returns the error code for this | |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Returns a formatted error message for this
| |
| valueOf | back to summary |
|---|---|
| public static DnsResponseCode valueOf(int responseCode) Returns the
| |