| Modifier and Type | Field and Description |
|---|---|
| public static final HttpResponseStatus | ACCEPTED
202 Accepted |
| public static final HttpResponseStatus | BAD_GATEWAY
502 Bad Gateway |
| public static final HttpResponseStatus | BAD_REQUEST
400 Bad Request |
| private final byte[] | |
| private final int | |
| private final AsciiString | |
| private final HttpStatusClass | |
| public static final HttpResponseStatus | CONFLICT
409 Conflict |
| public static final HttpResponseStatus | CONTINUE
100 Continue |
| public static final HttpResponseStatus | CREATED
201 Created |
| public static final HttpResponseStatus | EARLY_HINTS
103 Early Hints (RFC 8297) |
| public static final HttpResponseStatus | EXPECTATION_FAILED
417 Expectation Failed |
| public static final HttpResponseStatus | FAILED_DEPENDENCY
424 Failed Dependency (WebDAV, RFC4918) |
| public static final HttpResponseStatus | FORBIDDEN
403 Forbidden |
| public static final HttpResponseStatus | FOUND
302 Found |
| public static final HttpResponseStatus | GATEWAY_TIMEOUT
504 Gateway Timeout |
| public static final HttpResponseStatus | GONE
410 Gone |
| public static final HttpResponseStatus | HTTP_VERSION_NOT_SUPPORTED
505 HTTP Version Not Supported |
| public static final HttpResponseStatus | INSUFFICIENT_STORAGE
507 Insufficient Storage (WebDAV, RFC4918) |
| public static final HttpResponseStatus | INTERNAL_SERVER_ERROR
500 Internal Server Error |
| public static final HttpResponseStatus | LENGTH_REQUIRED
411 Length Required |
| public static final HttpResponseStatus | LOCKED
423 Locked (WebDAV, RFC4918) |
| public static final HttpResponseStatus | METHOD_NOT_ALLOWED
405 Method Not Allowed |
| public static final HttpResponseStatus | MISDIRECTED_REQUEST
421 Misdirected Request |
| public static final HttpResponseStatus | MOVED_PERMANENTLY
301 Moved Permanently |
| public static final HttpResponseStatus | MULTI_STATUS
207 Multi-Status (WebDAV, RFC2518) |
| public static final HttpResponseStatus | MULTIPLE_CHOICES
300 Multiple Choices |
| public static final HttpResponseStatus | NETWORK_AUTHENTICATION_REQUIRED
511 Network Authentication Required (RFC6585) |
| public static final HttpResponseStatus | NO_CONTENT
204 No Content |
| public static final HttpResponseStatus | NON_AUTHORITATIVE_INFORMATION
203 Non-Authoritative Information (since HTTP/1.1) |
| public static final HttpResponseStatus | NOT_ACCEPTABLE
406 Not Acceptable |
| public static final HttpResponseStatus | NOT_EXTENDED
510 Not Extended (RFC2774) |
| public static final HttpResponseStatus | NOT_FOUND
404 Not Found |
| public static final HttpResponseStatus | NOT_IMPLEMENTED
501 Not Implemented |
| public static final HttpResponseStatus | NOT_MODIFIED
304 Not Modified |
| public static final HttpResponseStatus | OK
200 OK |
| public static final HttpResponseStatus | PARTIAL_CONTENT
206 Partial Content |
| public static final HttpResponseStatus | PAYMENT_REQUIRED
402 Payment Required |
| public static final HttpResponseStatus | PERMANENT_REDIRECT
308 Permanent Redirect (RFC7538) |
| public static final HttpResponseStatus | PRECONDITION_FAILED
412 Precondition Failed |
| public static final HttpResponseStatus | PRECONDITION_REQUIRED
428 Precondition Required (RFC6585) |
| public static final HttpResponseStatus | PROCESSING
102 Processing (WebDAV, RFC2518) |
| public static final HttpResponseStatus | PROXY_AUTHENTICATION_REQUIRED
407 Proxy Authentication Required |
| private final String | |
| public static final HttpResponseStatus | REQUEST_ENTITY_TOO_LARGE
413 Request Entity Too Large |
| public static final HttpResponseStatus | REQUEST_HEADER_FIELDS_TOO_LARGE
431 Request Header Fields Too Large (RFC6585) |
| public static final HttpResponseStatus | REQUEST_TIMEOUT
408 Request Timeout |
| public static final HttpResponseStatus | REQUEST_URI_TOO_LONG
414 Request-URI Too Long |
| public static final HttpResponseStatus | REQUESTED_RANGE_NOT_SATISFIABLE
416 Requested Range Not Satisfiable |
| public static final HttpResponseStatus | RESET_CONTENT
205 Reset Content |
| public static final HttpResponseStatus | SEE_OTHER
303 See Other (since HTTP/1.1) |
| public static final HttpResponseStatus | SERVICE_UNAVAILABLE
503 Service Unavailable |
| public static final HttpResponseStatus | SWITCHING_PROTOCOLS
101 Switching Protocols |
| public static final HttpResponseStatus | TEMPORARY_REDIRECT
307 Temporary Redirect (since HTTP/1.1) |
| public static final HttpResponseStatus | TOO_MANY_REQUESTS
429 Too Many Requests (RFC6585) |
| public static final HttpResponseStatus | UNAUTHORIZED
401 Unauthorized |
| public static final HttpResponseStatus | UNORDERED_COLLECTION
425 Unordered Collection (WebDAV, RFC3648) |
| public static final HttpResponseStatus | UNPROCESSABLE_ENTITY
422 Unprocessable Entity (WebDAV, RFC4918) |
| public static final HttpResponseStatus | UNSUPPORTED_MEDIA_TYPE
415 Unsupported Media Type |
| public static final HttpResponseStatus | UPGRADE_REQUIRED
426 Upgrade Required (RFC2817) |
| public static final HttpResponseStatus | USE_PROXY
305 Use Proxy (since HTTP/1.1) |
| public static final HttpResponseStatus | VARIANT_ALSO_NEGOTIATES
506 Variant Also Negotiates (RFC2295) |
| Access | Constructor and Description |
|---|---|
| private | HttpResponseStatus(int code)
Creates a new instance with the specified |
| public | HttpResponseStatus(int code, String reasonPhrase)
Creates a new instance with the specified |
| private |
| Modifier and Type | Method and Description |
|---|---|
| public int | |
| public AsciiString | |
| public HttpStatusClass | |
| public int | compareTo(HttpResponseStatus
the object to be compared. o)Implements java. HttpResponseStatus only depends on code().
|
| pack-priv void | |
| public boolean | equals(Object
the reference object with which to compare. o)Overrides java. HttpResponseStatus only depends on code().
|
| public int | |
| private static HttpResponseStatus | |
| public static HttpResponseStatus | |
| public static HttpResponseStatus | |
| public static HttpResponseStatus | |
| public String | |
| public String | |
| public static HttpResponseStatus | |
| public static HttpResponseStatus | valueOf(int
The response code value. code, String The response code reason phrase. reasonPhrase)Returns the |
| private static HttpResponseStatus |
| ACCEPTED | back to summary |
|---|---|
| public static final HttpResponseStatus ACCEPTED 202 Accepted | |
| BAD_GATEWAY | back to summary |
|---|---|
| public static final HttpResponseStatus BAD_GATEWAY 502 Bad Gateway | |
| BAD_REQUEST | back to summary |
|---|---|
| public static final HttpResponseStatus BAD_REQUEST 400 Bad Request | |
| bytes | back to summary |
|---|---|
| private final byte[] bytes | |
| code | back to summary |
|---|---|
| private final int code | |
| codeAsText | back to summary |
|---|---|
| private final AsciiString codeAsText | |
| codeClass | back to summary |
|---|---|
| private final HttpStatusClass codeClass | |
| CONFLICT | back to summary |
|---|---|
| public static final HttpResponseStatus CONFLICT 409 Conflict | |
| CONTINUE | back to summary |
|---|---|
| public static final HttpResponseStatus CONTINUE 100 Continue | |
| CREATED | back to summary |
|---|---|
| public static final HttpResponseStatus CREATED 201 Created | |
| EARLY_HINTS | back to summary |
|---|---|
| public static final HttpResponseStatus EARLY_HINTS 103 Early Hints (RFC 8297) | |
| EXPECTATION_FAILED | back to summary |
|---|---|
| public static final HttpResponseStatus EXPECTATION_FAILED 417 Expectation Failed | |
| FAILED_DEPENDENCY | back to summary |
|---|---|
| public static final HttpResponseStatus FAILED_DEPENDENCY 424 Failed Dependency (WebDAV, RFC4918) | |
| FORBIDDEN | back to summary |
|---|---|
| public static final HttpResponseStatus FORBIDDEN 403 Forbidden | |
| FOUND | back to summary |
|---|---|
| public static final HttpResponseStatus FOUND 302 Found | |
| GATEWAY_TIMEOUT | back to summary |
|---|---|
| public static final HttpResponseStatus GATEWAY_TIMEOUT 504 Gateway Timeout | |
| GONE | back to summary |
|---|---|
| public static final HttpResponseStatus GONE 410 Gone | |
| HTTP_VERSION_NOT_SUPPORTED | back to summary |
|---|---|
| public static final HttpResponseStatus HTTP_VERSION_NOT_SUPPORTED 505 HTTP Version Not Supported | |
| INSUFFICIENT_STORAGE | back to summary |
|---|---|
| public static final HttpResponseStatus INSUFFICIENT_STORAGE 507 Insufficient Storage (WebDAV, RFC4918) | |
| INTERNAL_SERVER_ERROR | back to summary |
|---|---|
| public static final HttpResponseStatus INTERNAL_SERVER_ERROR 500 Internal Server Error | |
| LENGTH_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus LENGTH_REQUIRED 411 Length Required | |
| LOCKED | back to summary |
|---|---|
| public static final HttpResponseStatus LOCKED 423 Locked (WebDAV, RFC4918) | |
| METHOD_NOT_ALLOWED | back to summary |
|---|---|
| public static final HttpResponseStatus METHOD_NOT_ALLOWED 405 Method Not Allowed | |
| MISDIRECTED_REQUEST | back to summary |
|---|---|
| public static final HttpResponseStatus MISDIRECTED_REQUEST 421 Misdirected Request | |
| MOVED_PERMANENTLY | back to summary |
|---|---|
| public static final HttpResponseStatus MOVED_PERMANENTLY 301 Moved Permanently | |
| MULTI_STATUS | back to summary |
|---|---|
| public static final HttpResponseStatus MULTI_STATUS 207 Multi-Status (WebDAV, RFC2518) | |
| MULTIPLE_CHOICES | back to summary |
|---|---|
| public static final HttpResponseStatus MULTIPLE_CHOICES 300 Multiple Choices | |
| NETWORK_AUTHENTICATION_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus NETWORK_AUTHENTICATION_REQUIRED 511 Network Authentication Required (RFC6585) | |
| NO_CONTENT | back to summary |
|---|---|
| public static final HttpResponseStatus NO_CONTENT 204 No Content | |
| NON_AUTHORITATIVE_INFORMATION | back to summary |
|---|---|
| public static final HttpResponseStatus NON_AUTHORITATIVE_INFORMATION 203 Non-Authoritative Information (since HTTP/1.1) | |
| NOT_ACCEPTABLE | back to summary |
|---|---|
| public static final HttpResponseStatus NOT_ACCEPTABLE 406 Not Acceptable | |
| NOT_EXTENDED | back to summary |
|---|---|
| public static final HttpResponseStatus NOT_EXTENDED 510 Not Extended (RFC2774) | |
| NOT_FOUND | back to summary |
|---|---|
| public static final HttpResponseStatus NOT_FOUND 404 Not Found | |
| NOT_IMPLEMENTED | back to summary |
|---|---|
| public static final HttpResponseStatus NOT_IMPLEMENTED 501 Not Implemented | |
| NOT_MODIFIED | back to summary |
|---|---|
| public static final HttpResponseStatus NOT_MODIFIED 304 Not Modified | |
| OK | back to summary |
|---|---|
| public static final HttpResponseStatus OK 200 OK | |
| PARTIAL_CONTENT | back to summary |
|---|---|
| public static final HttpResponseStatus PARTIAL_CONTENT 206 Partial Content | |
| PAYMENT_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus PAYMENT_REQUIRED 402 Payment Required | |
| PERMANENT_REDIRECT | back to summary |
|---|---|
| public static final HttpResponseStatus PERMANENT_REDIRECT 308 Permanent Redirect (RFC7538) | |
| PRECONDITION_FAILED | back to summary |
|---|---|
| public static final HttpResponseStatus PRECONDITION_FAILED 412 Precondition Failed | |
| PRECONDITION_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus PRECONDITION_REQUIRED 428 Precondition Required (RFC6585) | |
| PROCESSING | back to summary |
|---|---|
| public static final HttpResponseStatus PROCESSING 102 Processing (WebDAV, RFC2518) | |
| PROXY_AUTHENTICATION_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus PROXY_AUTHENTICATION_REQUIRED 407 Proxy Authentication Required | |
| reasonPhrase | back to summary |
|---|---|
| private final String reasonPhrase | |
| REQUEST_ENTITY_TOO_LARGE | back to summary |
|---|---|
| public static final HttpResponseStatus REQUEST_ENTITY_TOO_LARGE 413 Request Entity Too Large | |
| REQUEST_HEADER_FIELDS_TOO_LARGE | back to summary |
|---|---|
| public static final HttpResponseStatus REQUEST_HEADER_FIELDS_TOO_LARGE 431 Request Header Fields Too Large (RFC6585) | |
| REQUEST_TIMEOUT | back to summary |
|---|---|
| public static final HttpResponseStatus REQUEST_TIMEOUT 408 Request Timeout | |
| REQUEST_URI_TOO_LONG | back to summary |
|---|---|
| public static final HttpResponseStatus REQUEST_URI_TOO_LONG 414 Request-URI Too Long | |
| REQUESTED_RANGE_NOT_SATISFIABLE | back to summary |
|---|---|
| public static final HttpResponseStatus REQUESTED_RANGE_NOT_SATISFIABLE 416 Requested Range Not Satisfiable | |
| RESET_CONTENT | back to summary |
|---|---|
| public static final HttpResponseStatus RESET_CONTENT 205 Reset Content | |
| SEE_OTHER | back to summary |
|---|---|
| public static final HttpResponseStatus SEE_OTHER 303 See Other (since HTTP/1.1) | |
| SERVICE_UNAVAILABLE | back to summary |
|---|---|
| public static final HttpResponseStatus SERVICE_UNAVAILABLE 503 Service Unavailable | |
| SWITCHING_PROTOCOLS | back to summary |
|---|---|
| public static final HttpResponseStatus SWITCHING_PROTOCOLS 101 Switching Protocols | |
| TEMPORARY_REDIRECT | back to summary |
|---|---|
| public static final HttpResponseStatus TEMPORARY_REDIRECT 307 Temporary Redirect (since HTTP/1.1) | |
| TOO_MANY_REQUESTS | back to summary |
|---|---|
| public static final HttpResponseStatus TOO_MANY_REQUESTS 429 Too Many Requests (RFC6585) | |
| UNAUTHORIZED | back to summary |
|---|---|
| public static final HttpResponseStatus UNAUTHORIZED 401 Unauthorized | |
| UNORDERED_COLLECTION | back to summary |
|---|---|
| public static final HttpResponseStatus UNORDERED_COLLECTION 425 Unordered Collection (WebDAV, RFC3648) | |
| UNPROCESSABLE_ENTITY | back to summary |
|---|---|
| public static final HttpResponseStatus UNPROCESSABLE_ENTITY 422 Unprocessable Entity (WebDAV, RFC4918) | |
| UNSUPPORTED_MEDIA_TYPE | back to summary |
|---|---|
| public static final HttpResponseStatus UNSUPPORTED_MEDIA_TYPE 415 Unsupported Media Type | |
| UPGRADE_REQUIRED | back to summary |
|---|---|
| public static final HttpResponseStatus UPGRADE_REQUIRED 426 Upgrade Required (RFC2817) | |
| USE_PROXY | back to summary |
|---|---|
| public static final HttpResponseStatus USE_PROXY 305 Use Proxy (since HTTP/1.1) | |
| VARIANT_ALSO_NEGOTIATES | back to summary |
|---|---|
| public static final HttpResponseStatus VARIANT_ALSO_NEGOTIATES 506 Variant Also Negotiates (RFC2295) | |
| HttpResponseStatus | back to summary |
|---|---|
| private HttpResponseStatus(int code) Creates a new instance with the specified | |
| HttpResponseStatus | back to summary |
|---|---|
| public HttpResponseStatus(int code, String reasonPhrase) Creates a new instance with the specified | |
| HttpResponseStatus | back to summary |
|---|---|
| private HttpResponseStatus(int code, String reasonPhrase, boolean bytes) | |
| code | back to summary |
|---|---|
| public int code() Returns the code of this | |
| codeAsText | back to summary |
|---|---|
| public AsciiString codeAsText() Returns the status code as | |
| codeClass | back to summary |
|---|---|
| public HttpStatusClass codeClass() Returns the class of this | |
| compareTo | back to summary |
|---|---|
| public int compareTo(HttpResponseStatus o) Implements java. Equality of
| |
| encode | back to summary |
|---|---|
| pack-priv void encode(ByteBuf buf) | |
| equals | back to summary |
|---|---|
| public boolean equals(Object o) Overrides java. Equality of
| |
| hashCode | back to summary |
|---|---|
| public int hashCode() Overrides java. Doc from java. Returns a hash code value for the object. This method is
supported for the benefit of hash tables such as those provided by
The general contract of
| |
| newStatus | back to summary |
|---|---|
| private static HttpResponseStatus newStatus(int statusCode, String reasonPhrase) | |
| parseLine | back to summary |
|---|---|
| public static HttpResponseStatus parseLine(CharSequence line) Parses the specified HTTP status line into a
| |
| parseLine | back to summary |
|---|---|
| public static HttpResponseStatus parseLine(String line) Parses the specified HTTP status line into a
| |
| parseLine | back to summary |
|---|---|
| public static HttpResponseStatus parseLine(AsciiString line) Parses the specified HTTP status line into a
| |
| reasonPhrase | back to summary |
|---|---|
| public String reasonPhrase() Returns the reason phrase of this | |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Doc from java. Returns a string representation of the object. | |
| valueOf | back to summary |
|---|---|
| public static HttpResponseStatus valueOf(int code) Returns the | |
| valueOf | back to summary |
|---|---|
| public static HttpResponseStatus valueOf(int code, String reasonPhrase) Returns the
| |
| valueOf0 | back to summary |
|---|---|
| private static HttpResponseStatus valueOf0(int code) | |