Top Description Fields Constructors Methods
io.netty.handler.codec.dns

public Class DnsRecordType

extends Object
implements Comparable<DnsRecordType>
Class Inheritance
All Implemented Interfaces
java.lang.Comparable
Annotations
@UnstableApi
Imports
io.netty.util.collection.IntObjectHashMap, io.netty.util.internal.UnstableApi, java.util.HashMap, .Map

Represents a DNS record type.

Field Summary

Modifier and TypeField and Description
public static final DnsRecordType
A

Address record RFC 1035 Returns a 32-bit IPv4 address, most commonly used to map hostnames to an IP address of the host, but also used for DNSBLs, storing subnet masks in RFC 1101, etc.

public static final DnsRecordType
AAAA

IPv6 address record RFC 3596 Returns a 128-bit IPv6 address, most commonly used to map hostnames to an IP address of the host.

public static final DnsRecordType
AFSDB

AFS database record RFC 1183 Location of database servers of an AFS cell.

public static final DnsRecordType
ANY

All cached records RFC 1035 Returns all records of all types known to the name server.

public static final DnsRecordType
APL

Address Prefix List record RFC 3123 Specify lists of address ranges, e.g. in CIDR format, for various address families.

public static final DnsRecordType
AXFR

Authoritative Zone Transfer record RFC 1035 Transfer entire zone file from the master name server to secondary name servers.

private static final Map<String, DnsRecordType>
private static final IntObjectHashMap<DnsRecordType>
public static final DnsRecordType
CAA

Certification Authority Authorization record RFC 6844 CA pinning, constraining acceptable CAs for a host/domain.

public static final DnsRecordType
CERT

Certificate record RFC 4398 Stores PKIX, SPKI, PGP, etc.

public static final DnsRecordType
CNAME

Canonical name record RFC 1035 Alias of one name to another: the DNS lookup will continue by retrying the lookup with the new name.

public static final DnsRecordType
DHCID

DHCP identifier record RFC 4701 Used in conjunction with the FQDN option to DHCP.

public static final DnsRecordType
DLV

DNSSEC Lookaside Validation record RFC 4431 For publishing DNSSEC trust anchors outside of the DNS delegation chain.

public static final DnsRecordType
DNAME

Delegation name record RFC 2672 DNAME creates an alias for a name and all its subnames, unlike CNAME, which aliases only the exact name in its label.

public static final DnsRecordType
DNSKEY

DNS Key record RFC 4034 The key record used in DNSSEC.

public static final DnsRecordType
DS

Delegation signer record RFC 4034 The record used to identify the DNSSEC signing key of a delegated zone.

private static final String
public static final DnsRecordType
HIP

Host Identity Protocol record RFC 5205 Method of separating the end-point identifier and locator roles of IP addresses.

private final int
public static final DnsRecordType
IPSECKEY

IPsec Key record RFC 4025 Key record that can be used with IPsec.

public static final DnsRecordType
IXFR

Incremental Zone Transfer record RFC 1996 Requests a zone transfer of the given zone but only differences from a previous serial number.

public static final DnsRecordType
KEY

key record RFC 2535 and RFC 2930 Used only for SIG(0) (RFC 2931) and TKEY (RFC 2930).

public static final DnsRecordType
KX

Key eXchanger record RFC 2230 Used with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name.

public static final DnsRecordType
LOC

Location record RFC 1876 Specifies a geographical location associated with a domain name.

public static final DnsRecordType
MX

Mail exchange record RFC 1035 Maps a domain name to a list of message transfer agents for that domain.

private final String
public static final DnsRecordType
NAPTR

Naming Authority Pointer record RFC 3403 Allows regular expression based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc.

public static final DnsRecordType
NS

Name server record RFC 1035 Delegates a DNS zone to use the given authoritative name servers

public static final DnsRecordType
NSEC

Next-Secure record RFC 4034 Part of DNSSEC, used to prove a name does not exist.

public static final DnsRecordType
NSEC3

NSEC record version 3 RFC 5155 An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalking.

public static final DnsRecordType
NSEC3PARAM

NSEC3 parameters record RFC 5155 Parameter record for use with NSEC3.

public static final DnsRecordType
OPT

Option record RFC 2671 This is a pseudo DNS record type needed to support EDNS.

public static final DnsRecordType
PTR

Pointer record RFC 1035 Pointer to a canonical name.

public static final DnsRecordType
RP

Responsible person record RFC 1183 Information about the responsible person(s) for the domain.

public static final DnsRecordType
RRSIG

DNSSEC signature record RFC 4034 Signature for a DNSSEC-secured record set.

public static final DnsRecordType
SIG

Signature record RFC 2535 Signature record used in SIG(0) (RFC 2931) and TKEY (RFC 2930).

public static final DnsRecordType
SOA

Start of [a zone of] authority record RFC 1035 and RFC 2308 Specifies authoritative information about a DNS zone, including the primary name server, the email of the domain administrator, the domain serial number, and several timers relating to refreshing the zone.

public static final DnsRecordType
SPF

Sender Policy Framework record RFC 4408 Specified as part of the SPF protocol as an alternative to of storing SPF data in TXT records.

public static final DnsRecordType
SRV

Service locator RFC 2782 Generalized service location record, used for newer protocols instead of creating protocol-specific records such as MX.

public static final DnsRecordType
SSHFP

SSH Public Key Fingerprint record RFC 4255 Resource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host.

public static final DnsRecordType
TA

DNSSEC Trust Authorities record N/A Part of a deployment proposal for DNSSEC without a signed DNS root.

private String
public static final DnsRecordType
TKEY

Secret key record RFC 2930 A method of providing keying material to be used with TSIG that is encrypted under the public key in an accompanying KEY RR..

public static final DnsRecordType
TLSA

TLSA certificate association record RFC 6698 A record for DNS-based Authentication of Named Entities (DANE).

public static final DnsRecordType
TSIG

Transaction Signature record RFC 2845 Can be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name server similar to DNSSEC.

public static final DnsRecordType
TXT

Text record RFC 1035 Originally for arbitrary human-readable text in a DNS record.

Constructor Summary

AccessConstructor and Description
private
DnsRecordType(int intValue)

public
DnsRecordType(int intValue, String name)

Method Summary

Modifier and TypeMethod and Description
public int
compareTo(DnsRecordType
the object to be compared.
o
)

Implements java.lang.Comparable.compareTo.

Compares this object with the specified object for order.
public boolean
equals(Object
the reference object with which to compare.
o
)

Overrides java.lang.Object.equals.

Indicates whether some other object is "equal to" this one.
public int
hashCode()

Overrides java.lang.Object.hashCode.

Returns a hash code value for this object.
public int
intValue()

Returns the value of this DnsType as it appears in DNS protocol

public String
name()

Returns the name of this type, as seen in bind config files

public String
toString()

Overrides java.lang.Object.toString.

Returns a string representation of the object.
public static DnsRecordType
valueOf(int intValue)

public static DnsRecordType
Inherited from java.lang.Object:
clonefinalizegetClassnotifynotifyAllwaitwaitwait

Field Detail

Aback to summary
public static final DnsRecordType A

Address record RFC 1035 Returns a 32-bit IPv4 address, most commonly used to map hostnames to an IP address of the host, but also used for DNSBLs, storing subnet masks in RFC 1101, etc.

AAAAback to summary
public static final DnsRecordType AAAA

IPv6 address record RFC 3596 Returns a 128-bit IPv6 address, most commonly used to map hostnames to an IP address of the host.

AFSDBback to summary
public static final DnsRecordType AFSDB

AFS database record RFC 1183 Location of database servers of an AFS cell. This record is commonly used by AFS clients to contact AFS cells outside their local domain. A subtype of this record is used by the obsolete DCE/DFS file system.

ANYback to summary
public static final DnsRecordType ANY

All cached records RFC 1035 Returns all records of all types known to the name server. If the name server does not have any information on the name, the request will be forwarded on. The records returned may not be complete. For example, if there is both an A and an MX for a name, but the name server has only the A record cached, only the A record will be returned. Sometimes referred to as ANY, for example in Windows nslookup and Wireshark.

APLback to summary
public static final DnsRecordType APL

Address Prefix List record RFC 3123 Specify lists of address ranges, e.g. in CIDR format, for various address families. Experimental.

AXFRback to summary
public static final DnsRecordType AXFR

Authoritative Zone Transfer record RFC 1035 Transfer entire zone file from the master name server to secondary name servers.

BY_NAMEback to summary
private static final Map<String, DnsRecordType> BY_NAME
BY_TYPEback to summary
private static final IntObjectHashMap<DnsRecordType> BY_TYPE
CAAback to summary
public static final DnsRecordType CAA

Certification Authority Authorization record RFC 6844 CA pinning, constraining acceptable CAs for a host/domain.

CERTback to summary
public static final DnsRecordType CERT

Certificate record RFC 4398 Stores PKIX, SPKI, PGP, etc.

CNAMEback to summary
public static final DnsRecordType CNAME

Canonical name record RFC 1035 Alias of one name to another: the DNS lookup will continue by retrying the lookup with the new name.

DHCIDback to summary
public static final DnsRecordType DHCID

DHCP identifier record RFC 4701 Used in conjunction with the FQDN option to DHCP.

DLVback to summary
public static final DnsRecordType DLV

DNSSEC Lookaside Validation record RFC 4431 For publishing DNSSEC trust anchors outside of the DNS delegation chain. Uses the same format as the DS record. RFC 5074 describes a way of using these records.

DNAMEback to summary
public static final DnsRecordType DNAME

Delegation name record RFC 2672 DNAME creates an alias for a name and all its subnames, unlike CNAME, which aliases only the exact name in its label. Like the CNAME record, the DNS lookup will continue by retrying the lookup with the new name.

DNSKEYback to summary
public static final DnsRecordType DNSKEY

DNS Key record RFC 4034 The key record used in DNSSEC. Uses the same format as the KEY record.

DSback to summary
public static final DnsRecordType DS

Delegation signer record RFC 4034 The record used to identify the DNSSEC signing key of a delegated zone.

EXPECTEDback to summary
private static final String EXPECTED
HIPback to summary
public static final DnsRecordType HIP

Host Identity Protocol record RFC 5205 Method of separating the end-point identifier and locator roles of IP addresses.

intValueback to summary
private final int intValue
IPSECKEYback to summary
public static final DnsRecordType IPSECKEY

IPsec Key record RFC 4025 Key record that can be used with IPsec.

IXFRback to summary
public static final DnsRecordType IXFR

Incremental Zone Transfer record RFC 1996 Requests a zone transfer of the given zone but only differences from a previous serial number. This request may be ignored and a full (AXFR) sent in response if the authoritative server is unable to fulfill the request due to configuration or lack of required deltas.

KEYback to summary
public static final DnsRecordType KEY

key record RFC 2535 and RFC 2930 Used only for SIG(0) (RFC 2931) and TKEY (RFC 2930). RFC 3445 eliminated their use for application keys and limited their use to DNSSEC. RFC 3755 designates DNSKEY as the replacement within DNSSEC. RFC 4025 designates IPSECKEY as the replacement for use with IPsec.

KXback to summary
public static final DnsRecordType KX

Key eXchanger record RFC 2230 Used with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name. Note that this has nothing to do with DNS Security. It is Informational status, rather than being on the IETF standards-track. It has always had limited deployment, but is still in use.

LOCback to summary
public static final DnsRecordType LOC

Location record RFC 1876 Specifies a geographical location associated with a domain name.

MXback to summary
public static final DnsRecordType MX

Mail exchange record RFC 1035 Maps a domain name to a list of message transfer agents for that domain.

nameback to summary
private final String name
NAPTRback to summary
public static final DnsRecordType NAPTR

Naming Authority Pointer record RFC 3403 Allows regular expression based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc.

NSback to summary
public static final DnsRecordType NS

Name server record RFC 1035 Delegates a DNS zone to use the given authoritative name servers

NSECback to summary
public static final DnsRecordType NSEC

Next-Secure record RFC 4034 Part of DNSSEC, used to prove a name does not exist. Uses the same format as the (obsolete) NXT record.

NSEC3back to summary
public static final DnsRecordType NSEC3

NSEC record version 3 RFC 5155 An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalking.

NSEC3PARAMback to summary
public static final DnsRecordType NSEC3PARAM

NSEC3 parameters record RFC 5155 Parameter record for use with NSEC3.

OPTback to summary
public static final DnsRecordType OPT

Option record RFC 2671 This is a pseudo DNS record type needed to support EDNS.

PTRback to summary
public static final DnsRecordType PTR

Pointer record RFC 1035 Pointer to a canonical name. Unlike a CNAME, DNS processing does NOT proceed, just the name is returned. The most common use is for implementing reverse DNS lookups, but other uses include such things as DNS-SD.

RPback to summary
public static final DnsRecordType RP

Responsible person record RFC 1183 Information about the responsible person(s) for the domain. Usually an email address with the @ replaced by a .

RRSIGback to summary
public static final DnsRecordType RRSIG

DNSSEC signature record RFC 4034 Signature for a DNSSEC-secured record set. Uses the same format as the SIG record.

SIGback to summary
public static final DnsRecordType SIG

Signature record RFC 2535 Signature record used in SIG(0) (RFC 2931) and TKEY (RFC 2930). RFC 3755 designated RRSIG as the replacement for SIG for use within DNSSEC.

SOAback to summary
public static final DnsRecordType SOA

Start of [a zone of] authority record RFC 1035 and RFC 2308 Specifies authoritative information about a DNS zone, including the primary name server, the email of the domain administrator, the domain serial number, and several timers relating to refreshing the zone.

SPFback to summary
public static final DnsRecordType SPF

Sender Policy Framework record RFC 4408 Specified as part of the SPF protocol as an alternative to of storing SPF data in TXT records. Uses the same format as the earlier TXT record.

SRVback to summary
public static final DnsRecordType SRV

Service locator RFC 2782 Generalized service location record, used for newer protocols instead of creating protocol-specific records such as MX.

SSHFPback to summary
public static final DnsRecordType SSHFP

SSH Public Key Fingerprint record RFC 4255 Resource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host. RFC 6594 defines ECC SSH keys and SHA-256 hashes. See the IANA SSHFP RR parameters registry for details.

TAback to summary
public static final DnsRecordType TA

DNSSEC Trust Authorities record N/A Part of a deployment proposal for DNSSEC without a signed DNS root. See the IANA database and Weiler Spec for details. Uses the same format as the DS record.

textback to summary
private String text
TKEYback to summary
public static final DnsRecordType TKEY

Secret key record RFC 2930 A method of providing keying material to be used with TSIG that is encrypted under the public key in an accompanying KEY RR..

TLSAback to summary
public static final DnsRecordType TLSA

TLSA certificate association record RFC 6698 A record for DNS-based Authentication of Named Entities (DANE). RFC 6698 defines The TLSA DNS resource record is used to associate a TLS server certificate or public key with the domain name where the record is found, thus forming a 'TLSA certificate association'.

TSIGback to summary
public static final DnsRecordType TSIG

Transaction Signature record RFC 2845 Can be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name server similar to DNSSEC.

TXTback to summary
public static final DnsRecordType TXT

Text record RFC 1035 Originally for arbitrary human-readable text in a DNS record. Since the early 1990s, however, this record more often carries machine-readable data, such as specified by RFC 1464, opportunistic encryption, Sender Policy Framework, DKIM, DMARC DNS-SD, etc.

Constructor Detail

DnsRecordTypeback to summary
private DnsRecordType(int intValue)
DnsRecordTypeback to summary
public DnsRecordType(int intValue, String name)

Method Detail

compareToback to summary
public int compareTo(DnsRecordType o)

Implements java.lang.Comparable.compareTo.

Doc from java.lang.Comparable.compareTo.

Compares this object with the specified object for order. Returns a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

The implementor must ensure signum(x.compareTo(y)) == -signum(y.compareTo(x)) for all x and y. (This implies that x.compareTo(y) must throw an exception if and only if y.compareTo(x) throws an exception.)

The implementor must also ensure that the relation is transitive: (x.compareTo(y) > 0 && y.compareTo(z) > 0) implies x.compareTo(z) > 0.

Finally, the implementor must ensure that x.compareTo(y)==0 implies that signum(x.compareTo(z)) == signum(y.compareTo(z)), for all z.

Parameters
o:DnsRecordType

the object to be compared.

Returns:int

a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

Annotations
@Override
equalsback to summary
public boolean equals(Object o)

Overrides java.lang.Object.equals.

Doc from java.lang.Object.equals.

Indicates whether some other object is "equal to" this one.

The equals method implements an equivalence relation on non-null object references:

  • It is reflexive: for any non-null reference value x, x.equals(x) should return true.
  • It is symmetric: for any non-null reference values x and y, x.equals(y) should return true if and only if y.equals(x) returns true.
  • It is transitive: for any non-null reference values x, y, and z, if x.equals(y) returns true and y.equals(z) returns true, then x.equals(z) should return true.
  • It is consistent: for any non-null reference values x and y, multiple invocations of x.equals(y) consistently return true or consistently return false, provided no information used in equals comparisons on the objects is modified.
  • For any non-null reference value x, x.equals(null) should return false.

An equivalence relation partitions the elements it operates on into equivalence classes; all the members of an equivalence class are equal to each other. Members of an equivalence class are substitutable for each other, at least for some purposes.

Parameters
o:Object

the reference object with which to compare.

Returns:boolean

true if this object is the same as the obj argument; false otherwise.

Annotations
@Override
hashCodeback to summary
public int hashCode()

Overrides java.lang.Object.hashCode.

Doc from java.lang.Object.hashCode.

Returns a hash code value for this object. This method is supported for the benefit of hash tables such as those provided by java.util.HashMap.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.
Returns:int

a hash code value for this object

Annotations
@Override
intValueback to summary
public int intValue()

Returns the value of this DnsType as it appears in DNS protocol

nameback to summary
public String name()

Returns the name of this type, as seen in bind config files

toStringback to summary
public String toString()

Overrides java.lang.Object.toString.

Doc from java.lang.Object.toString.

Returns a string representation of the object.

Returns:String

a string representation of the object

Annotations
@Override
valueOfback to summary
public static DnsRecordType valueOf(int intValue)
valueOfback to summary
public static DnsRecordType valueOf(String name)