Top Description Fields Constructors Methods
io.netty.handler.codec.dns

public Class DnsResponseCode

extends Object
implements Comparable<DnsResponseCode>
Class Inheritance
All Implemented Interfaces
java.lang.Comparable
Annotations
@UnstableApi
Imports
io.netty.util.internal.UnstableApi

The DNS RCODE, as defined in RFC2929.

Field Summary

Modifier and TypeField and Description
public static final DnsResponseCode
BADALG

The 'BADALG' DNS RCODE (21), as defined in RFC2930.

public static final DnsResponseCode
BADKEY

The 'BADKEY' DNS RCODE (17), as defined in RFC2845.

public static final DnsResponseCode
BADMODE

The 'BADMODE' DNS RCODE (19), as defined in RFC2930.

public static final DnsResponseCode
BADNAME

The 'BADNAME' DNS RCODE (20), as defined in RFC2930.

public static final DnsResponseCode
BADTIME

The 'BADTIME' DNS RCODE (18), as defined in RFC2845.

public static final DnsResponseCode
BADVERS_OR_BADSIG

The 'BADVERS' or 'BADSIG' DNS RCODE (16), as defined in RFC2671 and RFC2845.

private final int
public static final DnsResponseCode
FORMERR

The 'FormErr' DNS RCODE (1), as defined in RFC1035.

private final String
public static final DnsResponseCode
NOERROR

The 'NoError' DNS RCODE (0), as defined in RFC1035.

public static final DnsResponseCode
NOTAUTH

The 'NotAuth' DNS RCODE (9), as defined in RFC2136.

public static final DnsResponseCode
NOTIMP

The 'NotImp' DNS RCODE (4), as defined in RFC1035.

public static final DnsResponseCode
NOTZONE

The 'NotZone' DNS RCODE (10), as defined in RFC2136.

public static final DnsResponseCode
NXDOMAIN

The 'NXDomain' DNS RCODE (3), as defined in RFC1035.

public static final DnsResponseCode
NXRRSET

The 'NXRRSet' DNS RCODE (8), as defined in RFC2136.

public static final DnsResponseCode
REFUSED

The 'Refused' DNS RCODE (5), as defined in RFC1035.

public static final DnsResponseCode
SERVFAIL

The 'ServFail' DNS RCODE (2), as defined in RFC1035.

private String
public static final DnsResponseCode
YXDOMAIN

The 'YXDomain' DNS RCODE (6), as defined in RFC2136.

public static final DnsResponseCode
YXRRSET

The 'YXRRSet' DNS RCODE (7), as defined in RFC2136.

Constructor Summary

AccessConstructor and Description
private
DnsResponseCode(int code)

public
DnsResponseCode(int code, String name)

Method Summary

Modifier and TypeMethod and Description
public int
compareTo(DnsResponseCode
the object to be compared.
o
)

Implements java.lang.Comparable.compareTo.

Compares this object with the specified object for order.
public boolean
equals(Object
the reference object with which to compare.
o
)

Overrides java.lang.Object.equals.

Equality of DnsResponseCode only depends on intValue().
public int
hashCode()

Overrides java.lang.Object.hashCode.

Returns a hash code value for this object.
public int
intValue()

Returns the error code for this DnsResponseCode.

public String
toString()

Overrides java.lang.Object.toString.

Returns a formatted error message for this DnsResponseCode.
public static DnsResponseCode

Returns:

the corresponding DnsResponseCode
valueOf
(int
the DNS RCODE
responseCode
)

Returns the DnsResponseCode that corresponds with the given responseCode.

Inherited from java.lang.Object:
clonefinalizegetClassnotifynotifyAllwaitwaitwait

Field Detail

BADALGback to summary
public static final DnsResponseCode BADALG

The 'BADALG' DNS RCODE (21), as defined in RFC2930.

BADKEYback to summary
public static final DnsResponseCode BADKEY

The 'BADKEY' DNS RCODE (17), as defined in RFC2845.

BADMODEback to summary
public static final DnsResponseCode BADMODE

The 'BADMODE' DNS RCODE (19), as defined in RFC2930.

BADNAMEback to summary
public static final DnsResponseCode BADNAME

The 'BADNAME' DNS RCODE (20), as defined in RFC2930.

BADTIMEback to summary
public static final DnsResponseCode BADTIME

The 'BADTIME' DNS RCODE (18), as defined in RFC2845.

BADVERS_OR_BADSIGback to summary
public static final DnsResponseCode BADVERS_OR_BADSIG

The 'BADVERS' or 'BADSIG' DNS RCODE (16), as defined in RFC2671 and RFC2845.

codeback to summary
private final int code
FORMERRback to summary
public static final DnsResponseCode FORMERR

The 'FormErr' DNS RCODE (1), as defined in RFC1035.

nameback to summary
private final String name
NOERRORback to summary
public static final DnsResponseCode NOERROR

The 'NoError' DNS RCODE (0), as defined in RFC1035.

NOTAUTHback to summary
public static final DnsResponseCode NOTAUTH

The 'NotAuth' DNS RCODE (9), as defined in RFC2136.

NOTIMPback to summary
public static final DnsResponseCode NOTIMP

The 'NotImp' DNS RCODE (4), as defined in RFC1035.

NOTZONEback to summary
public static final DnsResponseCode NOTZONE

The 'NotZone' DNS RCODE (10), as defined in RFC2136.

NXDOMAINback to summary
public static final DnsResponseCode NXDOMAIN

The 'NXDomain' DNS RCODE (3), as defined in RFC1035.

NXRRSETback to summary
public static final DnsResponseCode NXRRSET

The 'NXRRSet' DNS RCODE (8), as defined in RFC2136.

REFUSEDback to summary
public static final DnsResponseCode REFUSED

The 'Refused' DNS RCODE (5), as defined in RFC1035.

SERVFAILback to summary
public static final DnsResponseCode SERVFAIL

The 'ServFail' DNS RCODE (2), as defined in RFC1035.

textback to summary
private String text
YXDOMAINback to summary
public static final DnsResponseCode YXDOMAIN

The 'YXDomain' DNS RCODE (6), as defined in RFC2136.

YXRRSETback to summary
public static final DnsResponseCode YXRRSET

The 'YXRRSet' DNS RCODE (7), as defined in RFC2136.

Constructor Detail

DnsResponseCodeback to summary
private DnsResponseCode(int code)
DnsResponseCodeback to summary
public DnsResponseCode(int code, String name)

Method Detail

compareToback to summary
public int compareTo(DnsResponseCode o)

Implements java.lang.Comparable.compareTo.

Doc from java.lang.Comparable.compareTo.

Compares this object with the specified object for order. Returns a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

The implementor must ensure signum(x.compareTo(y)) == -signum(y.compareTo(x)) for all x and y. (This implies that x.compareTo(y) must throw an exception if and only if y.compareTo(x) throws an exception.)

The implementor must also ensure that the relation is transitive: (x.compareTo(y) > 0 && y.compareTo(z) > 0) implies x.compareTo(z) > 0.

Finally, the implementor must ensure that x.compareTo(y)==0 implies that signum(x.compareTo(z)) == signum(y.compareTo(z)), for all z.

Parameters
o:DnsResponseCode

the object to be compared.

Returns:int

a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object.

Annotations
@Override
equalsback to summary
public boolean equals(Object o)

Overrides java.lang.Object.equals.

Equality of DnsResponseCode only depends on intValue().

Parameters
o:Object

Doc from java.lang.Object.equals.

the reference object with which to compare.

Returns:boolean

Doc from java.lang.Object.equals.

true if this object is the same as the obj argument; false otherwise.

Annotations
@Override
hashCodeback to summary
public int hashCode()

Overrides java.lang.Object.hashCode.

Doc from java.lang.Object.hashCode.

Returns a hash code value for this object. This method is supported for the benefit of hash tables such as those provided by java.util.HashMap.

The general contract of hashCode is:

  • Whenever it is invoked on the same object more than once during an execution of a Java application, the hashCode method must consistently return the same integer, provided no information used in equals comparisons on the object is modified. This integer need not remain consistent from one execution of an application to another execution of the same application.
  • If two objects are equal according to the equals method, then calling the hashCode method on each of the two objects must produce the same integer result.
  • It is not required that if two objects are unequal according to the equals method, then calling the hashCode method on each of the two objects must produce distinct integer results. However, the programmer should be aware that producing distinct integer results for unequal objects may improve the performance of hash tables.
Returns:int

a hash code value for this object

Annotations
@Override
intValueback to summary
public int intValue()

Returns the error code for this DnsResponseCode.

toStringback to summary
public String toString()

Overrides java.lang.Object.toString.

Returns a formatted error message for this DnsResponseCode.

Returns:String

Doc from java.lang.Object.toString.

a string representation of the object

Annotations
@Override
valueOfback to summary
public static DnsResponseCode valueOf(int responseCode)

Returns the DnsResponseCode that corresponds with the given responseCode.

Parameters
responseCode:int

the DNS RCODE

Returns:DnsResponseCode

the corresponding DnsResponseCode