| Modifier and Type | Field and Description |
|---|---|
| public static final DnsRecordType | A
Address record RFC 1035 Returns a 32-bit IPv4 address, most commonly used to map hostnames to an IP address of the host, but also used for DNSBLs, storing subnet masks in RFC 1101, etc. |
| public static final DnsRecordType | AAAA
IPv6 address record RFC 3596 Returns a 128-bit IPv6 address, most commonly used to map hostnames to an IP address of the host. |
| public static final DnsRecordType | AFSDB
AFS database record RFC 1183 Location of database servers of an AFS cell. |
| public static final DnsRecordType | ANY
All cached records RFC 1035 Returns all records of all types known to the name server. |
| public static final DnsRecordType | APL
Address Prefix List record RFC 3123 Specify lists of address ranges, e.g. in CIDR format, for various address families. |
| public static final DnsRecordType | AXFR
Authoritative Zone Transfer record RFC 1035 Transfer entire zone file from the master name server to secondary name servers. |
| private static final Map | |
| private static final IntObjectHashMap | |
| public static final DnsRecordType | CAA
Certification Authority Authorization record RFC 6844 CA pinning, constraining acceptable CAs for a host/domain. |
| public static final DnsRecordType | CERT
Certificate record RFC 4398 Stores PKIX, SPKI, PGP, etc. |
| public static final DnsRecordType | CNAME
Canonical name record RFC 1035 Alias of one name to another: the DNS lookup will continue by retrying the lookup with the new name. |
| public static final DnsRecordType | DHCID
DHCP identifier record RFC 4701 Used in conjunction with the FQDN option to DHCP. |
| public static final DnsRecordType | DLV
DNSSEC Lookaside Validation record RFC 4431 For publishing DNSSEC trust anchors outside of the DNS delegation chain. |
| public static final DnsRecordType | DNAME
Delegation name record RFC 2672 DNAME creates an alias for a name and all its subnames, unlike CNAME, which aliases only the exact name in its label. |
| public static final DnsRecordType | DNSKEY
DNS Key record RFC 4034 The key record used in DNSSEC. |
| public static final DnsRecordType | DS
Delegation signer record RFC 4034 The record used to identify the DNSSEC signing key of a delegated zone. |
| private static final String | |
| public static final DnsRecordType | HIP
Host Identity Protocol record RFC 5205 Method of separating the end-point identifier and locator roles of IP addresses. |
| private final int | |
| public static final DnsRecordType | IPSECKEY
IPsec Key record RFC 4025 Key record that can be used with IPsec. |
| public static final DnsRecordType | IXFR
Incremental Zone Transfer record RFC 1996 Requests a zone transfer of the given zone but only differences from a previous serial number. |
| public static final DnsRecordType | KEY
key record RFC 2535 and RFC 2930 Used only for SIG(0) (RFC 2931) and TKEY (RFC 2930). |
| public static final DnsRecordType | KX
Key eXchanger record RFC 2230 Used with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name. |
| public static final DnsRecordType | LOC
Location record RFC 1876 Specifies a geographical location associated with a domain name. |
| public static final DnsRecordType | MX
Mail exchange record RFC 1035 Maps a domain name to a list of message transfer agents for that domain. |
| private final String | |
| public static final DnsRecordType | NAPTR
Naming Authority Pointer record RFC 3403 Allows regular expression based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc. |
| public static final DnsRecordType | NS
Name server record RFC 1035 Delegates a DNS zone to use the given authoritative name servers |
| public static final DnsRecordType | NSEC
Next-Secure record RFC 4034 Part of DNSSEC, used to prove a name does not exist. |
| public static final DnsRecordType | NSEC3
NSEC record version 3 RFC 5155 An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalking. |
| public static final DnsRecordType | NSEC3PARAM
NSEC3 parameters record RFC 5155 Parameter record for use with NSEC3. |
| public static final DnsRecordType | OPT
Option record RFC 2671 This is a pseudo DNS record type needed to support EDNS. |
| public static final DnsRecordType | PTR
Pointer record RFC 1035 Pointer to a canonical name. |
| public static final DnsRecordType | RP
Responsible person record RFC 1183 Information about the responsible person(s) for the domain. |
| public static final DnsRecordType | RRSIG
DNSSEC signature record RFC 4034 Signature for a DNSSEC-secured record set. |
| public static final DnsRecordType | SIG
Signature record RFC 2535 Signature record used in SIG(0) (RFC 2931) and TKEY (RFC 2930). |
| public static final DnsRecordType | SOA
Start of [a zone of] authority record RFC 1035 and RFC 2308 Specifies authoritative information about a DNS zone, including the primary name server, the email of the domain administrator, the domain serial number, and several timers relating to refreshing the zone. |
| public static final DnsRecordType | SPF
Sender Policy Framework record RFC 4408 Specified as part of the SPF protocol as an alternative to of storing SPF data in TXT records. |
| public static final DnsRecordType | SRV
Service locator RFC 2782 Generalized service location record, used for newer protocols instead of creating protocol-specific records such as MX. |
| public static final DnsRecordType | SSHFP
SSH Public Key Fingerprint record RFC 4255 Resource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host. |
| public static final DnsRecordType | TA
DNSSEC Trust Authorities record N/A Part of a deployment proposal for DNSSEC without a signed DNS root. |
| private String | |
| public static final DnsRecordType | TKEY
Secret key record RFC 2930 A method of providing keying material to be used with TSIG that is encrypted under the public key in an accompanying KEY RR.. |
| public static final DnsRecordType | TLSA
TLSA certificate association record RFC 6698 A record for DNS-based Authentication of Named Entities (DANE). |
| public static final DnsRecordType | TSIG
Transaction Signature record RFC 2845 Can be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name server similar to DNSSEC. |
| public static final DnsRecordType | TXT
Text record RFC 1035 Originally for arbitrary human-readable text in a DNS record. |
| Access | Constructor and Description |
|---|---|
| private | |
| public |
| Modifier and Type | Method and Description |
|---|---|
| public int | compareTo(DnsRecordType
the object to be compared. o)Implements java. |
| public boolean | equals(Object
the reference object with which to compare. o)Overrides java. |
| public int | |
| public int | |
| public String | |
| public String | |
| public static DnsRecordType | |
| public static DnsRecordType |
| A | back to summary |
|---|---|
| public static final DnsRecordType A Address record RFC 1035 Returns a 32-bit IPv4 address, most commonly used to map hostnames to an IP address of the host, but also used for DNSBLs, storing subnet masks in RFC 1101, etc. | |
| AAAA | back to summary |
|---|---|
| public static final DnsRecordType AAAA IPv6 address record RFC 3596 Returns a 128-bit IPv6 address, most commonly used to map hostnames to an IP address of the host. | |
| AFSDB | back to summary |
|---|---|
| public static final DnsRecordType AFSDB AFS database record RFC 1183 Location of database servers of an AFS cell. This record is commonly used by AFS clients to contact AFS cells outside their local domain. A subtype of this record is used by the obsolete DCE/DFS file system. | |
| ANY | back to summary |
|---|---|
| public static final DnsRecordType ANY All cached records RFC 1035 Returns all records of all types known to the name server. If the name server does not have any information on the name, the request will be forwarded on. The records returned may not be complete. For example, if there is both an A and an MX for a name, but the name server has only the A record cached, only the A record will be returned. Sometimes referred to as ANY, for example in Windows nslookup and Wireshark. | |
| APL | back to summary |
|---|---|
| public static final DnsRecordType APL Address Prefix List record RFC 3123 Specify lists of address ranges, e.g. in CIDR format, for various address families. Experimental. | |
| AXFR | back to summary |
|---|---|
| public static final DnsRecordType AXFR Authoritative Zone Transfer record RFC 1035 Transfer entire zone file from the master name server to secondary name servers. | |
| BY_NAME | back to summary |
|---|---|
| private static final Map<String, DnsRecordType> BY_NAME | |
| BY_TYPE | back to summary |
|---|---|
| private static final IntObjectHashMap<DnsRecordType> BY_TYPE | |
| CAA | back to summary |
|---|---|
| public static final DnsRecordType CAA Certification Authority Authorization record RFC 6844 CA pinning, constraining acceptable CAs for a host/domain. | |
| CERT | back to summary |
|---|---|
| public static final DnsRecordType CERT Certificate record RFC 4398 Stores PKIX, SPKI, PGP, etc. | |
| CNAME | back to summary |
|---|---|
| public static final DnsRecordType CNAME Canonical name record RFC 1035 Alias of one name to another: the DNS lookup will continue by retrying the lookup with the new name. | |
| DHCID | back to summary |
|---|---|
| public static final DnsRecordType DHCID DHCP identifier record RFC 4701 Used in conjunction with the FQDN option to DHCP. | |
| DLV | back to summary |
|---|---|
| public static final DnsRecordType DLV DNSSEC Lookaside Validation record RFC 4431 For publishing DNSSEC trust anchors outside of the DNS delegation chain. Uses the same format as the DS record. RFC 5074 describes a way of using these records. | |
| DNAME | back to summary |
|---|---|
| public static final DnsRecordType DNAME Delegation name record RFC 2672 DNAME creates an alias for a name and all its subnames, unlike CNAME, which aliases only the exact name in its label. Like the CNAME record, the DNS lookup will continue by retrying the lookup with the new name. | |
| DNSKEY | back to summary |
|---|---|
| public static final DnsRecordType DNSKEY DNS Key record RFC 4034 The key record used in DNSSEC. Uses the same format as the KEY record. | |
| DS | back to summary |
|---|---|
| public static final DnsRecordType DS Delegation signer record RFC 4034 The record used to identify the DNSSEC signing key of a delegated zone. | |
| EXPECTED | back to summary |
|---|---|
| private static final String EXPECTED | |
| HIP | back to summary |
|---|---|
| public static final DnsRecordType HIP Host Identity Protocol record RFC 5205 Method of separating the end-point identifier and locator roles of IP addresses. | |
| intValue | back to summary |
|---|---|
| private final int intValue | |
| IPSECKEY | back to summary |
|---|---|
| public static final DnsRecordType IPSECKEY IPsec Key record RFC 4025 Key record that can be used with IPsec. | |
| IXFR | back to summary |
|---|---|
| public static final DnsRecordType IXFR Incremental Zone Transfer record RFC 1996 Requests a zone transfer of the given zone but only differences from a previous serial number. This request may be ignored and a full (AXFR) sent in response if the authoritative server is unable to fulfill the request due to configuration or lack of required deltas. | |
| KEY | back to summary |
|---|---|
| public static final DnsRecordType KEY key record RFC 2535 and RFC 2930 Used only for SIG(0) (RFC 2931) and TKEY (RFC 2930). RFC 3445 eliminated their use for application keys and limited their use to DNSSEC. RFC 3755 designates DNSKEY as the replacement within DNSSEC. RFC 4025 designates IPSECKEY as the replacement for use with IPsec. | |
| KX | back to summary |
|---|---|
| public static final DnsRecordType KX Key eXchanger record RFC 2230 Used with some cryptographic systems (not including DNSSEC) to identify a key management agent for the associated domain-name. Note that this has nothing to do with DNS Security. It is Informational status, rather than being on the IETF standards-track. It has always had limited deployment, but is still in use. | |
| LOC | back to summary |
|---|---|
| public static final DnsRecordType LOC Location record RFC 1876 Specifies a geographical location associated with a domain name. | |
| MX | back to summary |
|---|---|
| public static final DnsRecordType MX Mail exchange record RFC 1035 Maps a domain name to a list of message transfer agents for that domain. | |
| name | back to summary |
|---|---|
| private final String name | |
| NAPTR | back to summary |
|---|---|
| public static final DnsRecordType NAPTR Naming Authority Pointer record RFC 3403 Allows regular expression based rewriting of domain names which can then be used as URIs, further domain names to lookups, etc. | |
| NS | back to summary |
|---|---|
| public static final DnsRecordType NS Name server record RFC 1035 Delegates a DNS zone to use the given authoritative name servers | |
| NSEC | back to summary |
|---|---|
| public static final DnsRecordType NSEC Next-Secure record RFC 4034 Part of DNSSEC, used to prove a name does not exist. Uses the same format as the (obsolete) NXT record. | |
| NSEC3 | back to summary |
|---|---|
| public static final DnsRecordType NSEC3 NSEC record version 3 RFC 5155 An extension to DNSSEC that allows proof of nonexistence for a name without permitting zonewalking. | |
| NSEC3PARAM | back to summary |
|---|---|
| public static final DnsRecordType NSEC3PARAM NSEC3 parameters record RFC 5155 Parameter record for use with NSEC3. | |
| OPT | back to summary |
|---|---|
| public static final DnsRecordType OPT Option record RFC 2671 This is a pseudo DNS record type needed to support EDNS. | |
| PTR | back to summary |
|---|---|
| public static final DnsRecordType PTR Pointer record RFC 1035 Pointer to a canonical name. Unlike a CNAME, DNS processing does NOT proceed, just the name is returned. The most common use is for implementing reverse DNS lookups, but other uses include such things as DNS-SD. | |
| RP | back to summary |
|---|---|
| public static final DnsRecordType RP Responsible person record RFC 1183 Information about the responsible person(s) for the domain. Usually an email address with the @ replaced by a . | |
| RRSIG | back to summary |
|---|---|
| public static final DnsRecordType RRSIG DNSSEC signature record RFC 4034 Signature for a DNSSEC-secured record set. Uses the same format as the SIG record. | |
| SIG | back to summary |
|---|---|
| public static final DnsRecordType SIG Signature record RFC 2535 Signature record used in SIG(0) (RFC 2931) and TKEY (RFC 2930). RFC 3755 designated RRSIG as the replacement for SIG for use within DNSSEC. | |
| SOA | back to summary |
|---|---|
| public static final DnsRecordType SOA Start of [a zone of] authority record RFC 1035 and RFC 2308 Specifies authoritative information about a DNS zone, including the primary name server, the email of the domain administrator, the domain serial number, and several timers relating to refreshing the zone. | |
| SPF | back to summary |
|---|---|
| public static final DnsRecordType SPF Sender Policy Framework record RFC 4408 Specified as part of the SPF protocol as an alternative to of storing SPF data in TXT records. Uses the same format as the earlier TXT record. | |
| SRV | back to summary |
|---|---|
| public static final DnsRecordType SRV Service locator RFC 2782 Generalized service location record, used for newer protocols instead of creating protocol-specific records such as MX. | |
| SSHFP | back to summary |
|---|---|
| public static final DnsRecordType SSHFP SSH Public Key Fingerprint record RFC 4255 Resource record for publishing SSH public host key fingerprints in the DNS System, in order to aid in verifying the authenticity of the host. RFC 6594 defines ECC SSH keys and SHA-256 hashes. See the IANA SSHFP RR parameters registry for details. | |
| TA | back to summary |
|---|---|
| public static final DnsRecordType TA DNSSEC Trust Authorities record N/A Part of a deployment proposal for DNSSEC without a signed DNS root. See the IANA database and Weiler Spec for details. Uses the same format as the DS record. | |
| text | back to summary |
|---|---|
| private String text | |
| TKEY | back to summary |
|---|---|
| public static final DnsRecordType TKEY Secret key record RFC 2930 A method of providing keying material to be used with TSIG that is encrypted under the public key in an accompanying KEY RR.. | |
| TLSA | back to summary |
|---|---|
| public static final DnsRecordType TLSA TLSA certificate association record RFC 6698 A record for DNS-based Authentication of Named Entities (DANE). RFC 6698 defines The TLSA DNS resource record is used to associate a TLS server certificate or public key with the domain name where the record is found, thus forming a 'TLSA certificate association'. | |
| TSIG | back to summary |
|---|---|
| public static final DnsRecordType TSIG Transaction Signature record RFC 2845 Can be used to authenticate dynamic updates as coming from an approved client, or to authenticate responses as coming from an approved recursive name server similar to DNSSEC. | |
| TXT | back to summary |
|---|---|
| public static final DnsRecordType TXT Text record RFC 1035 Originally for arbitrary human-readable text in a DNS record. Since the early 1990s, however, this record more often carries machine-readable data, such as specified by RFC 1464, opportunistic encryption, Sender Policy Framework, DKIM, DMARC DNS-SD, etc. | |
| DnsRecordType | back to summary |
|---|---|
| private DnsRecordType(int intValue) | |
| DnsRecordType | back to summary |
|---|---|
| public DnsRecordType(int intValue, String name) | |
| compareTo | back to summary |
|---|---|
| public int compareTo(DnsRecordType o) Implements java. Doc from java. Compares this object with the specified object for order. Returns a negative integer, zero, or a positive integer as this object is less than, equal to, or greater than the specified object. The implementor must ensure The implementor must also ensure that the relation is transitive:
Finally, the implementor must ensure that
| |
| equals | back to summary |
|---|---|
| public boolean equals(Object o) Overrides java. Doc from java. Indicates whether some other object is "equal to" this one.
The
An equivalence relation partitions the elements it operates on into equivalence classes; all the members of an equivalence class are equal to each other. Members of an equivalence class are substitutable for each other, at least for some purposes. | |
| hashCode | back to summary |
|---|---|
| public int hashCode() Overrides java. Doc from java. Returns a hash code value for the object. This method is
supported for the benefit of hash tables such as those provided by
The general contract of
| |
| intValue | back to summary |
|---|---|
| public int intValue() Returns the value of this DnsType as it appears in DNS protocol | |
| name | back to summary |
|---|---|
| public String name() Returns the name of this type, as seen in bind config files | |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Doc from java. Returns a string representation of the object. | |
| valueOf | back to summary |
|---|---|
| public static DnsRecordType valueOf(int intValue) | |
| valueOf | back to summary |
|---|---|
| public static DnsRecordType valueOf(String name) | |