| Modifier and Type | Field and Description |
|---|---|
| public static final String | BASIC
Basic authentication scheme (considered inherently insecure without TLS, but most widely supported). |
| public static final String | BEARER
Bearer authentication scheme (should be used with TLS). |
| public static final String | DIGEST
Digest authentication scheme. |
| public static final String | KERBEROS
Kerberos authentication scheme as defined in RFC 4120. |
| public static final String | NTLM
The NTLM authentication scheme is a proprietary Microsoft Windows authentication protocol as defined in [MS-NLMP]. |
| public static final String | SPNEGO
SPNEGO authentication scheme as defined in RFC 4559 and RFC 4178. |
| Access | Constructor and Description |
|---|---|
| private |
| BASIC | back to summary |
|---|---|
| public static final String BASIC Basic authentication scheme (considered inherently insecure without TLS, but most widely supported). | |
| BEARER | back to summary |
|---|---|
| public static final String BEARER Bearer authentication scheme (should be used with TLS). | |
| DIGEST | back to summary |
|---|---|
| public static final String DIGEST Digest authentication scheme. | |
| KERBEROS | back to summary |
|---|---|
| public static final String KERBEROS
Deprecated Do not use. The GGS based experimental authentication schemes are no longer supported. Consider using Basic or Bearer authentication with TLS instead. Kerberos authentication scheme as defined in RFC 4120. | |
| NTLM | back to summary |
|---|---|
| public static final String NTLM
Deprecated Do not use. the NTLM authentication scheme is no longer supported. Consider using Basic or Bearer authentication with TLS instead. The NTLM authentication scheme is a proprietary Microsoft Windows authentication protocol as defined in [MS-NLMP]. | |
| SPNEGO | back to summary |
|---|---|
| public static final String SPNEGO
Deprecated Do not use. The GGS based experimental authentication schemes are no longer supported. Consider using Basic or Bearer authentication with TLS instead. SPNEGO authentication scheme as defined in RFC 4559 and RFC 4178. | |
| StandardAuthScheme | back to summary |
|---|---|
| private StandardAuthScheme() | |