org.apache.hc.core5.http.io.entity.HttpEntityWrapper responsible for
handling deflate Content Coded responses. In RFC2616 terms, deflate
means a zlib stream as defined in RFC1950. Some server
implementations have misinterpreted RFC2616 to mean that a
deflate stream as defined in RFC1951 should be used
(or maybe they did that since that's how IE behaves?). It's confusing
that deflate in HTTP 1.1 means zlib streams
rather than deflate streams. We handle both types in here,
since that's what is seen on the internet. Moral - prefer
gzip!
GzipDecompressingEntity
| Access | Constructor and Description |
|---|---|
| public | DeflateDecompressingEntity(final HttpEntity
a non-null entity)HttpEntity to be wrappedCreates a new |
| DeflateDecompressingEntity | back to summary |
|---|---|
| public DeflateDecompressingEntity(final HttpEntity entity) Creates a new
| |