Top Description Fields Constructors Methods
org.apache.hc.client5.http.entity.mime

public final Enum HttpMultipartMode

extends Enum<HttpMultipartMode>
Class Inheritance

MIME compliance mode.
Since
4.0

Field Summary

Modifier and TypeField and Description
public static final HttpMultipartMode
EXTENDED

Extended MIME specification conformance.

public static final HttpMultipartMode
LEGACY

Legacy compatibility mode.

public static final HttpMultipartMode
STRICT

Strict MIME specification conformance.

Constructor Summary

AccessConstructor and Description
private

Method Summary

Modifier and TypeMethod and Description
public static HttpMultipartMode
public static HttpMultipartMode[]
Inherited from java.lang.Enum:
clonecompareTodescribeConstableequalsfinalizegetDeclaringClasshashCodenameordinaltoStringvalueOf

Field Detail

EXTENDEDback to summary
public static final HttpMultipartMode EXTENDED

Extended MIME specification conformance.

In this mode header field values may contain international UTF-8 encoded characters.

Presently conforms to RFC 6532 and RFC 7578.

LEGACYback to summary
public static final HttpMultipartMode LEGACY

Legacy compatibility mode.

In this mode only the most essential fields are generated such as Content-Type and Content-Disposition.

STRICTback to summary
public static final HttpMultipartMode STRICT

Strict MIME specification conformance.

Presently conforms to RFC 822, RFC 2045, RFC 2046.

Constructor Detail

HttpMultipartModeback to summary
private HttpMultipartMode()

Method Detail

valueOfback to summary
public static HttpMultipartMode valueOf(String name)
valuesback to summary
public static HttpMultipartMode[] values()