| Modifier and Type | Field and Description |
|---|---|
| public static final String | BASIC
Basic authentication scheme as defined in RFC 2617 (considered inherently insecure, but most widely supported). |
| public static final String | CREDSSP
CredSSP authentication scheme defined in [MS-CSSP]. |
| public static final String | DIGEST
Digest authentication scheme as defined in RFC 2617. |
| public static final String | KERBEROS
Kerberos authentication scheme as defined in RFC 4120 (considered to be the most secure among currently supported authentication schemes). |
| public static final String | NTLM
The NTLM authentication scheme is a proprietary Microsoft Windows authentication protocol as defined in [MS-NLMP]. |
| public static final String | SPNEGO
SPNEGO authentication scheme as defined in RFC 4559 and RFC 4178 (considered to be the most secure among currently supported authentication schemes if Kerberos is selected). |
| Access | Constructor and Description |
|---|---|
| private |
| BASIC | back to summary |
|---|---|
| public static final String BASIC Basic authentication scheme as defined in RFC 2617 (considered inherently insecure, but most widely supported). | |
| CREDSSP | back to summary |
|---|---|
| public static final String CREDSSP CredSSP authentication scheme defined in [MS-CSSP]. | |
| DIGEST | back to summary |
|---|---|
| public static final String DIGEST Digest authentication scheme as defined in RFC 2617. | |
| KERBEROS | back to summary |
|---|---|
| public static final String KERBEROS Kerberos authentication scheme as defined in RFC 4120 (considered to be the most secure among currently supported authentication schemes). | |
| NTLM | back to summary |
|---|---|
| public static final String NTLM The NTLM authentication scheme is a proprietary Microsoft Windows authentication protocol as defined in [MS-NLMP]. | |
| SPNEGO | back to summary |
|---|---|
| public static final String SPNEGO SPNEGO authentication scheme as defined in RFC 4559 and RFC 4178 (considered to be the most secure among currently supported authentication schemes if Kerberos is selected). | |
| AuthSchemes | back to summary |
|---|---|
| private AuthSchemes() | |