Top Description Classes
[default module]

Package org.apache.http.impl.cookie


Default implementations of standard and common HTTP state management policies.

Class Summary

Modifier and TypeClass and Description
public abstract class
public abstract class
AbstractCookieSpec

Abstract cookie specification which can delegate the job of parsing, validation or matching cookie attributes to a number of arbitrary CookieAttributeHandlers.

public class
BasicClientCookie

Default implementation of SetCookie.

public class
BasicClientCookie2

Default implementation of SetCookie2.

public class
public class
public class
public class
public class
public class
public class
BestMatchSpec

'Meta' cookie specification that picks up a cookie policy based on the format of cookies sent with the HTTP response.
public class
public class
BrowserCompatSpec

Cookie specification that strives to closely mimic (mis)behavior of common web browser applications such as Microsoft Internet Explorer and Mozilla FireFox.
public class
public class
BrowserCompatVersionAttributeHandler

Deprecated (4.4) no longer used.
"Version" cookie attribute handler for BrowserCompat cookie spec.
public abstract class
CookieSpecBase

Cookie management functions shared by all specification.

public class
DateParseException

Deprecated (4.3) no longer used.
An exception to indicate an error parsing a date string.
public class
DateUtils

A utility class for parsing and formatting HTTP dates as used in cookies and other headers.
public class
DefaultCookieSpec

Default cookie specification that picks up the best matching cookie policy based on the format of cookies sent with the HTTP response.

public class
public class
IgnoreSpec

CookieSpec that ignores all cookies

public class
IgnoreSpecFactory

CookieSpecProvider implementation that ignores all cookies.
public class
IgnoreSpecProvider

org.apache.http.cookie.CookieSpecProvider implementation that ignores all cookies.

public class
public class
public class
public class
public class
NetscapeDraftSpec

This org.apache.http.cookie.CookieSpec implementation conforms to the original draft specification published by Netscape Communications.

public class
public class
public class
PublicSuffixDomainFilter

Wraps a org.apache.http.cookie.CookieAttributeHandler and leverages its match method to never match a suffix from a black list.

public class
PublicSuffixFilter

Wraps a CookieAttributeHandler and leverages its match method to never match a suffix from a black list.
public class
PublicSuffixListParser

Parses the list from publicsuffix.org and configures a PublicSuffixFilter.
public class
public class
RFC2109Spec

RFC 2109 compliant org.apache.http.cookie.CookieSpec implementation.

public class
public class
public class
public class
RFC2965CommentUrlAttributeHandler

"CommentURL" cookie attribute handler for RFC 2965 cookie spec.

public class
RFC2965DiscardAttributeHandler

"Discard" cookie attribute handler for RFC 2965 cookie spec.

public class
RFC2965DomainAttributeHandler

"Domain" cookie attribute handler for RFC 2965 cookie spec.

public class
RFC2965PortAttributeHandler

"Port" cookie attribute handler for RFC 2965 cookie spec.

public class
RFC2965Spec

RFC 2965 compliant org.apache.http.cookie.CookieSpec implementation.

public class
public class
public class
RFC2965VersionAttributeHandler

"Version" cookie attribute handler for RFC 2965 cookie spec.

public class
RFC6265CookieSpec

Cookie management functions shared by RFC C6265 compliant specification.

pack-priv class
public class
RFC6265CookieSpecProvider

org.apache.http.cookie.CookieSpecProvider implementation that provides an instance of RFC 6265 conformant cookie policy.

public class
RFC6265LaxSpec

Standard org.apache.http.cookie.CookieSpec implementation that enforces a more relaxed interpretation of the HTTP state management specification (RFC 6265, section 5) for interoperability with existing servers that do not conform to the well behaved profile (RFC 6265, section 4).

public class
RFC6265StrictSpec

Standard org.apache.http.cookie.CookieSpec implementation that enforces syntax and semantics of the well-behaved profile of the HTTP state management specification (RFC 6265, section 4).