Top Description Fields Constructors Methods
org.apache.http

public final Class HttpHeaders

extends Object
Class Inheritance

Constants enumerating the HTTP headers. All headers defined in RFC1945 (HTTP/1.0), RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are listed.
Since
4.1

Field Summary

Modifier and TypeField and Description
public static final String
ACCEPT

RFC 2616 (HTTP/1.1) Section 14.1

public static final String
ACCEPT_CHARSET

RFC 2616 (HTTP/1.1) Section 14.2

public static final String
ACCEPT_ENCODING

RFC 2616 (HTTP/1.1) Section 14.3

public static final String
ACCEPT_LANGUAGE

RFC 2616 (HTTP/1.1) Section 14.4

public static final String
ACCEPT_RANGES

RFC 2616 (HTTP/1.1) Section 14.5

public static final String
AGE

RFC 2616 (HTTP/1.1) Section 14.6

public static final String
ALLOW

RFC 1945 (HTTP/1.0) Section 10.1, RFC 2616 (HTTP/1.1) Section 14.7

public static final String
AUTHORIZATION

RFC 1945 (HTTP/1.0) Section 10.2, RFC 2616 (HTTP/1.1) Section 14.8

public static final String
CACHE_CONTROL

RFC 2616 (HTTP/1.1) Section 14.9

public static final String
CONNECTION

RFC 2616 (HTTP/1.1) Section 14.10

public static final String
CONTENT_ENCODING

RFC 1945 (HTTP/1.0) Section 10.3, RFC 2616 (HTTP/1.1) Section 14.11

public static final String
CONTENT_LANGUAGE

RFC 2616 (HTTP/1.1) Section 14.12

public static final String
CONTENT_LENGTH

RFC 1945 (HTTP/1.0) Section 10.4, RFC 2616 (HTTP/1.1) Section 14.13

public static final String
CONTENT_LOCATION

RFC 2616 (HTTP/1.1) Section 14.14

public static final String
CONTENT_MD5

RFC 2616 (HTTP/1.1) Section 14.15

public static final String
CONTENT_RANGE

RFC 2616 (HTTP/1.1) Section 14.16

public static final String
CONTENT_TYPE

RFC 1945 (HTTP/1.0) Section 10.5, RFC 2616 (HTTP/1.1) Section 14.17

public static final String
DATE

RFC 1945 (HTTP/1.0) Section 10.6, RFC 2616 (HTTP/1.1) Section 14.18

public static final String
DAV

RFC 2518 (WevDAV) Section 9.1

public static final String
DEPTH

RFC 2518 (WevDAV) Section 9.2

public static final String
DESTINATION

RFC 2518 (WevDAV) Section 9.3

public static final String
ETAG

RFC 2616 (HTTP/1.1) Section 14.19

public static final String
EXPECT

RFC 2616 (HTTP/1.1) Section 14.20

public static final String
EXPIRES

RFC 1945 (HTTP/1.0) Section 10.7, RFC 2616 (HTTP/1.1) Section 14.21

public static final String
FROM

RFC 1945 (HTTP/1.0) Section 10.8, RFC 2616 (HTTP/1.1) Section 14.22

public static final String
HOST

RFC 2616 (HTTP/1.1) Section 14.23

public static final String
IF

RFC 2518 (WevDAV) Section 9.4

public static final String
IF_MATCH

RFC 2616 (HTTP/1.1) Section 14.24

public static final String
IF_MODIFIED_SINCE

RFC 1945 (HTTP/1.0) Section 10.9, RFC 2616 (HTTP/1.1) Section 14.25

public static final String
IF_NONE_MATCH

RFC 2616 (HTTP/1.1) Section 14.26

public static final String
IF_RANGE

RFC 2616 (HTTP/1.1) Section 14.27

public static final String
IF_UNMODIFIED_SINCE

RFC 2616 (HTTP/1.1) Section 14.28

public static final String
LAST_MODIFIED

RFC 1945 (HTTP/1.0) Section 10.10, RFC 2616 (HTTP/1.1) Section 14.29

public static final String
LOCATION

RFC 1945 (HTTP/1.0) Section 10.11, RFC 2616 (HTTP/1.1) Section 14.30

public static final String
LOCK_TOKEN

RFC 2518 (WevDAV) Section 9.5

public static final String
MAX_FORWARDS

RFC 2616 (HTTP/1.1) Section 14.31

public static final String
OVERWRITE

RFC 2518 (WevDAV) Section 9.6

public static final String
PRAGMA

RFC 1945 (HTTP/1.0) Section 10.12, RFC 2616 (HTTP/1.1) Section 14.32

public static final String
PROXY_AUTHENTICATE

RFC 2616 (HTTP/1.1) Section 14.33

public static final String
PROXY_AUTHORIZATION

RFC 2616 (HTTP/1.1) Section 14.34

public static final String
RANGE

RFC 2616 (HTTP/1.1) Section 14.35

public static final String
REFERER

RFC 1945 (HTTP/1.0) Section 10.13, RFC 2616 (HTTP/1.1) Section 14.36

public static final String
RETRY_AFTER

RFC 2616 (HTTP/1.1) Section 14.37

public static final String
SERVER

RFC 1945 (HTTP/1.0) Section 10.14, RFC 2616 (HTTP/1.1) Section 14.38

public static final String
STATUS_URI

RFC 2518 (WevDAV) Section 9.7

public static final String
TE

RFC 2616 (HTTP/1.1) Section 14.39

public static final String
TIMEOUT

RFC 2518 (WevDAV) Section 9.8

public static final String
TRAILER

RFC 2616 (HTTP/1.1) Section 14.40

public static final String
TRANSFER_ENCODING

RFC 2616 (HTTP/1.1) Section 14.41

public static final String
UPGRADE

RFC 2616 (HTTP/1.1) Section 14.42

public static final String
USER_AGENT

RFC 1945 (HTTP/1.0) Section 10.15, RFC 2616 (HTTP/1.1) Section 14.43

public static final String
VARY

RFC 2616 (HTTP/1.1) Section 14.44

public static final String
VIA

RFC 2616 (HTTP/1.1) Section 14.45

public static final String
WARNING

RFC 2616 (HTTP/1.1) Section 14.46

public static final String
WWW_AUTHENTICATE

RFC 1945 (HTTP/1.0) Section 10.16, RFC 2616 (HTTP/1.1) Section 14.47

Constructor Summary

AccessConstructor and Description
private

Method Summary

Inherited from java.lang.Object:
cloneequalsfinalizegetClasshashCodenotifynotifyAlltoStringwaitwaitwait

Field Detail

ACCEPTback to summary
public static final String ACCEPT

RFC 2616 (HTTP/1.1) Section 14.1

ACCEPT_CHARSETback to summary
public static final String ACCEPT_CHARSET

RFC 2616 (HTTP/1.1) Section 14.2

ACCEPT_ENCODINGback to summary
public static final String ACCEPT_ENCODING

RFC 2616 (HTTP/1.1) Section 14.3

ACCEPT_LANGUAGEback to summary
public static final String ACCEPT_LANGUAGE

RFC 2616 (HTTP/1.1) Section 14.4

ACCEPT_RANGESback to summary
public static final String ACCEPT_RANGES

RFC 2616 (HTTP/1.1) Section 14.5

AGEback to summary
public static final String AGE

RFC 2616 (HTTP/1.1) Section 14.6

ALLOWback to summary
public static final String ALLOW

RFC 1945 (HTTP/1.0) Section 10.1, RFC 2616 (HTTP/1.1) Section 14.7

AUTHORIZATIONback to summary
public static final String AUTHORIZATION

RFC 1945 (HTTP/1.0) Section 10.2, RFC 2616 (HTTP/1.1) Section 14.8

CACHE_CONTROLback to summary
public static final String CACHE_CONTROL

RFC 2616 (HTTP/1.1) Section 14.9

CONNECTIONback to summary
public static final String CONNECTION

RFC 2616 (HTTP/1.1) Section 14.10

CONTENT_ENCODINGback to summary
public static final String CONTENT_ENCODING

RFC 1945 (HTTP/1.0) Section 10.3, RFC 2616 (HTTP/1.1) Section 14.11

CONTENT_LANGUAGEback to summary
public static final String CONTENT_LANGUAGE

RFC 2616 (HTTP/1.1) Section 14.12

CONTENT_LENGTHback to summary
public static final String CONTENT_LENGTH

RFC 1945 (HTTP/1.0) Section 10.4, RFC 2616 (HTTP/1.1) Section 14.13

CONTENT_LOCATIONback to summary
public static final String CONTENT_LOCATION

RFC 2616 (HTTP/1.1) Section 14.14

CONTENT_MD5back to summary
public static final String CONTENT_MD5

RFC 2616 (HTTP/1.1) Section 14.15

CONTENT_RANGEback to summary
public static final String CONTENT_RANGE

RFC 2616 (HTTP/1.1) Section 14.16

CONTENT_TYPEback to summary
public static final String CONTENT_TYPE

RFC 1945 (HTTP/1.0) Section 10.5, RFC 2616 (HTTP/1.1) Section 14.17

DATEback to summary
public static final String DATE

RFC 1945 (HTTP/1.0) Section 10.6, RFC 2616 (HTTP/1.1) Section 14.18

DAVback to summary
public static final String DAV

RFC 2518 (WevDAV) Section 9.1

DEPTHback to summary
public static final String DEPTH

RFC 2518 (WevDAV) Section 9.2

DESTINATIONback to summary
public static final String DESTINATION

RFC 2518 (WevDAV) Section 9.3

ETAGback to summary
public static final String ETAG

RFC 2616 (HTTP/1.1) Section 14.19

EXPECTback to summary
public static final String EXPECT

RFC 2616 (HTTP/1.1) Section 14.20

EXPIRESback to summary
public static final String EXPIRES

RFC 1945 (HTTP/1.0) Section 10.7, RFC 2616 (HTTP/1.1) Section 14.21

FROMback to summary
public static final String FROM

RFC 1945 (HTTP/1.0) Section 10.8, RFC 2616 (HTTP/1.1) Section 14.22

HOSTback to summary
public static final String HOST

RFC 2616 (HTTP/1.1) Section 14.23

IFback to summary
public static final String IF

RFC 2518 (WevDAV) Section 9.4

IF_MATCHback to summary
public static final String IF_MATCH

RFC 2616 (HTTP/1.1) Section 14.24

IF_MODIFIED_SINCEback to summary
public static final String IF_MODIFIED_SINCE

RFC 1945 (HTTP/1.0) Section 10.9, RFC 2616 (HTTP/1.1) Section 14.25

IF_NONE_MATCHback to summary
public static final String IF_NONE_MATCH

RFC 2616 (HTTP/1.1) Section 14.26

IF_RANGEback to summary
public static final String IF_RANGE

RFC 2616 (HTTP/1.1) Section 14.27

IF_UNMODIFIED_SINCEback to summary
public static final String IF_UNMODIFIED_SINCE

RFC 2616 (HTTP/1.1) Section 14.28

LAST_MODIFIEDback to summary
public static final String LAST_MODIFIED

RFC 1945 (HTTP/1.0) Section 10.10, RFC 2616 (HTTP/1.1) Section 14.29

LOCATIONback to summary
public static final String LOCATION

RFC 1945 (HTTP/1.0) Section 10.11, RFC 2616 (HTTP/1.1) Section 14.30

LOCK_TOKENback to summary
public static final String LOCK_TOKEN

RFC 2518 (WevDAV) Section 9.5

MAX_FORWARDSback to summary
public static final String MAX_FORWARDS

RFC 2616 (HTTP/1.1) Section 14.31

OVERWRITEback to summary
public static final String OVERWRITE

RFC 2518 (WevDAV) Section 9.6

PRAGMAback to summary
public static final String PRAGMA

RFC 1945 (HTTP/1.0) Section 10.12, RFC 2616 (HTTP/1.1) Section 14.32

PROXY_AUTHENTICATEback to summary
public static final String PROXY_AUTHENTICATE

RFC 2616 (HTTP/1.1) Section 14.33

PROXY_AUTHORIZATIONback to summary
public static final String PROXY_AUTHORIZATION

RFC 2616 (HTTP/1.1) Section 14.34

RANGEback to summary
public static final String RANGE

RFC 2616 (HTTP/1.1) Section 14.35

REFERERback to summary
public static final String REFERER

RFC 1945 (HTTP/1.0) Section 10.13, RFC 2616 (HTTP/1.1) Section 14.36

RETRY_AFTERback to summary
public static final String RETRY_AFTER

RFC 2616 (HTTP/1.1) Section 14.37

SERVERback to summary
public static final String SERVER

RFC 1945 (HTTP/1.0) Section 10.14, RFC 2616 (HTTP/1.1) Section 14.38

STATUS_URIback to summary
public static final String STATUS_URI

RFC 2518 (WevDAV) Section 9.7

TEback to summary
public static final String TE

RFC 2616 (HTTP/1.1) Section 14.39

TIMEOUTback to summary
public static final String TIMEOUT

RFC 2518 (WevDAV) Section 9.8

TRAILERback to summary
public static final String TRAILER

RFC 2616 (HTTP/1.1) Section 14.40

TRANSFER_ENCODINGback to summary
public static final String TRANSFER_ENCODING

RFC 2616 (HTTP/1.1) Section 14.41

UPGRADEback to summary
public static final String UPGRADE

RFC 2616 (HTTP/1.1) Section 14.42

USER_AGENTback to summary
public static final String USER_AGENT

RFC 1945 (HTTP/1.0) Section 10.15, RFC 2616 (HTTP/1.1) Section 14.43

VARYback to summary
public static final String VARY

RFC 2616 (HTTP/1.1) Section 14.44

VIAback to summary
public static final String VIA

RFC 2616 (HTTP/1.1) Section 14.45

WARNINGback to summary
public static final String WARNING

RFC 2616 (HTTP/1.1) Section 14.46

WWW_AUTHENTICATEback to summary
public static final String WWW_AUTHENTICATE

RFC 1945 (HTTP/1.0) Section 10.16, RFC 2616 (HTTP/1.1) Section 14.47

Constructor Detail

HttpHeadersback to summary
private HttpHeaders()