StatusLine, RFC1945 (HTTP/1.0), RFC2616 (HTTP/1.1), RFC2518 (WebDAV)
| Modifier and Type | Field and Description |
|---|---|
| public static final int | SC_ACCEPTED
|
| public static final int | SC_BAD_GATEWAY
|
| public static final int | SC_BAD_REQUEST
|
| public static final int | SC_CONFLICT
|
| public static final int | SC_CONTINUE
|
| public static final int | SC_CREATED
|
| public static final int | SC_EXPECTATION_FAILED
|
| public static final int | SC_FAILED_DEPENDENCY
|
| public static final int | SC_FORBIDDEN
|
| public static final int | SC_GATEWAY_TIMEOUT
|
| public static final int | SC_GONE
|
| public static final int | SC_HTTP_VERSION_NOT_SUPPORTED
|
| public static final int | SC_INSUFFICIENT_SPACE_ON_RESOURCE
Static constant for a 419 error. |
| public static final int | SC_INSUFFICIENT_STORAGE
|
| public static final int | SC_INTERNAL_SERVER_ERROR
|
| public static final int | SC_LENGTH_REQUIRED
|
| public static final int | SC_LOCKED
|
| public static final int | SC_METHOD_FAILURE
Static constant for a 420 error. |
| public static final int | SC_METHOD_NOT_ALLOWED
|
| public static final int | SC_MOVED_PERMANENTLY
|
| public static final int | SC_MOVED_TEMPORARILY
|
| public static final int | SC_MULTI_STATUS
|
| public static final int | SC_MULTIPLE_CHOICES
|
| public static final int | SC_NO_CONTENT
|
| public static final int | SC_NON_AUTHORITATIVE_INFORMATION
|
| public static final int | SC_NOT_ACCEPTABLE
|
| public static final int | SC_NOT_FOUND
|
| public static final int | SC_NOT_IMPLEMENTED
|
| public static final int | SC_NOT_MODIFIED
|
| public static final int | SC_OK
|
| public static final int | SC_PARTIAL_CONTENT
|
| public static final int | SC_PAYMENT_REQUIRED
|
| public static final int | SC_PRECONDITION_FAILED
|
| public static final int | SC_PROCESSING
|
| public static final int | SC_PROXY_AUTHENTICATION_REQUIRED
|
| public static final int | SC_REQUEST_TIMEOUT
|
| public static final int | SC_REQUEST_TOO_LONG
|
| public static final int | SC_REQUEST_URI_TOO_LONG
|
| public static final int | SC_REQUESTED_RANGE_NOT_SATISFIABLE
|
| public static final int | SC_RESET_CONTENT
|
| public static final int | SC_SEE_OTHER
|
| public static final int | SC_SERVICE_UNAVAILABLE
|
| public static final int | SC_SWITCHING_PROTOCOLS
|
| public static final int | SC_TEMPORARY_REDIRECT
|
| public static final int | SC_TOO_MANY_REQUESTS
|
| public static final int | SC_UNAUTHORIZED
|
| public static final int | SC_UNPROCESSABLE_ENTITY
|
| public static final int | SC_UNSUPPORTED_MEDIA_TYPE
|
| public static final int | SC_USE_PROXY
|
| SC_ACCEPTED | back to summary |
|---|---|
| public static final int SC_ACCEPTED
| |
| SC_BAD_GATEWAY | back to summary |
|---|---|
| public static final int SC_BAD_GATEWAY
| |
| SC_BAD_REQUEST | back to summary |
|---|---|
| public static final int SC_BAD_REQUEST
| |
| SC_CONFLICT | back to summary |
|---|---|
| public static final int SC_CONFLICT
| |
| SC_CONTINUE | back to summary |
|---|---|
| public static final int SC_CONTINUE
| |
| SC_CREATED | back to summary |
|---|---|
| public static final int SC_CREATED
| |
| SC_EXPECTATION_FAILED | back to summary |
|---|---|
| public static final int SC_EXPECTATION_FAILED
| |
| SC_FAILED_DEPENDENCY | back to summary |
|---|---|
| public static final int SC_FAILED_DEPENDENCY
| |
| SC_FORBIDDEN | back to summary |
|---|---|
| public static final int SC_FORBIDDEN
| |
| SC_GATEWAY_TIMEOUT | back to summary |
|---|---|
| public static final int SC_GATEWAY_TIMEOUT
| |
| SC_GONE | back to summary |
|---|---|
| public static final int SC_GONE
| |
| SC_HTTP_VERSION_NOT_SUPPORTED | back to summary |
|---|---|
| public static final int SC_HTTP_VERSION_NOT_SUPPORTED
| |
| SC_INSUFFICIENT_SPACE_ON_RESOURCE | back to summary |
|---|---|
| public static final int SC_INSUFFICIENT_SPACE_ON_RESOURCE Static constant for a 419 error.
| |
| SC_INSUFFICIENT_STORAGE | back to summary |
|---|---|
| public static final int SC_INSUFFICIENT_STORAGE
| |
| SC_INTERNAL_SERVER_ERROR | back to summary |
|---|---|
| public static final int SC_INTERNAL_SERVER_ERROR
| |
| SC_LENGTH_REQUIRED | back to summary |
|---|---|
| public static final int SC_LENGTH_REQUIRED
| |
| SC_LOCKED | back to summary |
|---|---|
| public static final int SC_LOCKED
| |
| SC_METHOD_FAILURE | back to summary |
|---|---|
| public static final int SC_METHOD_FAILURE Static constant for a 420 error.
| |
| SC_METHOD_NOT_ALLOWED | back to summary |
|---|---|
| public static final int SC_METHOD_NOT_ALLOWED
| |
| SC_MOVED_PERMANENTLY | back to summary |
|---|---|
| public static final int SC_MOVED_PERMANENTLY
| |
| SC_MOVED_TEMPORARILY | back to summary |
|---|---|
| public static final int SC_MOVED_TEMPORARILY
| |
| SC_MULTI_STATUS | back to summary |
|---|---|
| public static final int SC_MULTI_STATUS
| |
| SC_MULTIPLE_CHOICES | back to summary |
|---|---|
| public static final int SC_MULTIPLE_CHOICES
| |
| SC_NO_CONTENT | back to summary |
|---|---|
| public static final int SC_NO_CONTENT
| |
| SC_NON_AUTHORITATIVE_INFORMATION | back to summary |
|---|---|
| public static final int SC_NON_AUTHORITATIVE_INFORMATION
| |
| SC_NOT_ACCEPTABLE | back to summary |
|---|---|
| public static final int SC_NOT_ACCEPTABLE
| |
| SC_NOT_FOUND | back to summary |
|---|---|
| public static final int SC_NOT_FOUND
| |
| SC_NOT_IMPLEMENTED | back to summary |
|---|---|
| public static final int SC_NOT_IMPLEMENTED
| |
| SC_NOT_MODIFIED | back to summary |
|---|---|
| public static final int SC_NOT_MODIFIED
| |
| SC_OK | back to summary |
|---|---|
| public static final int SC_OK
| |
| SC_PARTIAL_CONTENT | back to summary |
|---|---|
| public static final int SC_PARTIAL_CONTENT
| |
| SC_PAYMENT_REQUIRED | back to summary |
|---|---|
| public static final int SC_PAYMENT_REQUIRED
| |
| SC_PRECONDITION_FAILED | back to summary |
|---|---|
| public static final int SC_PRECONDITION_FAILED
| |
| SC_PROCESSING | back to summary |
|---|---|
| public static final int SC_PROCESSING
| |
| SC_PROXY_AUTHENTICATION_REQUIRED | back to summary |
|---|---|
| public static final int SC_PROXY_AUTHENTICATION_REQUIRED
| |
| SC_REQUEST_TIMEOUT | back to summary |
|---|---|
| public static final int SC_REQUEST_TIMEOUT
| |
| SC_REQUEST_TOO_LONG | back to summary |
|---|---|
| public static final int SC_REQUEST_TOO_LONG
| |
| SC_REQUEST_URI_TOO_LONG | back to summary |
|---|---|
| public static final int SC_REQUEST_URI_TOO_LONG
| |
| SC_REQUESTED_RANGE_NOT_SATISFIABLE | back to summary |
|---|---|
| public static final int SC_REQUESTED_RANGE_NOT_SATISFIABLE
| |
| SC_RESET_CONTENT | back to summary |
|---|---|
| public static final int SC_RESET_CONTENT
| |
| SC_SEE_OTHER | back to summary |
|---|---|
| public static final int SC_SEE_OTHER
| |
| SC_SERVICE_UNAVAILABLE | back to summary |
|---|---|
| public static final int SC_SERVICE_UNAVAILABLE
| |
| SC_SWITCHING_PROTOCOLS | back to summary |
|---|---|
| public static final int SC_SWITCHING_PROTOCOLS
| |
| SC_TEMPORARY_REDIRECT | back to summary |
|---|---|
| public static final int SC_TEMPORARY_REDIRECT
| |
| SC_TOO_MANY_REQUESTS | back to summary |
|---|---|
| public static final int SC_TOO_MANY_REQUESTS
| |
| SC_UNAUTHORIZED | back to summary |
|---|---|
| public static final int SC_UNAUTHORIZED
| |
| SC_UNPROCESSABLE_ENTITY | back to summary |
|---|---|
| public static final int SC_UNPROCESSABLE_ENTITY
| |
| SC_UNSUPPORTED_MEDIA_TYPE | back to summary |
|---|---|
| public static final int SC_UNSUPPORTED_MEDIA_TYPE
| |
| SC_USE_PROXY | back to summary |
|---|---|
| public static final int SC_USE_PROXY
| |