| Modifier and Type | Method and Description |
|---|---|
| public void | addPropertyChangeListener(PropertyChangeListener
The listener to add listener)Add a property change listener to this component. |
| public Principal | Returns: the associated principal, ornull if none is associated.Username of the Principal to look up username)Try to authenticate with the specified username. |
| public Principal | Returns: the associated principal, ornull if there is noneUsername of the Principal to look up username, String Password or other credentials to use in
authenticating this username credentials)Try to authenticate using the specified username and credentials. |
| public Principal | Returns: the associated principal, ornull if there is none.Username of the Principal to look up username, String Digest which has been submitted by the client digest, String Unique (or supposedly unique) token which has been used
for this request nonce, String the nonce counter nc, String the client chosen nonce cnonce, String the "quality of protection" ( qop, String nc and cnonce
will only be used, if qop is not null).Realm name realm, String Second digest calculated as digest(Method + ":" + uri) digestA2)
Deprecated
Unused.
Try to authenticate with the specified username, which matches the digest calculated using the given parameters using the method described in RFC 2617 (which is a superset of RFC 2069). |
| public default Principal | Returns: the associated principal, ornull if there is none.Username of the Principal to look up username, String Digest which has been submitted by the client digest, String Unique (or supposedly unique) token which has been used
for this request nonce, String the nonce counter nc, String the client chosen nonce cnonce, String the "quality of protection" ( qop, String nc and cnonce
will only be used, if qop is not null).Realm name realm, String Second digest calculated as digest(Method + ":" + uri) digestA2, String The message digest algorithm to use algorithm)Try to authenticate with the specified username, which matches the digest calculated using the given parameters using the method described in RFC 7616. |
| public Principal | Returns: the associated principal, ornull if there is noneThe gssContext processed by the gssContext, boolean Authenticator.Should the realm attempt to store the delegated
credentials in the returned Principal? storeCreds)Try to authenticate using a |
| public Principal | Returns: the associated principal, ornull if there is noneThe gssName, GSSCredential GSSName of the principal to look upThe gssCredential)GSSCredential of the principal, may be
nullTry to authenticate using a |
| public Principal | Returns: the associated principal, ornull if there is noneArray of client certificates, with the first one in
the array being the certificate of the client itself. certs)Try to authenticate using a chain of |
| public void | backgroundProcess()
Execute a periodic task, such as reloading, etc. This method will be invoked inside the classloading context of this container. |
| public SecurityConstraint[] | findSecurityConstraints(Request
Request we are processing request, Context Context the Request is mapped to context)Find the SecurityConstraints configured to guard the request URI for this request. |
| public CredentialHandler | |
| public boolean | Returns: true if this constraint is satisfied and processing
should continue, or false otherwiseRequest we are processing request, Response Response we are creating response, SecurityConstraint[] Security constraint we are enforcing constraint, Context The Context to which client of this class is attached. context)Perform access control based on the specified authorization constraint. |
| public boolean | Returns: true if the specified Principal has the specified
security role, within the context of this Realm; otherwise return
false.wrapper context for evaluating role wrapper, Principal Principal for whom the role is to be checked principal, String Security role to be checked role)Check if the specified Principal has the specified security role, within the context of this Realm. |
| public boolean | Returns: true if this constraint
was not violated and processing should continue, or false
if we have created a response already.Request we are processing request, Response Response we are creating response, SecurityConstraint[] Security constraint being checked constraint)Enforce any user data constraint required by the security constraint guarding this request URI. |
| public default boolean | Returns: true if the realm is able to perform authenticationReturn the availability of the realm for authentication. |
| public void | removePropertyChangeListener(PropertyChangeListener
The listener to remove listener)Remove a property change listener from this component. |
| public void | setCredentialHandler(CredentialHandler
the credentialHandler)CredentialHandler to useSet the CredentialHandler to be used by this Realm. |
| addPropertyChangeListener | back to summary |
|---|---|
| public void addPropertyChangeListener(PropertyChangeListener listener) Add a property change listener to this component.
| |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(String username) Try to authenticate with the specified username. | |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(String username, String credentials) Try to authenticate using the specified username and credentials. | |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(String username, String digest, String nonce, String nc, String cnonce, String qop, String realm, String digestA2)
Deprecated Unused. Use Try to authenticate with the specified username, which matches the digest calculated using the given parameters using the method described in RFC 2617 (which is a superset of RFC 2069).
| |
| authenticate | back to summary |
|---|---|
| public default Principal authenticate(String username, String digest, String nonce, String nc, String cnonce, String qop, String realm, String digestA2, String algorithm) Try to authenticate with the specified username, which matches the digest calculated using the given parameters using the method described in RFC 7616.
The default implementation calls Implementations are expected to override the default implementation and take account of the algorithm parameter.
| |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(GSSContext gssContext, boolean storeCreds) Try to authenticate using a
| |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(GSSName gssName, GSSCredential gssCredential) Try to authenticate using a
| |
| authenticate | back to summary |
|---|---|
| public Principal authenticate(X509Certificate[] certs) Try to authenticate using a chain of
| |
| backgroundProcess | back to summary |
|---|---|
| public void backgroundProcess() Execute a periodic task, such as reloading, etc. This method will be invoked inside the classloading context of this container. Unexpected throwables will be caught and logged. | |
| findSecurityConstraints | back to summary |
|---|---|
| public SecurityConstraint[] findSecurityConstraints(Request request, Context context) Find the SecurityConstraints configured to guard the request URI for this request.
| |
| getCredentialHandler | back to summary |
|---|---|
public CredentialHandler getCredentialHandler()
| |
| hasResourcePermission | back to summary |
|---|---|
| public boolean hasResourcePermission(Request request, Response response, SecurityConstraint[] constraint, Context context) throws IOException Perform access control based on the specified authorization constraint.
| |
| hasRole | back to summary |
|---|---|
| public boolean hasRole(Wrapper wrapper, Principal principal, String role) Check if the specified Principal has the specified security role, within the context of this Realm.
| |
| hasUserDataPermission | back to summary |
|---|---|
| public boolean hasUserDataPermission(Request request, Response response, SecurityConstraint[] constraint) throws IOException Enforce any user data constraint required by the security constraint guarding this request URI.
| |
| isAvailable | back to summary |
|---|---|
| public default boolean isAvailable() Return the availability of the realm for authentication.
| |
| removePropertyChangeListener | back to summary |
|---|---|
| public void removePropertyChangeListener(PropertyChangeListener listener) Remove a property change listener from this component.
| |
| setCredentialHandler | back to summary |
|---|---|
| public void setCredentialHandler(CredentialHandler credentialHandler) Set the CredentialHandler to be used by this Realm.
| |