Top Classes Enums
module tomcat.embed.core

Package org.apache.tomcat.util.http.parser


Class Summary

Modifier and TypeClass and Description
public class
public class
public class
Authorization

Parser for an "Authorization" header.

public class
public class
Cookie

Cookie header parser based on RFC6265

The parsing of cookies using RFC6265 is more relaxed that the specification in the following ways:

  • Values 0x80 to 0xFF are permitted in cookie-octet to support the use of UTF-8 in cookie values as used by HTML 5.
  • For cookies without a value, the '=' is not required after the name as some browsers do not sent it.
public class
public class
public class
HttpParser

HTTP header value parser implementation.

public class
public class
MediaTypeCache

Caches the results of parsing content-type headers.

public class
Priority

HTTP priority header parser as per RFC 9218.

public class
public class
StructuredField

Parsing of structured fields as per RFC 8941.

public class
public class

Enum Summary

Modifier and TypeEnum and Description
pack-priv enum