Top Interfaces Classes
module bcprov

Package org.bouncycastle.jce.provider


Interface Summary

Modifier and TypeInterface and Description
public interface

Class Summary

Modifier and TypeClass and Description
public class
public class
BouncyCastleProvider

To add the provider at runtime use:

import java.security.Security;
import org.bouncycastle.jce.provider.BouncyCastleProvider;

Security.addProvider(new BouncyCastleProvider());
pack-priv class
public class
public class
BrokenKDF2BytesGenerator

Generator for PBE derived keys and ivs as defined by IEEE P1363a This implementation is based on draft 9 of IEEE P1363a

Note

as this is still a draft the output of this generator may change, don't use it for anything that might be subject to long term storage.

pack-priv class
pack-priv class
public class
pack-priv class
public class
DHUtil

utility class for converting jce/jca DH objects objects into their org.bouncycastle.crypto counterparts.

pack-priv class
public class
public class
public class
public class
public class
public class
JCEElGamalPublicKey

References Deprecated ElGamalPublicKey is deprecated or references (maybe indirectly) at least one deprecated element.
public class
JCERSAPrivateCrtKey

A provider representation for a RSA private key, with CRT factors included.

public class
public class
public class
public class
public class
JDKPKCS12StoreParameter

Deprecated use org.bouncycastle.jcajce.config.PKCS12StoreParameter
public class
pack-priv class
pack-priv class
OldPKCS12ParametersGenerator

Generator for PBE derived keys and ivs as defined by PKCS 12 V1.0, with a bug affecting 180 bit plus keys - this class is only here to allow smooth migration of the version 0 keystore to version 1.

public class
public class
public class
PKIXAttrCertPathValidatorSpi

CertPathValidatorSpi implementation for X.509 Attribute Certificates la RFC 3281.

public class
PKIXCertPathBuilderSpi

Implements the PKIX CertPathBuilding algorithm for BouncyCastle.

public class
PKIXCertPathBuilderSpi_8

Implements the PKIX CertPathBuilding algorithm for BouncyCastle.

public class
PKIXCertPathValidatorSpi

CertPathValidatorSpi implementation for X.509 Certificate validation � la RFC 3280.

public class
PKIXCertPathValidatorSpi_8

CertPathValidatorSpi implementation for X.509 Certificate validation � la RFC 3280.

pack-priv abstract class
public class
public class
public class
pack-priv class
pack-priv class
pack-priv class
pack-priv class
pack-priv class
ReasonsMask

This class helps to handle CRL revocation reasons mask.

pack-priv class
pack-priv class
pack-priv class
pack-priv class
public class
public class
X509CertificateObject

Deprecated Do not use this class directly - either use org.bouncycastle.cert (bcpkix) or CertificateFactory.
public class
public class
X509CertParser

Deprecated use CertificateFactory or the PEMParser in the openssl package (pkix jar).
public class
X509CRLEntryObject

The following extensions are listed in RFC 2459 as relevant to CRL Entries ReasonCode Hode Instruction Code Invalidity Date Certificate Issuer (critical)

public class
X509CRLObject

Deprecated Do not use this class directly - either use org.bouncycastle.cert (bcpkix) or CertificateFactory.
The following extensions are listed in RFC 2459 as relevant to CRLs Authority Key Identifier Issuer Alternative Name CRL Number Delta CRL Indicator (critical) Issuing Distribution Point (critical)
public class
public class
X509LDAPCertStoreSpi

This is a general purpose implementation to get X.509 certificates and CRLs from a LDAP location.

pack-priv class
public class
public class
public class
X509StoreCertPairCollection

This class is a collection based Bouncy Castle org.bouncycastle.x509.X509Store SPI implementation for certificate pairs.

public class
public class
X509StoreLDAPAttrCerts

A SPI implementation of Bouncy Castle X509Store for getting attribute certificates from an LDAP directory.

public class
X509StoreLDAPCertPairs

A SPI implementation of Bouncy Castle X509Store for getting cross certificates pairs from an LDAP directory.

public class
X509StoreLDAPCerts

A SPI implementation of Bouncy Castle X509Store for getting certificates form a LDAP directory.

public class
X509StoreLDAPCRLs

A SPI implementation of Bouncy Castle X509Store for getting certificate revocation lists from an LDAP directory.