Top Description Packages

Bouncy Castle PKIX APIs (FIPS Distribution) 1.0.7

Resources
Homepage, Development, Bug Tracker, License (Bouncy Castle Licence)
Dependencies
java.base, java.logging, java.naming, bc-fips
Maven Central
Group ID:org.bouncycastle
Artifacts:bcpkix-fips

Project Bouncy Castle PKIX APIs (FIPS Distribution)

The Bouncy Castle Java APIs for CMS, PKCS, EAC, TSP, CMP, CRMF, OCSP, S/MIME and certificate generation. The APIs are designed primarily to be used in conjunction with the BC FIPS provider. The APIs may also be used with other providers although if being used in a FIPS context it is the responsibility of the user to ensure that any other providers used are FIPS certified and used appropriately.

Release 1.0.7

Release Date
2022-11-01
Developers
The Legion of the Bouncy Castle Inc.

Package Summary

Modifier and TypePackage and Description
package
org.bouncycastle.cert

Basic support package for handling and creating X.509 certificates, CRLs, and attribute certificates.

package
org.bouncycastle.cert.cmp

Basic support package for handling and creating CMP (RFC 4210) certificate management messages.

package
org.bouncycastle.cert.crmf

Basic support package for handling and creating CRMF (RFC 4211) certificate request messages.

package
org.bouncycastle.cert.crmf.jcajce

JCA extensions to the CRMF online certificate request package.

package
package
package
org.bouncycastle.cert.jcajce

JCA extensions to the certificate building and processing package.

package
org.bouncycastle.cert.ocsp

Basic support package for handling and creating OCSP (RFC 2560) online certificate status requests.

package
org.bouncycastle.cert.ocsp.jcajce

JCA extensions to the OCSP online certificate status package.

package
package
package
org.bouncycastle.cert.selector

Specialised Selector classes for certificates, CRLs, and attribute certificates.

package
package
package
org.bouncycastle.cms

A package for processing RFC 3852 Cryptographic Message Syntax (CMS) objects - also referred to as PKCS#7 (formerly RFC 2630, 3369).

package
org.bouncycastle.cms.jcajce

CMS operator implementations for doing message encryption, signing, digesting, and MACing operations using the JCA and the JCE.

package
org.bouncycastle.dvcs

Classes for dealing "Internet X.509 Public Key Infrastructure Data Validation and Certification Server Protocols" - RFC 3029.

package
org.bouncycastle.eac

Base classes Extended Access Control (EAC) Certificates as described in "Technical Guideline, Advanced Security Mechanisms for Machine Readable Travel Documents, Extended Access Control (EAC), Version 1.0.1, BSI 2006".

package
package
package
package
org.bouncycastle.est

A package for processing messages for RFC 7030 "Enrollment over Secure Transport".

package
org.bouncycastle.est.jcajce

JCA/JCE/JSSE support Enrollment over Secure Transport.

package
package
package
package
org.bouncycastle.mozilla

Support class for mozilla signed public key and challenge.

package
package
org.bouncycastle.openssl

Classes for dealing with OpenSSL PEM files.

package
package
org.bouncycastle.operator

Basic operator definitions for doing encryption, signing, and digest operations.

package
org.bouncycastle.operator.jcajce

Basic operator implementations for doing encryption, signing, and digest operations using the JCA and the JCE.

package
org.bouncycastle.pkcs

Basic support package for handling and creating PKCS#10 certification requests, PKCS#8 encrypted keys and PKCS#12 keys stores.

package
org.bouncycastle.pkcs.jcajce

JCA extensions and operators for the PKCS#10 certification request package.

package
package
package
package
package
org.bouncycastle.tsp

Classes for dealing Time Stamp Protocol (TSP) - RFC 3161.

package
org.bouncycastle.tsp.cms

Classes for dealing Syntax for Binding Documents with Time-Stamps - RFC 5544.

package