Deprecated
use org.bouncycastle.asn1.x500.X500Name.
RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
RelativeDistinguishedName ::= SET SIZE (1..MAX) OF AttributeTypeAndValue
AttributeTypeAndValue ::= SEQUENCE {
type OBJECT IDENTIFIER,
value ANY }
| Modifier and Type | Field and Description |
|---|---|
| private Vector | |
| public static final ASN1ObjectIdentifier | BUSINESS_CATEGORY
businessCategory - DirectoryString(SIZE(1..128) |
| public static final ASN1ObjectIdentifier | C
country code - StringType(SIZE(2)) |
| public static final ASN1ObjectIdentifier | CN
common name - StringType(SIZE(1..64)) |
| private X509NameEntryConverter | |
| public static final ASN1ObjectIdentifier | COUNTRY_OF_CITIZENSHIP
RFC 3039 CountryOfCitizenship - PrintableString (SIZE (2)) -- ISO 3166 codes only |
| public static final ASN1ObjectIdentifier | COUNTRY_OF_RESIDENCE
RFC 3039 CountryOfResidence - PrintableString (SIZE (2)) -- ISO 3166 codes only |
| public static final ASN1ObjectIdentifier | DATE_OF_BIRTH
RFC 3039 DateOfBirth - GeneralizedTime - YYYYMMDD000000Z |
| public static final ASN1ObjectIdentifier | |
| public static final Hashtable | DefaultLookUp
look up table translating common symbols into their OIDS. |
| public static boolean | DefaultReverse
determines whether or not strings should be processed and printed from back to front. |
| public static final Hashtable | DefaultSymbols
default look up table translating OID values into their common symbols following the convention in RFC 2253 with a few extras |
| public static final ASN1ObjectIdentifier | DMD_NAME
RFC 2256 dmdName |
| public static final ASN1ObjectIdentifier | DN_QUALIFIER
dnQualifier - DirectoryString(SIZE(1..64) |
| public static final ASN1ObjectIdentifier | E
email address in Verisign certificates |
| public static final ASN1ObjectIdentifier | EmailAddress
Email address (RSA PKCS#9 extension) - IA5String. |
| private static final Boolean | |
| public static final ASN1ObjectIdentifier | GENDER
RFC 3039 Gender - PrintableString (SIZE(1)) -- "M", "F", "m" or "f" |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | |
| private int | |
| public static final ASN1ObjectIdentifier | |
| private boolean | |
| public static final ASN1ObjectIdentifier | L
locality name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | NAME
id-at-name |
| public static final ASN1ObjectIdentifier | NAME_AT_BIRTH
ISIS-MTT NameAtBirth - DirectoryString(SIZE(1..64) |
| public static final ASN1ObjectIdentifier | O
organization - StringType(SIZE(1..64)) |
| public static final Hashtable | OIDLookUp
look up table translating OID values into their common symbols |
| private Vector | |
| public static final ASN1ObjectIdentifier | OU
organizational unit name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | PLACE_OF_BIRTH
RFC 3039 PlaceOfBirth - DirectoryString(SIZE(1..128) |
| public static final ASN1ObjectIdentifier | POSTAL_ADDRESS
RFC 3039 PostalAddress - SEQUENCE SIZE (1..6) OF DirectoryString(SIZE(1..30)) |
| public static final ASN1ObjectIdentifier | POSTAL_CODE
postalCode - DirectoryString(SIZE(1..40) |
| public static final ASN1ObjectIdentifier | PSEUDONYM
RFC 3039 Pseudonym - DirectoryString(SIZE(1..64) |
| public static final Hashtable | RFC1779Symbols
look up table translating OID values into their common symbols following the convention in RFC 1779 |
| public static final Hashtable | RFC2253Symbols
look up table translating OID values into their common symbols following the convention in RFC 2253 |
| private ASN1Sequence | |
| public static final ASN1ObjectIdentifier | SERIALNUMBER
device serial number name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | SN
device serial number name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | ST
state, or province name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | STREET
street - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | SURNAME
Naming attributes of type X520name |
| public static final Hashtable | SymbolLookUp
look up table translating string values into their OIDS - |
| public static final ASN1ObjectIdentifier | T
Title |
| public static final ASN1ObjectIdentifier | TELEPHONE_NUMBER
id-at-telephoneNumber |
| private static final Boolean | |
| public static final ASN1ObjectIdentifier | UID
LDAP User id. |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | UnstructuredName
more from PKCS#9 |
| private Vector |
| Access | Constructor and Description |
|---|---|
| protected | |
| public | X509Name(ASN1Sequence seq)
Deprecated
use X500Name.getInstance()
Constructor from ASN1Sequence
the principal will be a list of constructed sets, each containing an (OID, String) pair.
|
| public | |
| public | |
| public | X509Name(Vector<E> ordering, Hashtable<K, V> attributes, X509NameEntryConverter converter)
Deprecated
use X500Name, X500NameBuilder
Constructor from a table of attributes with ordering.
|
| public | |
| public | X509Name(Vector<E> oids, Vector<E> values, X509NameEntryConverter converter)
Deprecated
use X500Name, X500NameBuilder
Takes two vectors one of the oids and the other of the values.
|
| public | |
| public | X509Name(String dirName, X509NameEntryConverter converter)
Deprecated
use X500Name, X500NameBuilder
Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or
some such, converting it into an ordered set of name attributes with each
string value being converted to its associated ASN.1 type using the passed
in converter.
|
| public | |
| public | X509Name(boolean reverse, String dirName, X509NameEntryConverter converter)
Deprecated
use X500Name, X500NameBuilder
Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or
some such, converting it into an ordered set of name attributes with each
string value being converted to its associated ASN.1 type using the passed
in converter.
|
| public | X509Name(boolean
true if we should start scanning from the end (RFC 2553). reverse, Hashtable<K, V> table of names and their oids. lookUp, String the X.500 string to be parsed. dirName)
Deprecated
use X500Name, X500NameBuilder
Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or
some such, converting it into an ordered set of name attributes.
|
| public | X509Name(boolean
true if we should start scanning from the end, false otherwise. reverse, Hashtable<K, V> table of names and oids. lookUp, String the string dirName dirName, X509NameEntryConverter the converter to convert string values into their ASN.1 equivalents converter)Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or some such, converting it into an ordered set of name attributes. |
| Modifier and Type | Method and Description |
|---|---|
| private void | |
| private void | |
| private String | |
| private String | |
| private ASN1Primitive | |
| private ASN1ObjectIdentifier | |
| public boolean | |
| public boolean | equals(Object
the reference object with which to compare. obj)Overrides org. |
| private boolean | |
| public static X509Name | Returns: the X509Nametag object holding name. obj, boolean true if explicitly tagged false otherwise. explicit)
Deprecated
as a consequence of
Return a X509Name based on the passed in tagged object.
X509Name being deprecated.
|
| public static X509Name | |
| public Vector | |
| public Vector | |
| public Vector | getValues(ASN1ObjectIdentifier oid)
return a vector of the values found in the name, in the order they were found, with the DN label corresponding to passed in oid. |
| public int | hashCode()
Overrides org. |
| private String | |
| public ASN1Primitive | toASN1Primitive()
Implements abstract org. Implements org. |
| public String | toString(boolean
if true start at the end of the sequence and work back. reverse, Hashtable<K, V> look up table strings for oids. oidSymbols)convert the structure to a string - if reverse is true the oids and values are listed out starting with the last element in the sequence (ala RFC 2253), otherwise the string will begin with the first element of the structure. |
| public String | |
| private String |
| added | back to summary |
|---|---|
| private Vector<E> added | |
| BUSINESS_CATEGORY | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier BUSINESS_CATEGORY businessCategory - DirectoryString(SIZE(1..128) | |
| C | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier C
Deprecated use a X500NameStyle country code - StringType(SIZE(2)) | |
| CN | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier CN
Deprecated use a X500NameStyle common name - StringType(SIZE(1..64)) | |
| converter | back to summary |
|---|---|
| private X509NameEntryConverter converter | |
| COUNTRY_OF_CITIZENSHIP | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier COUNTRY_OF_CITIZENSHIP RFC 3039 CountryOfCitizenship - PrintableString (SIZE (2)) -- ISO 3166 codes only | |
| COUNTRY_OF_RESIDENCE | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier COUNTRY_OF_RESIDENCE RFC 3039 CountryOfResidence - PrintableString (SIZE (2)) -- ISO 3166 codes only | |
| DATE_OF_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DATE_OF_BIRTH RFC 3039 DateOfBirth - GeneralizedTime - YYYYMMDD000000Z | |
| DC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DC | |
| DefaultLookUp | back to summary |
|---|---|
| public static final Hashtable<K, V> DefaultLookUp look up table translating common symbols into their OIDS. | |
| DefaultReverse | back to summary |
|---|---|
| public static boolean DefaultReverse determines whether or not strings should be processed and printed from back to front. | |
| DefaultSymbols | back to summary |
|---|---|
| public static final Hashtable<K, V> DefaultSymbols default look up table translating OID values into their common symbols following the convention in RFC 2253 with a few extras | |
| DMD_NAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DMD_NAME RFC 2256 dmdName | |
| DN_QUALIFIER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DN_QUALIFIER dnQualifier - DirectoryString(SIZE(1..64) | |
| E | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier E email address in Verisign certificates | |
| EmailAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier EmailAddress
Deprecated use a X500NameStyle Email address (RSA PKCS#9 extension) - IA5String. Note if you're trying to be ultra orthodox, don't use this! It shouldn't be in here. | |
| FALSE | back to summary |
|---|---|
| private static final Boolean FALSE | |
| GENDER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GENDER RFC 3039 Gender - PrintableString (SIZE(1)) -- "M", "F", "m" or "f" | |
| GENERATION | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GENERATION | |
| GIVENNAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GIVENNAME | |
| hashCodeValue | back to summary |
|---|---|
| private int hashCodeValue | |
| INITIALS | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier INITIALS | |
| isHashCodeCalculated | back to summary |
|---|---|
| private boolean isHashCodeCalculated | |
| L | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier L locality name - StringType(SIZE(1..64)) | |
| NAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier NAME id-at-name | |
| NAME_AT_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier NAME_AT_BIRTH ISIS-MTT NameAtBirth - DirectoryString(SIZE(1..64) | |
| O | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier O
Deprecated use a X500NameStyle organization - StringType(SIZE(1..64)) | |
| OIDLookUp | back to summary |
|---|---|
| public static final Hashtable<K, V> OIDLookUp
Deprecated use DefaultSymbols look up table translating OID values into their common symbols | |
| ordering | back to summary |
|---|---|
| private Vector<E> ordering | |
| OU | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier OU
Deprecated use a X500NameStyle organizational unit name - StringType(SIZE(1..64)) | |
| PLACE_OF_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier PLACE_OF_BIRTH RFC 3039 PlaceOfBirth - DirectoryString(SIZE(1..128) | |
| POSTAL_ADDRESS | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier POSTAL_ADDRESS RFC 3039 PostalAddress - SEQUENCE SIZE (1..6) OF DirectoryString(SIZE(1..30)) | |
| POSTAL_CODE | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier POSTAL_CODE postalCode - DirectoryString(SIZE(1..40) | |
| PSEUDONYM | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier PSEUDONYM RFC 3039 Pseudonym - DirectoryString(SIZE(1..64) | |
| RFC1779Symbols | back to summary |
|---|---|
| public static final Hashtable<K, V> RFC1779Symbols look up table translating OID values into their common symbols following the convention in RFC 1779 | |
| RFC2253Symbols | back to summary |
|---|---|
| public static final Hashtable<K, V> RFC2253Symbols look up table translating OID values into their common symbols following the convention in RFC 2253 | |
| seq | back to summary |
|---|---|
| private ASN1Sequence seq | |
| SERIALNUMBER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SERIALNUMBER device serial number name - StringType(SIZE(1..64)) | |
| SN | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SN device serial number name - StringType(SIZE(1..64)) | |
| ST | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier ST state, or province name - StringType(SIZE(1..64)) | |
| STREET | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier STREET street - StringType(SIZE(1..64)) | |
| SURNAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SURNAME Naming attributes of type X520name | |
| SymbolLookUp | back to summary |
|---|---|
| public static final Hashtable<K, V> SymbolLookUp
Deprecated use DefaultLookUp look up table translating string values into their OIDS - | |
| T | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier T
Deprecated use a X500NameStyle Title | |
| TELEPHONE_NUMBER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier TELEPHONE_NUMBER id-at-telephoneNumber | |
| TRUE | back to summary |
|---|---|
| private static final Boolean TRUE | |
| UID | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UID LDAP User id. | |
| UNIQUE_IDENTIFIER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UNIQUE_IDENTIFIER | |
| UnstructuredAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UnstructuredAddress | |
| UnstructuredName | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UnstructuredName more from PKCS#9 | |
| values | back to summary |
|---|---|
| private Vector<E> values | |
| X509Name | back to summary |
|---|---|
| protected X509Name() | |
| X509Name | back to summary |
|---|---|
| public X509Name(ASN1Sequence seq)
Deprecated use X500Name.getInstance() Constructor from ASN1Sequence the principal will be a list of constructed sets, each containing an (OID, String) pair. | |
| X509Name | back to summary |
|---|---|
| public X509Name(Hashtable<K, V> attributes)
Deprecated use an ordered constructor! The hashtable ordering is rarely correct constructor from a table of attributes. it's is assumed the table contains OID/String pairs, and the contents of the table are copied into an internal table as part of the construction process. Note if the name you are trying to generate should be following a specific ordering, you should use the constructor with the ordering specified below. | |
| X509Name | back to summary |
|---|---|
| public X509Name(Vector<E> ordering, Hashtable<K, V> attributes) Constructor from a table of attributes with ordering. it's is assumed the table contains OID/String pairs, and the contents of the table are copied into an internal table as part of the construction process. The ordering vector should contain the OIDs in the order they are meant to be encoded or printed in toString. | |
| X509Name | back to summary |
|---|---|
| public X509Name(Vector<E> ordering, Hashtable<K, V> attributes, X509NameEntryConverter converter)
Deprecated use X500Name, X500NameBuilder Constructor from a table of attributes with ordering. it's is assumed the table contains OID/String pairs, and the contents of the table are copied into an internal table as part of the construction process. The ordering vector should contain the OIDs in the order they are meant to be encoded or printed in toString. The passed in converter will be used to convert the strings into their ASN.1 counterparts. | |
| X509Name | back to summary |
|---|---|
| public X509Name(Vector<E> oids, Vector<E> values)
Deprecated use X500Name, X500NameBuilder Takes two vectors one of the oids and the other of the values. | |
| X509Name | back to summary |
|---|---|
| public X509Name(Vector<E> oids, Vector<E> values, X509NameEntryConverter converter)
Deprecated use X500Name, X500NameBuilder Takes two vectors one of the oids and the other of the values. The passed in converter will be used to convert the strings into their ASN.1 counterparts. | |
| X509Name | back to summary |
|---|---|
| public X509Name(String dirName)
Deprecated use X500Name, X500NameBuilder Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or some such, converting it into an ordered set of name attributes. | |
| X509Name | back to summary |
|---|---|
| public X509Name(String dirName, X509NameEntryConverter converter)
Deprecated use X500Name, X500NameBuilder Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or some such, converting it into an ordered set of name attributes with each string value being converted to its associated ASN.1 type using the passed in converter. | |
| X509Name | back to summary |
|---|---|
| public X509Name(boolean reverse, String dirName)
Deprecated use X500Name, X500NameBuilder Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or some such, converting it into an ordered set of name attributes. If reverse is true, create the encoded version of the sequence starting from the last element in the string. | |
| X509Name | back to summary |
|---|---|
| public X509Name(boolean reverse, String dirName, X509NameEntryConverter converter)
Deprecated use X500Name, X500NameBuilder Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or some such, converting it into an ordered set of name attributes with each string value being converted to its associated ASN.1 type using the passed in converter. If reverse is true the ASN.1 sequence representing the DN will be built by starting at the end of the string, rather than the start. | |
| X509Name | back to summary |
|---|---|
| public X509Name(boolean reverse, Hashtable<K, V> lookUp, String dirName)
Deprecated use X500Name, X500NameBuilder Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or
some such, converting it into an ordered set of name attributes. lookUp
should provide a table of lookups, indexed by lowercase only strings and
yielding a ASN1ObjectIdentifier, other than that OID. and numeric oids
will be processed automatically.
| |
| X509Name | back to summary |
|---|---|
| public X509Name(boolean reverse, Hashtable<K, V> lookUp, String dirName, X509NameEntryConverter converter) Takes an X509 dir name as a string of the format "C=AU, ST=Victoria", or
some such, converting it into an ordered set of name attributes. lookUp
should provide a table of lookups, indexed by lowercase only strings and
yielding a ASN1ObjectIdentifier, other than that OID. and numeric oids
will be processed automatically. The passed in converter is used to convert the
string values to the right of each equals sign to their ASN.1 counterparts.
| |
| addEntry | back to summary |
|---|---|
| private void addEntry(Hashtable<K, V> lookUp, String token, Boolean isAdded) | |
| appendValue | back to summary |
|---|---|
| private void appendValue(StringBuffer buf, Hashtable<K, V> oidSymbols, ASN1ObjectIdentifier oid, String value) | |
| bytesToString | back to summary |
|---|---|
| private String bytesToString(byte[] data) | |
| canonicalize | back to summary |
|---|---|
| private String canonicalize(String s) | |
| decodeObject | back to summary |
|---|---|
| private ASN1Primitive decodeObject(String oValue) | |
| decodeOID | back to summary |
|---|---|
| private ASN1ObjectIdentifier decodeOID(String name, Hashtable<K, V> lookUp) | |
| equals | back to summary |
|---|---|
public boolean equals(Object obj, boolean inOrder)
| |
| equals | back to summary |
|---|---|
| public boolean equals(Object obj) Overrides org. test for equality - note: case is ignored.
| |
| equivalentStrings | back to summary |
|---|---|
| private boolean equivalentStrings(String s1, String s2) | |
| getInstance | back to summary |
|---|---|
| public static X509Name getInstance(ASN1TaggedObject obj, boolean explicit)
Deprecated as a consequence of Return a X509Name based on the passed in tagged object.
| |
| getInstance | back to summary |
|---|---|
| public static X509Name getInstance(Object obj)
Deprecated as a consequence of | |
| getOIDs | back to summary |
|---|---|
| public Vector return a vector of the oids in the name, in the order they were found. | |
| getValues | back to summary |
|---|---|
| public Vector return a vector of the values found in the name, in the order they were found. | |
| getValues | back to summary |
|---|---|
| public Vector return a vector of the values found in the name, in the order they were found, with the DN label corresponding to passed in oid. | |
| hashCode | back to summary |
|---|---|
| public int hashCode() Overrides org. Doc from java. Returns a hash code value for the object. This method is
supported for the benefit of hash tables such as those provided by
The general contract of
| |
| stripInternalSpaces | back to summary |
|---|---|
| private String stripInternalSpaces(String str) | |
| toASN1Primitive | back to summary |
|---|---|
| public ASN1Primitive toASN1Primitive() Implements abstract org. Implements org. Doc from org. Method providing a primitive representation of this object suitable for encoding.
| |
| toString | back to summary |
|---|---|
| public String toString(boolean reverse, Hashtable<K, V> oidSymbols) convert the structure to a string - if reverse is true the oids and values are listed out starting with the last element in the sequence (ala RFC 2253), otherwise the string will begin with the first element of the structure. If no string definition for the oid is found in oidSymbols the string value of the oid is added. Two standard symbol tables are provided DefaultSymbols, and RFC2253Symbols as part of this class.
| |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Doc from java. Returns a string representation of the object.
| |
| unescape | back to summary |
|---|---|
| private String unescape(String elt) | |