| Modifier and Type | Field and Description |
|---|---|
| protected CertificateStatusRequest | |
| protected int[] | |
| protected Hashtable | |
| protected Vector | |
| protected boolean | |
| protected TlsServerContext | |
| protected boolean | |
| protected short | |
| protected int[] | |
| protected ProtocolVersion[] | |
| protected int | |
| protected ProtocolName | |
| protected final Hashtable | |
| protected Vector | |
| protected boolean | |
| protected Vector |
| Access | Constructor and Description |
|---|---|
| public |
| Modifier and Type | Method and Description |
|---|---|
| protected boolean | |
| protected boolean | |
| protected boolean | |
| protected boolean | |
| protected boolean | |
| protected Hashtable | |
| protected short[] | |
| public CertificateRequest | |
| public CertificateStatus | getCertificateStatus()
Implements org. |
| public int[] | |
| protected String | |
| public TlsDHConfig | |
| public TlsECConfig | |
| public TlsPSKExternal | getExternalPSK(Vector<E>
a identities)Vector of PskIdentity instances.Implements org. Warning EXPERIMENTAL FEATURE, UNSTABLE API
Return the |
| protected int | |
| protected int | |
| protected byte[] | Returns: The connection ID to use.RFC 9146 DTLS connection ID. This method will be called if a connection_id extension was sent by the client. |
| public byte[] | |
| public NewSessionTicket | |
| protected Vector | |
| public ProtocolVersion[] | |
| public TlsPSKIdentityManager | |
| public int | |
| public Hashtable | |
| public void | getServerExtensionsForConnection(Hashtable<K, V> serverExtensions)
Implements org. |
| public Vector | |
| public ProtocolVersion | |
| public TlsSession | getSessionToResume(byte[]
the ID of the session to resume. sessionID)Implements org. |
| public TlsSRPLoginParameters | |
| public int[] | |
| public void | |
| protected boolean | isSelectableCipherSuite(int cipherSuite, int availCurveBits, int availFiniteFieldBits, Vector<E> sigAlgs)
|
| public void | notifyClientCertificate(Certificate
the effective client certificate (may be an empty chain). clientCertificate)Implements org. getCertificateRequest() returned non-null.
|
| public void | notifyClientVersion(ProtocolVersion clientVersion)
Implements org. |
| public void | |
| public void | notifyHandshakeBeginning()
Overrides org. Implements org. |
| public void | notifyOfferedCipherSuites(int[] offeredCipherSuites)
Implements org. |
| public void | |
| protected boolean | |
| protected boolean | |
| public void | processClientExtensions(Hashtable<K, V> clientExtensions)
Implements org. |
| public void | processClientSupplementalData(Vector<E> clientSupplementalData)
Implements org. |
| protected boolean | |
| protected int | |
| protected int | |
| protected int | |
| protected int | |
| protected ProtocolName | |
| protected ProtocolName | |
| protected boolean |
| certificateStatusRequest | back to summary |
|---|---|
| protected CertificateStatusRequest certificateStatusRequest | |
| cipherSuites | back to summary |
|---|---|
| protected int[] cipherSuites | |
| clientExtensions | back to summary |
|---|---|
| protected Hashtable<K, V> clientExtensions | |
| clientProtocolNames | back to summary |
|---|---|
| protected Vector<E> clientProtocolNames | |
| clientSentECPointFormats | back to summary |
|---|---|
| protected boolean clientSentECPointFormats | |
| context | back to summary |
|---|---|
| protected TlsServerContext context | |
| encryptThenMACOffered | back to summary |
|---|---|
| protected boolean encryptThenMACOffered | |
| maxFragmentLengthOffered | back to summary |
|---|---|
| protected short maxFragmentLengthOffered | |
| offeredCipherSuites | back to summary |
|---|---|
| protected int[] offeredCipherSuites | |
| protocolVersions | back to summary |
|---|---|
| protected ProtocolVersion[] protocolVersions | |
| selectedCipherSuite | back to summary |
|---|---|
| protected int selectedCipherSuite | |
| selectedProtocolName | back to summary |
|---|---|
| protected ProtocolName selectedProtocolName | |
| serverExtensions | back to summary |
|---|---|
| protected final Hashtable<K, V> serverExtensions | |
| statusRequestV2 | back to summary |
|---|---|
| protected Vector<E> statusRequestV2 | |
| truncatedHMacOffered | back to summary |
|---|---|
| protected boolean truncatedHMacOffered | |
| trustedCAKeys | back to summary |
|---|---|
| protected Vector<E> trustedCAKeys | |
| AbstractTlsServer | back to summary |
|---|---|
| public AbstractTlsServer(TlsCrypto crypto) | |
| allowCertificateStatus | back to summary |
|---|---|
| protected boolean allowCertificateStatus() | |
| allowEncryptThenMAC | back to summary |
|---|---|
| protected boolean allowEncryptThenMAC() | |
| allowMultiCertStatus | back to summary |
|---|---|
| protected boolean allowMultiCertStatus() | |
| allowTruncatedHMac | back to summary |
|---|---|
| protected boolean allowTruncatedHMac() | |
| allowTrustedCAIndication | back to summary |
|---|---|
| protected boolean allowTrustedCAIndication() | |
| checkServerExtensions | back to summary |
|---|---|
| protected Hashtable Deprecated Use 'serverExtensions' directly, it is now never null | |
| getAllowedClientCertificateTypes | back to summary |
|---|---|
| protected short[] getAllowedClientCertificateTypes() | |
| getCertificateRequest | back to summary |
|---|---|
| public CertificateRequest getCertificateRequest() throws IOException Implements org. | |
| getCertificateStatus | back to summary |
|---|---|
| public CertificateStatus getCertificateStatus() throws IOException Implements org. Doc from org. This method will be called (only) if the server included an extension of type
"status_request" with empty "extension_data" in the extended server hello. See RFC 3546
3.6. Certificate Status Request. If a non-null
| |
| getCipherSuites | back to summary |
|---|---|
| public int[] getCipherSuites() Implements org. | |
| getDetailMessageNoCipherSuite | back to summary |
|---|---|
| protected String getDetailMessageNoCipherSuite() | |
| getDHConfig | back to summary |
|---|---|
| public TlsDHConfig getDHConfig() throws IOException Implements org. | |
| getECDHConfig | back to summary |
|---|---|
| public TlsECConfig getECDHConfig() throws IOException Implements org. | |
| getExternalPSK | back to summary |
|---|---|
| public TlsPSKExternal getExternalPSK(Vector<E> identities) Implements org. Doc from org. Warning EXPERIMENTAL FEATURE, UNSTABLE API
Return the
| |
| getMaximumNegotiableCurveBits | back to summary |
|---|---|
| protected int getMaximumNegotiableCurveBits() | |
| getMaximumNegotiableFiniteFieldBits | back to summary |
|---|---|
| protected int getMaximumNegotiableFiniteFieldBits() | |
| getNewConnectionID | back to summary |
|---|---|
| protected byte[] getNewConnectionID() RFC 9146 DTLS connection ID. This method will be called if a connection_id extension was sent by the client. If the return value is non-null, the server will send this connection ID to the client to use in future packets. As future communication doesn't include the connection IDs length, this should either be fixed-length or include the connection ID's length. (see explanation in RFC 9146 4. "cid:")
| |
| getNewSessionID | back to summary |
|---|---|
| public byte[] getNewSessionID() Implements org. | |
| getNewSessionTicket | back to summary |
|---|---|
| public NewSessionTicket getNewSessionTicket() throws IOException Implements org. Doc from org. RFC 5077 3.3. NewSessionTicket Handshake Message. This method will be called (only) if a NewSessionTicket extension was sent by the server. See RFC 5077 4. Recommended Ticket Construction for recommended format and protection.
| |
| getProtocolNames | back to summary |
|---|---|
| protected Vector | |
| getProtocolVersions | back to summary |
|---|---|
| public ProtocolVersion[] getProtocolVersions() Implements org. | |
| getPSKIdentityManager | back to summary |
|---|---|
| public TlsPSKIdentityManager getPSKIdentityManager() throws IOException Implements org. | |
| getSelectedCipherSuite | back to summary |
|---|---|
| public int getSelectedCipherSuite() throws IOException Implements org. | |
| getServerExtensions | back to summary |
|---|---|
| public Hashtable Implements org. | |
| getServerExtensionsForConnection | back to summary |
|---|---|
| public void getServerExtensionsForConnection(Hashtable<K, V> serverExtensions) throws IOException Implements org. | |
| getServerSupplementalData | back to summary |
|---|---|
| public Vector Implements org. | |
| getServerVersion | back to summary |
|---|---|
| public ProtocolVersion getServerVersion() throws IOException Implements org. | |
| getSessionToResume | back to summary |
|---|---|
| public TlsSession getSessionToResume(byte[] sessionID) Implements org. Doc from org. Return the specified session, if available. Note that the peer's certificate chain for the session (if any) may need to be periodically revalidated.
| |
| getSRPLoginParameters | back to summary |
|---|---|
| public TlsSRPLoginParameters getSRPLoginParameters() throws IOException Implements org. | |
| getSupportedGroups | back to summary |
|---|---|
| public int[] getSupportedGroups() throws IOException Implements org. | |
| init | back to summary |
|---|---|
| public void init(TlsServerContext context) Implements org. | |
| isSelectableCipherSuite | back to summary |
|---|---|
| protected boolean isSelectableCipherSuite(int cipherSuite, int availCurveBits, int availFiniteFieldBits, Vector<E> sigAlgs) | |
| notifyClientCertificate | back to summary |
|---|---|
| public void notifyClientCertificate(Certificate clientCertificate) throws IOException Implements org. Doc from org. Called by the protocol handler to report the client certificate, only if
Note this method is responsible for certificate verification and validation.
| |
| notifyClientVersion | back to summary |
|---|---|
| public void notifyClientVersion(ProtocolVersion clientVersion) throws IOException Implements org. | |
| notifyFallback | back to summary |
|---|---|
| public void notifyFallback(boolean isFallback) throws IOException Implements org. | |
| notifyHandshakeBeginning | back to summary |
|---|---|
| public void notifyHandshakeBeginning() throws IOException Overrides org. Implements org. Doc from org. Notifies the peer that a new handshake is about to begin. | |
| notifyOfferedCipherSuites | back to summary |
|---|---|
| public void notifyOfferedCipherSuites(int[] offeredCipherSuites) throws IOException Implements org. | |
| notifySession | back to summary |
|---|---|
| public void notifySession(TlsSession session) Implements org. | |
| preferLocalCipherSuites | back to summary |
|---|---|
| protected boolean preferLocalCipherSuites() | |
| preferLocalClientCertificateTypes | back to summary |
|---|---|
| protected boolean preferLocalClientCertificateTypes() | |
| processClientExtensions | back to summary |
|---|---|
| public void processClientExtensions(Hashtable<K, V> clientExtensions) throws IOException Implements org. | |
| processClientSupplementalData | back to summary |
|---|---|
| public void processClientSupplementalData(Vector<E> clientSupplementalData) throws IOException Implements org. | |
| selectCipherSuite | back to summary |
|---|---|
| protected boolean selectCipherSuite(int cipherSuite) throws IOException | |
| selectDH | back to summary |
|---|---|
| protected int selectDH(int minimumFiniteFieldBits) | |
| selectDHDefault | back to summary |
|---|---|
| protected int selectDHDefault(int minimumFiniteFieldBits) | |
| selectECDH | back to summary |
|---|---|
| protected int selectECDH(int minimumCurveBits) | |
| selectECDHDefault | back to summary |
|---|---|
| protected int selectECDHDefault(int minimumCurveBits) | |
| selectProtocolName | back to summary |
|---|---|
| protected ProtocolName selectProtocolName() throws IOException | |
| selectProtocolName | back to summary |
|---|---|
| protected ProtocolName selectProtocolName(Vector<E> clientProtocolNames, Vector<E> serverProtocolNames) | |
| shouldSelectProtocolNameEarly | back to summary |
|---|---|
| protected boolean shouldSelectProtocolNameEarly() | |