Top Fields
org.bouncycastle.asn1.cmp

public Interface CMPObjectIdentifiers

Imports
org.bouncycastle.asn1.ASN1ObjectIdentifier

Field Summary

Modifier and TypeField and Description
public static final ASN1ObjectIdentifier
ct_encKeyWithID

1.2.840.113549.1.9.16.1.21

id-ct OBJECT IDENTIFIER ::= { id-smime 1 } -- content types

id-ct-encKeyWithID OBJECT IDENTIFIER ::= {id-ct 21}

public static final ASN1ObjectIdentifier
dhBasedMac

id-DHBasedMac OBJECT IDENTIFIER ::= {1 2 840 113533 7 66 30}

public static final ASN1ObjectIdentifier
id_it

RFC 4120: id-it: PKIX.4 = 1.3.6.1.5.5.7.4

public static final ASN1ObjectIdentifier
id_it_caCerts

Update 16, RFC 4210 {id-it 17}

public static final ASN1ObjectIdentifier
id_it_certProfile

Update-16 to RFC 4210 id-it-certProfile OBJECT IDENTIFIER ::= {id-it 21}

public static final ASN1ObjectIdentifier
id_it_certReqTemplate

Update 16, RFC 4210 {id-it 19}

public static final ASN1ObjectIdentifier
public static final ASN1ObjectIdentifier
public static final ASN1ObjectIdentifier
id_it_rootCaCert

Update 16, RFC 4210 GenMsg: {id-it 20}, RootCaCertValue

public static final ASN1ObjectIdentifier
id_it_rootCaKeyUpdate

Update 16, RFC 4210 GenRep: {id-it 18}, RootCaKeyUpdateContent

public static final ASN1ObjectIdentifier
id_pkip

RFC 4211: it-pkip: PKIX.5 = 1.3.6.1.5.5.7.5

public static final ASN1ObjectIdentifier
id_regCtrl

RFC 4211: it-regCtrl: 1.3.6.1.5.5.7.5.1

public static final ASN1ObjectIdentifier
id_regCtrl_algId

id-regCtrl-algId OBJECT IDENTIFIER ::= { iso(1) identified-organization(3) dod(6) internet(1) security(5) mechanisms(5) pkix(7) pkip(5) regCtrl(1) 11 }

public static final ASN1ObjectIdentifier
id_regCtrl_rsaKeyLen

id-regCtrl-rsaKeyLen OBJECT IDENTIFIER ::= { iso(1) identified-organization(3) dod(6) internet(1) security(5) mechanisms(5) pkix(7) pkip(5) regCtrl(1) 12 }

public static final ASN1ObjectIdentifier
id_regInfo

RFC 4211: it-regInfo: 1.3.6.1.5.5.7.5.2

public static final ASN1ObjectIdentifier
it_caKeyUpdateInfo

RFC 4120: 1.3.6.1.5.5.7.4.5

public static final ASN1ObjectIdentifier
it_caProtEncCert

RFC 4120: 1.3.6.1.5.5.7.4.1

public static final ASN1ObjectIdentifier
it_confirmWaitTime

RFC 4120: 1.3.6.1.5.5.7.4.14

public static final ASN1ObjectIdentifier
it_currentCRL

RFC 4120: 1.3.6.1.5.5.7.4.6

public static final ASN1ObjectIdentifier
it_encKeyPairTypes

RFC 4120: 1.3.6.1.5.5.7.4.3

public static final ASN1ObjectIdentifier
it_implicitConfirm

RFC 4120: 1.3.6.1.5.5.7.4.13

public static final ASN1ObjectIdentifier
it_keyPairParamRep

RFC 4120: 1.3.6.1.5.5.7.4.11

public static final ASN1ObjectIdentifier
it_keyPairParamReq

RFC 4120: 1.3.6.1.5.5.7.4.10

public static final ASN1ObjectIdentifier
it_origPKIMessage

RFC 4120: 1.3.6.1.5.5.7.4.15

public static final ASN1ObjectIdentifier
it_preferredSymAlg

RFC 4120: 1.3.6.1.5.5.7.4.4

public static final ASN1ObjectIdentifier
it_revPassphrase

RFC 4120: 1.3.6.1.5.5.7.4.12

public static final ASN1ObjectIdentifier
it_signKeyPairTypes

RFC 4120: 1.3.6.1.5.5.7.4.2

public static final ASN1ObjectIdentifier
it_suppLangTags

RFC 4120: 1.3.6.1.5.5.7.4.16

public static final ASN1ObjectIdentifier
it_unsupportedOIDs

RFC 4120: 1.3.6.1.5.5.7.4.7

public static final ASN1ObjectIdentifier
passwordBasedMac

id-PasswordBasedMac OBJECT IDENTIFIER ::= {1 2 840 113533 7 66 13}

public static final ASN1ObjectIdentifier
regCtrl_altCertTemplate

From RFC4210: id-regCtrl-altCertTemplate OBJECT IDENTIFIER ::= {id-regCtrl 7}; 1.3.6.1.5.5.7.1.7

public static final ASN1ObjectIdentifier
regCtrl_authenticator

1.3.6.1.5.5.7.5.1.2

public static final ASN1ObjectIdentifier
regCtrl_oldCertID

1.3.6.1.5.5.7.5.1.5

public static final ASN1ObjectIdentifier
regCtrl_pkiArchiveOptions

1.3.6.1.5.5.7.5.1.4

public static final ASN1ObjectIdentifier
regCtrl_pkiPublicationInfo

1.3.6.1.5.5.7.5.1.3

public static final ASN1ObjectIdentifier
regCtrl_protocolEncrKey

1.3.6.1.5.5.7.5.1.6

public static final ASN1ObjectIdentifier
regCtrl_regToken

1.3.6.1.5.5.7.5.1.1

public static final ASN1ObjectIdentifier
regInfo_certReq

RFC 4211: it-regInfo-certReq: 1.3.6.1.5.5.7.5.2.1

public static final ASN1ObjectIdentifier
regInfo_utf8Pairs

RFC 4211: it-regInfo-utf8Pairs: 1.3.6.1.5.5.7.5.2.1

Field Detail

ct_encKeyWithIDback to summary
public static final ASN1ObjectIdentifier ct_encKeyWithID

1.2.840.113549.1.9.16.1.21

id-ct OBJECT IDENTIFIER ::= { id-smime 1 } -- content types

id-ct-encKeyWithID OBJECT IDENTIFIER ::= {id-ct 21}

dhBasedMacback to summary
public static final ASN1ObjectIdentifier dhBasedMac

id-DHBasedMac OBJECT IDENTIFIER ::= {1 2 840 113533 7 66 30}

id_itback to summary
public static final ASN1ObjectIdentifier id_it

RFC 4120: id-it: PKIX.4 = 1.3.6.1.5.5.7.4

id_it_caCertsback to summary
public static final ASN1ObjectIdentifier id_it_caCerts

Update 16, RFC 4210 {id-it 17}

id_it_certProfileback to summary
public static final ASN1ObjectIdentifier id_it_certProfile

Update-16 to RFC 4210 id-it-certProfile OBJECT IDENTIFIER ::= {id-it 21}

id_it_certReqTemplateback to summary
public static final ASN1ObjectIdentifier id_it_certReqTemplate

Update 16, RFC 4210 {id-it 19}

id_it_crlsback to summary
public static final ASN1ObjectIdentifier id_it_crls
id_it_crlStatusListback to summary
public static final ASN1ObjectIdentifier id_it_crlStatusList
id_it_rootCaCertback to summary
public static final ASN1ObjectIdentifier id_it_rootCaCert

Update 16, RFC 4210 GenMsg: {id-it 20}, RootCaCertValue

id_it_rootCaKeyUpdateback to summary
public static final ASN1ObjectIdentifier id_it_rootCaKeyUpdate

Update 16, RFC 4210 GenRep: {id-it 18}, RootCaKeyUpdateContent

id_pkipback to summary
public static final ASN1ObjectIdentifier id_pkip

RFC 4211: it-pkip: PKIX.5 = 1.3.6.1.5.5.7.5

id_regCtrlback to summary
public static final ASN1ObjectIdentifier id_regCtrl

RFC 4211: it-regCtrl: 1.3.6.1.5.5.7.5.1

id_regCtrl_algIdback to summary
public static final ASN1ObjectIdentifier id_regCtrl_algId

id-regCtrl-algId OBJECT IDENTIFIER ::= { iso(1) identified-organization(3) dod(6) internet(1) security(5) mechanisms(5) pkix(7) pkip(5) regCtrl(1) 11 }

id_regCtrl_rsaKeyLenback to summary
public static final ASN1ObjectIdentifier id_regCtrl_rsaKeyLen

id-regCtrl-rsaKeyLen OBJECT IDENTIFIER ::= { iso(1) identified-organization(3) dod(6) internet(1) security(5) mechanisms(5) pkix(7) pkip(5) regCtrl(1) 12 }

id_regInfoback to summary
public static final ASN1ObjectIdentifier id_regInfo

RFC 4211: it-regInfo: 1.3.6.1.5.5.7.5.2

it_caKeyUpdateInfoback to summary
public static final ASN1ObjectIdentifier it_caKeyUpdateInfo

RFC 4120: 1.3.6.1.5.5.7.4.5

it_caProtEncCertback to summary
public static final ASN1ObjectIdentifier it_caProtEncCert

RFC 4120: 1.3.6.1.5.5.7.4.1

it_confirmWaitTimeback to summary
public static final ASN1ObjectIdentifier it_confirmWaitTime

RFC 4120: 1.3.6.1.5.5.7.4.14

it_currentCRLback to summary
public static final ASN1ObjectIdentifier it_currentCRL

RFC 4120: 1.3.6.1.5.5.7.4.6

it_encKeyPairTypesback to summary
public static final ASN1ObjectIdentifier it_encKeyPairTypes

RFC 4120: 1.3.6.1.5.5.7.4.3

it_implicitConfirmback to summary
public static final ASN1ObjectIdentifier it_implicitConfirm

RFC 4120: 1.3.6.1.5.5.7.4.13

it_keyPairParamRepback to summary
public static final ASN1ObjectIdentifier it_keyPairParamRep

RFC 4120: 1.3.6.1.5.5.7.4.11

it_keyPairParamReqback to summary
public static final ASN1ObjectIdentifier it_keyPairParamReq

RFC 4120: 1.3.6.1.5.5.7.4.10

it_origPKIMessageback to summary
public static final ASN1ObjectIdentifier it_origPKIMessage

RFC 4120: 1.3.6.1.5.5.7.4.15

it_preferredSymAlgback to summary
public static final ASN1ObjectIdentifier it_preferredSymAlg

RFC 4120: 1.3.6.1.5.5.7.4.4

it_revPassphraseback to summary
public static final ASN1ObjectIdentifier it_revPassphrase

RFC 4120: 1.3.6.1.5.5.7.4.12

it_signKeyPairTypesback to summary
public static final ASN1ObjectIdentifier it_signKeyPairTypes

RFC 4120: 1.3.6.1.5.5.7.4.2

it_suppLangTagsback to summary
public static final ASN1ObjectIdentifier it_suppLangTags

RFC 4120: 1.3.6.1.5.5.7.4.16

it_unsupportedOIDsback to summary
public static final ASN1ObjectIdentifier it_unsupportedOIDs

RFC 4120: 1.3.6.1.5.5.7.4.7

passwordBasedMacback to summary
public static final ASN1ObjectIdentifier passwordBasedMac

id-PasswordBasedMac OBJECT IDENTIFIER ::= {1 2 840 113533 7 66 13}

regCtrl_altCertTemplateback to summary
public static final ASN1ObjectIdentifier regCtrl_altCertTemplate

From RFC4210: id-regCtrl-altCertTemplate OBJECT IDENTIFIER ::= {id-regCtrl 7}; 1.3.6.1.5.5.7.1.7

regCtrl_authenticatorback to summary
public static final ASN1ObjectIdentifier regCtrl_authenticator

1.3.6.1.5.5.7.5.1.2

regCtrl_oldCertIDback to summary
public static final ASN1ObjectIdentifier regCtrl_oldCertID

1.3.6.1.5.5.7.5.1.5

regCtrl_pkiArchiveOptionsback to summary
public static final ASN1ObjectIdentifier regCtrl_pkiArchiveOptions

1.3.6.1.5.5.7.5.1.4

regCtrl_pkiPublicationInfoback to summary
public static final ASN1ObjectIdentifier regCtrl_pkiPublicationInfo

1.3.6.1.5.5.7.5.1.3

regCtrl_protocolEncrKeyback to summary
public static final ASN1ObjectIdentifier regCtrl_protocolEncrKey

1.3.6.1.5.5.7.5.1.6

regCtrl_regTokenback to summary
public static final ASN1ObjectIdentifier regCtrl_regToken

1.3.6.1.5.5.7.5.1.1

regInfo_certReqback to summary
public static final ASN1ObjectIdentifier regInfo_certReq

RFC 4211: it-regInfo-certReq: 1.3.6.1.5.5.7.5.2.1

regInfo_utf8Pairsback to summary
public static final ASN1ObjectIdentifier regInfo_utf8Pairs

RFC 4211: it-regInfo-utf8Pairs: 1.3.6.1.5.5.7.5.2.1