Top Description Methods
org.conscrypt

pack-priv Interface ConscryptSession

extends SSLSession
Known Direct Implementers
org.conscrypt.ExternalSession, org.conscrypt.ActiveSession, org.conscrypt.Java7ExtendedSSLSession, org.conscrypt.SessionSnapshot, org.conscrypt.SSLNullSession
Imports
java.security.cert.X509Certificate, java.util.List, javax.net.ssl.SSLPeerUnverifiedException, .SSLSession

Extends the default interface for SSLSession to provide additional properties exposed by Conscrypt.

Method Summary

Modifier and TypeMethod and Description
public String
public X509Certificate[]
getPeerCertificates()

Redeclares javax.net.ssl.SSLSession.getPeerCertificates.

Returns the identity of the peer which was established as part of defining the session.
public byte[]
getPeerSignedCertificateTimestamp()

Returns the signed certificate timestamp (SCT) received from the peer.

public String
public List<byte[]>
getStatusResponses()

Returns the OCSP stapled response.

Inherited from javax.net.ssl.SSLSession:
getApplicationBufferSizegetCipherSuitegetCreationTimegetIdgetLastAccessedTimegetLocalCertificatesgetLocalPrincipalgetPacketBufferSizegetPeerCertificateChaingetPeerHostgetPeerPortgetPeerPrincipalgetProtocolgetSessionContextgetValuegetValueNamesinvalidateisValidputValueremoveValue

Method Detail

getApplicationProtocolback to summary
public String getApplicationProtocol()
getPeerCertificatesback to summary
public X509Certificate[] getPeerCertificates() throws SSLPeerUnverifiedException

Redeclares javax.net.ssl.SSLSession.getPeerCertificates.

Doc from javax.net.ssl.SSLSession.getPeerCertificates.

Returns the identity of the peer which was established as part of defining the session.

Note

This method can be used only when using certificate-based cipher suites; using it with non-certificate-based cipher suites, such as Kerberos, will throw an SSLPeerUnverifiedException.

Note

The returned value may not be a valid certificate chain and should not be relied on for trust decisions.

Returns:X509Certificate[]

an ordered array of peer certificates, with the peer's own certificate first followed by any certificate authorities.

Annotations
@Override
Exceptions
SSLPeerUnverifiedException:
if the peer's identity has not been verified
getPeerSignedCertificateTimestampback to summary
public byte[] getPeerSignedCertificateTimestamp()

Returns the signed certificate timestamp (SCT) received from the peer. Returns a copy of the internal array.

See Also
RFC 6962
getRequestedServerNameback to summary
public String getRequestedServerName()
getStatusResponsesback to summary
public List<byte[]> getStatusResponses()

Returns the OCSP stapled response. Returns a copy of the internal arrays. The method signature matches Java 9.

See Also
RFC 6066, RFC 6961