Top Interfaces Classes
module org.eclipse.jetty.client

Package org.eclipse.jetty.client


Interface Summary

Modifier and TypeInterface and Description
public interface
Authentication

Authentication represents a mechanism to authenticate requests for protected resources.

public interface
public interface
Connection

Connection represent a connection to a Destination and allow applications to send requests via send(Request, Response.CompleteListener).

public interface
ConnectionPool

Client-side connection pool abstraction.

public interface
ContentDecoder

ContentDecoder decodes content bytes of a response.

public interface
ContentResponse

A specialized Response that can hold a limited content in memory.

public interface
Destination

A Destination represents the receiver of HTTP requests, and it is identified by an Origin.

public interface
HttpClientTransport

HttpClientTransport represents what transport implementations should provide in order to plug-in a different transport for HttpClient.

public interface
HttpUpgrader

HttpUpgrader prepares a HTTP request to upgrade from one protocol to another, and implements the upgrade mechanism.

public interface
ProtocolHandler

A protocol handler performs HTTP protocol operations on behalf of the application, typically like a browser would.

public interface
Request

Request represents an HTTP request, and offers a fluent interface to customize various attributes such as the path, the headers, the content, etc.

You can create Request objects via HttpClient#newRequest(String) and you can send them using either send() for a blocking semantic, or send(Response.CompleteListener) for an asynchronous semantic.

public interface
Response

Response represents an HTTP response and offers methods to retrieve status code, HTTP version and headers.

Class Summary

Modifier and TypeClass and Description
public abstract class
public abstract class
public abstract class
public abstract class
public class
public abstract class
public class
BasicAuthentication

Implementation of the HTTP "Basic" authentication defined in RFC 2617.

public abstract class
BufferingResponseListener

Implementation of Listener that buffers the content up to a maximum length specified to the constructors.

public class
public class
public class
CompletableResponseListener

A BufferingResponseListener that sends a Request and returns a CompletableFuture that is completed when onComplete(Result) is called.

public class
ContinueProtocolHandler

A protocol handler that handles the 100 response code.

public class
DigestAuthentication

Implementation of the HTTP "Digest" authentication defined in RFC 2617.

public class
public class
EarlyHintsProtocolHandler

A protocol handler that handles the 103 response code.

public class
FormRequestContent

A Request.Content for form uploads with the "application/x-www-form-urlencoded" content type.

public class
FutureResponseListener

Deprecated Use CompletableResponseListener instead
A BufferingResponseListener that is also a Future, to allow applications to block (indefinitely or for a timeout) until onComplete(Result) is called, or to abort the request/response conversation.
public class
GZIPContentDecoder

ContentDecoder for the "gzip" encoding.

public class
HttpClient

HttpClient provides an efficient, asynchronous, non-blocking implementation to perform HTTP requests to a server through a simple API that offers also blocking semantic.

public class
public class
HttpRedirector

Utility class that handles HTTP redirects.

public class
public class
public class
InputStreamRequestContent

A Request.Content that produces content from an InputStream.

public class
InputStreamResponseListener

Implementation of Listener that produces an InputStream that allows applications to read the response content.

public class
MultiPartRequestContent

A Request.Content for form uploads with the "multipart/form-data" content type.

public class
public class
Origin

Class that groups the elements that uniquely identify a destination.

public class
OutputStreamRequestContent

A Request.Content that provides content asynchronously through an OutputStream similar to AsyncRequestContent.

public class
PathRequestContent

A Request.Content for files using JDK 7's java.nio.file APIs.

public class
ProcessingProtocolHandler

A protocol handler that handles the 102 response code.

public class
public class
ProxyAuthenticationProtocolHandler

A protocol handler that handles the 401 response code in association with the Proxy-Authenticate header.

public class
ProxyConfiguration

The configuration of the forward proxies to use with org.eclipse.jetty.client.HttpClient.

public abstract class
ProxyProtocolClientConnectionFactory

ClientConnectionFactory for the PROXY protocol.

public class
RandomConnectionPool

A ConnectionPool that provides connections randomly among the ones that are available.

public class
RedirectProtocolHandler

A protocol handler that handles redirect status codes 301, 302, 303, 307 and 308.

public class
RequestListeners

A specialized container for request listeners.

public class
Result

The result of a request / response exchange, containing the Request, the Response and eventual failures of either.

public class
RoundRobinConnectionPool

A ConnectionPool that attempts to provide connections using a round-robin algorithm.

public class
public class
Socks5

Helper class for SOCKS5 proxying.

public class
Socks5Proxy

Client-side proxy configuration for SOCKS5, defined by RFC 1928.

public class
SPNEGOAuthentication

Implementation of the SPNEGO (or "Negotiate") authentication defined in RFC 4559.

public class
public class
UpgradeProtocolHandler

A protocol handler that handles HTTP 101 responses.

public class
ValidatingConnectionPool

A connection pool that validates connections before making them available for use.

public class
WWWAuthenticationProtocolHandler

A protocol handler that handles the 401 response code in association with the WWW-Authenticate header.