Top Description Interfaces Classes Enums
module org.eclipse.jetty.http

Package org.eclipse.jetty.http


Jetty Http : Tools for Http processing

Interface Summary

Modifier and TypeInterface and Description
public interface
ComplianceViolation

A Compliance Violation represents a requirement of an RFC, specification or Jetty implementation that may be allowed to be violated if it is included in a ComplianceViolation.Mode.

public interface
CookieParser

Cookie parser.

public interface
HttpCookie

Implementation of RFC6265 HTTP Cookies (with fallback support for RFC2965).

public interface
HttpCookieStore

A container for HttpCookies.

public interface
HttpException

A tagging interface for Exceptions that carry a HTTP response code and reason.

public interface
HttpFieldPreEncoder

Interface to pre-encode HttpFields.

public interface
HttpFields

An ordered collection of HttpFields that represent the HTTP headers or HTTP trailers of an HTTP request or an HTTP response.

public interface
HttpURI

Http URI.

public interface
SetCookieParser

A parser for Set-Cookie header values.

Class Summary

Modifier and TypeClass and Description
public class
BadMessageException

Exception thrown to indicate a Bad HTTP Message has either been received or attempted to be generated.

public class
public class
public class
CookieCache

Cookie parser

Optimized stateful cookie parser.

public class
CookieCompliance

The compliance mode for Cookie handling.

public class
CookieCutter

Deprecated
Cookie parser
public class
DateGenerator

ThreadLocal Date formatters for HTTP style dates.

public class
DateParser

ThreadLocal data parsers for HTTP style dates

pack-priv class
public class
EtagUtils

Utility classes for Entity Tag behaviors as outlined in RFC9110 : Section 8.8.3 - Entity Tag

public class
GZIPContentDecoder

Decoder for the "gzip" content encoding.

public class
HostPortHttpField

An HttpField holding a preparsed Host and port number

public class
public class
public abstract class
public class
HttpCompliance

HTTP compliance modes for Jetty HTTP parsing and handling.

public class
HttpField

An immutable class representing an HTTP header or trailer.

public class
HttpGenerator

HttpGenerator.

public class
HttpParser

A Parser for 1.0 and 1.1 as defined by RFC7230

This parser parses HTTP client and server messages from buffers passed in the parseNext(ByteBuffer) method.

public class
HttpStatus

Http Status Codes

public class
HttpTester

HTTP Testing helper class.

public class
HttpTokens

HTTP constants

pack-priv class
ImmutableHttpFields

HTTP Fields.

public class
MetaData

Immutable common HTTP information for requests and responses.

public class
MimeTypes

MIME Type enum and utilities

public class
MultiPart

Namespace class for interrelated classes that provide support for parsing and generating multipart bytes.

public class
MultiPartByteRanges

A CompletableFuture that is completed when a multipart/byteranges has been parsed asynchronously from a Content.Source.

public class
MultiPartCompliance

The compliance mode for MultiPart handling.

public class
MultiPartFormData

A CompletableFuture that is completed when a multipart/form-data content has been parsed asynchronously from a Content.Source.

pack-priv class
MutableHttpFields

HTTP Fields.

public class
PreEncodedHttpField

Pre encoded HttpField.

public class
QuotedCSV

Implements a quoted comma separated list of values in accordance with RFC7230.

public abstract class
QuotedCSVParser

Implements a quoted comma separated list parser in accordance with RFC9110 section 5.6.

public class
QuotedQualityCSV

Implements a quoted comma separated list of quality values in accordance with RFC7230 and RFC7231.

public class
RFC6265CookieParser

Cookie parser

public class
RFC6265SetCookieParser

A parser for Set-Cookie header values following RFC 6265.

public class
Syntax

Collection of Syntax validation methods.

public class
public class
UriCompliance

URI compliance modes for Jetty request handling.

Enum Summary

Modifier and TypeEnum and Description
public enum
public enum
public enum
HttpMethod

Known HTTP Methods

public enum
HttpScheme

HTTP and WebSocket Schemes

public enum