| Modifier and Type | Interface and Description |
|---|---|
| public interface | Authentication
|
| public interface | AuthenticationStore
A store for |
| public interface | Connection
|
| public interface | ConnectionPool
Client-side connection pool abstraction. |
| public interface | ContentDecoder
|
| public interface | ContentResponse
A specialized |
| public interface | Destination
A |
| public interface | HttpClientTransport
|
| public interface | HttpUpgrader
HttpUpgrader prepares a HTTP request to upgrade from one protocol to another, and implements the upgrade mechanism. |
| public interface | ProtocolHandler
A protocol handler performs HTTP protocol operations on behalf of the application, typically like a browser would. |
| public interface | Request
You can create |
| public interface |
| Modifier and Type | Class and Description |
|---|---|
| public abstract class | |
| public abstract class | |
| public abstract class | |
| public abstract class | |
| public class | |
| public abstract class | |
| public class | BasicAuthentication
Implementation of the HTTP "Basic" authentication defined in RFC 2617. |
| public abstract class | BufferingResponseListener
Implementation of |
| public class | |
| public class | BytesRequestContent
A |
| public class | CompletableResponseListener
A |
| public class | ContinueProtocolHandler
A protocol handler that handles the 100 response code. |
| public class | DigestAuthentication
Implementation of the HTTP "Digest" authentication defined in RFC 2617. |
| public class | |
| public class | EarlyHintsProtocolHandler
A protocol handler that handles the 103 response code. |
| public class | FormRequestContent
A |
| public class | FutureResponseListener
Deprecated
Use A CompletableResponseListener instead
BufferingResponseListener that is also a Future, to allow applications
to block (indefinitely or for a timeout) until onComplete(Result) is called,
or to abort the request/response conversation.
|
| public class | GZIPContentDecoder
|
| public class | HttpClient
HttpClient provides an efficient, asynchronous, non-blocking implementation to perform HTTP requests to a server through a simple API that offers also blocking semantic. |
| public class | |
| public class | HttpRedirector
Utility class that handles HTTP redirects. |
| public class | |
| public class | |
| public class | InputStreamRequestContent
A |
| public class | InputStreamResponseListener
Implementation of |
| public class | MultiPartRequestContent
A |
| public class | |
| public class | Origin
Class that groups the elements that uniquely identify a destination. |
| public class | OutputStreamRequestContent
A |
| public class | PathRequestContent
A |
| public class | ProcessingProtocolHandler
A protocol handler that handles the 102 response code. |
| public class | ProtocolHandlers
A container for |
| public class | ProxyAuthenticationProtocolHandler
A protocol handler that handles the 401 response code
in association with the |
| public class | ProxyConfiguration
The configuration of the forward proxies to use with
|
| public abstract class | ProxyProtocolClientConnectionFactory
ClientConnectionFactory for the PROXY protocol. |
| public class | RandomConnectionPool
A |
| public class | RedirectProtocolHandler
A protocol handler that handles redirect status codes 301, 302, 303, 307 and 308. |
| public class | RequestListeners
A specialized container for request listeners. |
| public class | |
| public class | RoundRobinConnectionPool
A |
| public class | |
| public class | Socks5
Helper class for SOCKS5 proxying. |
| public class | Socks5Proxy
Client-side proxy configuration for SOCKS5, defined by RFC 1928. |
| public class | SPNEGOAuthentication
Implementation of the SPNEGO (or "Negotiate") authentication defined in RFC 4559. |
| public class | StringRequestContent
A |
| public class | UpgradeProtocolHandler
A protocol handler that handles HTTP 101 responses. |
| public class | ValidatingConnectionPool
A connection pool that validates connections before making them available for use. |
| public class | WWWAuthenticationProtocolHandler
A protocol handler that handles the 401 response code
in association with the |