Implementation of RFC6265 HTTP Cookies (with fallback support for RFC2965).
| Modifier and Type | Class and Description |
|---|---|
| public static class | HttpCookie.
A builder for |
| public static class | HttpCookie.
Immutable implementation of |
| public static class | HttpCookie.
A |
| public static enum | HttpCookie.
The possible values for the |
| public static class | HttpCookie.
A wrapper for |
| Modifier and Type | Field and Description |
|---|---|
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String | |
| public static final String |
| Modifier and Type | Method and Description |
|---|---|
| public static HttpCookie | Returns: a newjava.the cookie to convert httpCookie)Converts a |
| private static String | |
| public static HttpCookie. | |
| public static HttpCookie. | |
| public static HttpCookie. | Returns: a newBuilder initialized with the given cookiethe cookie to copy httpCookie)Creates a |
| public static HttpCookie. | Returns: a newBuilder initialized with the given cookiethe httpCookie)java. to copyCreates a |
| public boolean | |
| public static boolean | Returns: whether the cookies are equalthe first cookie to equal cookie1, Object the second cookie to equal obj)Implementation of |
| private static boolean | |
| public static String | Returns: the instant formatted as an RFC 1123 stringthe expiration instant expires)Formats the |
| public static HttpCookie | |
| public static HttpCookie | from(String
the name of the cookie name, String the value of the cookie value, Map<String, String> the map of attributes to use with this cookie (this map is used for field values
such as attributes)getDomain(), getPath(), getMaxAge(), isHttpOnly(),
isSecure(), isPartitioned(), getComment(), plus any newly defined
attributes unknown to this code base.Creates a new |
| public static HttpCookie | from(String
the name of the cookie name, String the value of the cookie value, int the version of the cookie (only used in RFC2965 mode) version, Map<String, String> the map of attributes to use with this cookie (this map is used for field values
such as attributes)getDomain(), getPath(), getMaxAge(), isHttpOnly(),
isSecure(), isPartitioned(), getComment(), plus any newly defined
attributes unknown to this code base.Creates a new |
| public static HttpCookie | from(HttpCookie
A cookie to base the new cookie on. cookie, String... Additional name value pairs of strings to use as additional attributes additionalAttributes)Returns: A new cookie based on the passed cookie plus additional attributes. |
| public static HttpCookie | from(HttpCookie
the httpCookie)java. instance to copyCreates a new |
| public Map | |
| public default String | Returns: the value of theComment attributeEquivalent to |
| public default String | Returns: the value of theDomain attributeEquivalent to |
| public default Instant | |
| public default long | |
| public String | |
| public default String | |
| public default HttpCookie. | |
| public String | |
| public int | |
| public int | |
| public static int | Returns: the hash code of the cookiethe cookie to be hashed httpCookie)Implementation of |
| public default boolean | |
| public default boolean | |
| public default boolean | |
| public default boolean | |
| private static Map | |
| private static Map | |
| private static Map | |
| public static Instant | Returns: anInstant parsed from the given stringan instant in the RFC 1123 string format expires)Parses the |
| public static String | Returns: a logging string representation of the cookiethe cookie to format httpCookie)Formats this cookie into a string suitable to be used for logging. |