| Modifier and Type | Interface and Description |
|---|---|
| pack-priv interface | AESConstants
This class defines the constants used by the AES implementation. |
| pack-priv interface | BlowfishConstants
This class defines the constants used by the Blowfish algorithm implementation. |
| pack-priv interface | DESConstants
This class defines the constants used by the DES implementation. |
| public interface | GCM
This interface allows GHASH.java and GCTR.java to easily operate to better operate with GaloisCounterMode.java |
| pack-priv interface | Padding
Padding interface. |
| Modifier and Type | Class and Description |
|---|---|
| pack-priv class | AEADBufferedStream
This class extends ByteArrayOutputStream by optimizing internal buffering. |
| pack-priv class | AES_Crypt
Implementation of the AES cipher, which is based on the following documents: |
| pack-priv class | AESCipher
This class implements the AES algorithm in its various modes
( |
| public class | AESKeyGenerator
This class generates an AES key. |
| pack-priv class | AESKeyWrap
This class implement the AES KeyWrap mode of operation as defined in "Recommendation for Block Cipher Modes of Operation: Methods for Key Wrapping" and represents AES cipher in KW mode. |
| pack-priv class | AESKeyWrapPadded
This class implement the AES KeyWrap With Padding mode of operation as defined in "Recommendation for Block Cipher Modes of Operation: Methods for Key Wrapping" and represents AES cipher in KWP mode. |
| public class | AESParameters
This class implements the parameter (IV) used with the AES algorithm in feedback-mode. |
| public class | ARCFOURCipher
Implementation of the ARCFOUR cipher, an algorithm apparently compatible with RSA Security's RC4(tm) cipher. |
| pack-priv class | BlockCipherParamsCore
This class implements the parameter (IV) used with Block Ciphers in feedback-mode. |
| public class | BlowfishCipher
This class implements the Blowfish algorithm in its various modes
( |
| pack-priv class | BlowfishCrypt
This is the internal Blowfish class responsible for encryption and
decryption of a byte array of size |
| public class | BlowfishKeyGenerator
This class generates a secret key for use with the Blowfish algorithm. |
| public class | BlowfishParameters
This class implements the parameter (IV) used with the Blowfish algorithm in feedback-mode. |
| pack-priv abstract class | ChaCha20Cipher
Implementation of the ChaCha20 cipher, as described in RFC 7539. |
| public class | ChaCha20Poly1305Parameters
This class implements the parameter set used with the ChaCha20-Poly1305 algorithm. |
| pack-priv class | CipherBlockChaining
This class represents ciphers in cipher block chaining (CBC) mode. |
| pack-priv class | CipherCore
This class represents the symmetric algorithms in its various modes
( |
| pack-priv class | CipherFeedback
This class represents ciphers in cipher-feedback (CFB) mode. |
| pack-priv class | |
| pack-priv class | CipherTextStealing
This class represents ciphers in cipher text stealing (CTS) mode. |
| pack-priv class | ConstructKeys
This class is a helper class which construct key objects from encoded keys. |
| pack-priv class | CounterMode
This class represents ciphers in counter (CTR) mode. |
| public class | DESCipher
This class implements the DES algorithm in its various modes
( |
| pack-priv class | DESCrypt
This is the internal DES class responsible for encryption and
decryption of a byte array of size |
| public class | DESedeCipher
This class implements the DESede algorithm (DES-EDE, tripleDES) in
its various modes ( |
| pack-priv class | DESedeCrypt
This class implements the Triple DES algorithm (DES encryption, followed by
DES decryption, followed by DES encryption) on a byte array of size
|
| pack-priv class | DESedeKey
This class represents a DES-EDE key. |
| public class | DESedeKeyFactory
This class implements the DES-EDE key factory of the Sun provider. |
| public class | DESedeKeyGenerator
This class generates a Triple DES key. |
| public class | DESedeParameters
This class implements the parameter (IV) used with the Triple DES algorithm in feedback-mode. |
| public class | DESedeWrapCipher
This class implements the CMS DESede KeyWrap algorithm as defined in "XML Encryption Syntax and Processing" section 5.6.2 "CMS Triple DES Key Wrap". |
| pack-priv class | DESKey
This class represents a DES key. |
| public class | DESKeyFactory
This class implements the DES key factory of the Sun provider. |
| public class | DESKeyGenerator
This class generates a DES key. |
| public class | DESParameters
This class implements the parameter (IV) used with the DES algorithm in feedback-mode. |
| public class | |
| public class | DHKeyAgreement
This class implements the Diffie-Hellman key agreement protocol between any number of parties. |
| public class | DHKeyFactory
This class implements the Diffie-Hellman key factory of the Sun provider. |
| public class | DHKeyPairGenerator
This class represents the key pair generator for Diffie-Hellman key pairs. |
| public class | |
| public class | DHParameters
This class implements the parameter set used by the Diffie-Hellman key agreement as defined in the PKCS #3 standard. |
| pack-priv class | DHPrivateKey
A private key in PKCS#8 format for the Diffie-Hellman key agreement algorithm. |
| pack-priv class | DHPublicKey
A public key in X.509 format for the Diffie-Hellman key agreement algorithm. |
| pack-priv class | ElectronicCodeBook
This class represents ciphers in electronic codebook (ECB) mode. |
| pack-priv class | EncryptedPrivateKeyInfo
This class implements the
EncryptedPrivateKeyInfo ::= SEQUENCE {
encryptionAlgorithm AlgorithmIdentifier,
encryptedData OCTET STRING }
|
| pack-priv abstract class | FeedbackCipher
This class represents a block cipher in one of its modes. |
| pack-priv abstract class | GaloisCounterMode
This class represents ciphers in GaloisCounter (GCM) mode. |
| pack-priv class | GCTR
This class represents the GCTR function defined in NIST 800-38D under section 6.5. |
| pack-priv class | GHASH
This class represents the GHASH function defined in NIST 800-38D under section 6.4. |
| pack-priv abstract class | HKDFKeyDerivation
KDF implementation for the HKDF function. |
| pack-priv abstract class | HmacCore
This class constitutes the core of HMAC-<MD> algorithms, where <MD> is the digest algorithm used by HMAC as in RFC 2104 "HMAC: Keyed-Hashing for Message Authentication". |
| public class | HmacMD5
This is an implementation of the HMAC-MD5 algorithm. |
| public class | HmacMD5KeyGenerator
This class generates a secret key for use with the HMAC-MD5 algorithm. |
| pack-priv abstract class | HmacPKCS12PBECore
This is an implementation of the HMAC algorithms as defined in PKCS#12 v1.1 standard (see RFC 7292 Appendix B.4). |
| public class | HmacSHA1
This is an implementation of the HMAC-SHA1 algorithm. |
| public class | HmacSHA1KeyGenerator
This class generates a secret key for use with the HMAC-SHA1 algorithm. |
| public class | |
| pack-priv class | ISO10126Padding
This class implements padding as specified in the W3 XML ENC standard. |
| public class | JceKeyStore
This class provides the keystore implementation referred to as "jceks". |
| pack-priv class | KeyGeneratorCore
KeyGeneratore core implementation and individual key generator implementations. |
| pack-priv class | KeyProtector
This class implements a protection mechanism for private keys. |
| pack-priv abstract class | KeyWrapCipher
This class is the impl class for AES KeyWrap algorithms as defined in "Recommendation for Block Cipher Modes of Operation: Methods for Key Wrapping" |
| pack-priv class | KWUtil
This class acts as the base class for AES KeyWrap algorithms as defined in "Recommendation for Block Cipher Modes of Operation: Methods for Key Wrapping" |
| public class | |
| public class | |
| public class | OAEPParameters
This class implements the OAEP parameters used with the RSA algorithm in OAEP padding. |
| pack-priv class | OutputFeedback
This class represents ciphers in output-feedback (OFB) mode. |
| pack-priv class | PBEKey
This class represents a PBE key. |
| pack-priv abstract class | PBEKeyFactory
This class implements a key factory for PBE keys according to PKCS#5, meaning that the password must consist of printable ASCII characters (values 32 to 126 decimal inclusive) and only the low order 8 bits of each password character are used. |
| public class | PBEParameters
This class implements the parameter set used with password-based encryption, which is defined in PKCS#5 as follows:
PBEParameter ::= SEQUENCE {
salt OCTET STRING SIZE(8),
iterationCount INTEGER }
|
| pack-priv class | PBES1Core
This class represents password-based encryption as defined by the PKCS #5 standard. |
| pack-priv abstract class | PBES2Core
This class represents password-based encryption as defined by the PKCS #5 standard. |
| pack-priv abstract class | PBES2Parameters
This class implements the parameter set used with password-based encryption scheme 2 (PBES2), which is defined in PKCS#5 as follows:
-- PBES2
PBES2Algorithms ALGORITHM-IDENTIFIER ::=
{ {PBES2-params IDENTIFIED BY id-PBES2}, ...}
id-PBES2 OBJECT IDENTIFIER ::= {pkcs-5 13}
PBES2-params ::= SEQUENCE {
keyDerivationFunc AlgorithmIdentifier {{PBES2-KDFs}},
encryptionScheme AlgorithmIdentifier {{PBES2-Encs}} }
PBES2-KDFs ALGORITHM-IDENTIFIER ::=
{ {PBKDF2-params IDENTIFIED BY id-PBKDF2}, ...
|
| public class | PBEWithMD5AndDESCipher
This class represents password-based encryption as defined by the PKCS #5 standard. |
| public class | PBEWithMD5AndTripleDESCipher
This class implements a proprietary password-based encryption algorithm. |
| pack-priv abstract class | PBKDF2Core
This class implements a key factory for PBE keys derived using PBKDF2 with HmacSHA1, HmacSHA224, HmacSHA256, HmacSHA384, HmacSHA512, HmacSHA512/224, and HmacSHA512/256 pseudo random function (PRF) as defined in PKCS#5 v2.1. |
| public class | PBKDF2KeyImpl
This class represents a PBE key derived using PBKDF2 defined in PKCS#5 v2.0. |
| pack-priv abstract class | PBMAC1Core
This is an implementation of the PBMAC1 algorithms as defined in PKCS#5 v2.1 standard. |
| pack-priv class | PCBC
This class represents ciphers in Plaintext Cipher Block Chaining (PCBC) mode. |
| pack-priv class | PKCS12PBECipherCore
This class implements password-base encryption algorithm with SHA1 digest and the following Ciphers (in CBC mode, where applicable): - DESede cipher and - RC2 Cipher with 40-bit or 128-bit effective key length and - RC4 Cipher with 40-bit or 128-bit effective key length as defined by PKCS #12 version 1.0 standard. |
| pack-priv class | PKCS5Padding
This class implements padding as specified in the PKCS#5 standard. |
| pack-priv class | Poly1305
This class represents the Poly1305 function defined in RFC 7539. |
| pack-priv class | PrivateKeyInfo
This class implements the
PrivateKeyInfo ::= SEQUENCE {
version INTEGER,
privateKeyAlgorithm AlgorithmIdentifier,
privateKey OCTET STRING,
attributes [0] IMPLICIT Attributes OPTIONAL }
|
| public class | RC2Cipher
JCE CipherSpi for the RC2(tm) algorithm as described in RFC 2268. |
| pack-priv class | RC2Crypt
Implementation of the RC2(tm) algorithm as described in RFC 2268. |
| public class | RC2Parameters
This class implements the parameter set used with RC2 encryption, which is defined in RFC2268 as follows:
RC2-CBCParameter ::= CHOICE {
iv IV,
params SEQUENCE {
version RC2Version,
iv IV
}
}
where
IV ::= OCTET STRING -- 8 octets
RC2Version ::= INTEGER -- 1-1024
|
| public class | RSACipher
RSA cipher implementation. |
| public class | RSACipherAdaptor
NONEwithRSA Signature implementation using the RSA/ECB/PKCS1Padding Cipher implementation from SunJCE. |
| pack-priv class | |
| pack-priv class | SslMacCore
This file contains the code for the SslMacMD5 and SslMacSHA1 implementations. |
| public class | SunJCE
Defines the "SunJCE" provider. |
| pack-priv abstract class | SymmetricCipher
This abstract class represents the core of all block ciphers. |
| public class | TlsKeyMaterialGenerator
KeyGenerator implementation for the SSL/TLS master secret derivation. |
| public class | TlsMasterSecretGenerator
KeyGenerator implementation for the SSL/TLS master secret derivation. |
| pack-priv abstract class | TlsPrfGenerator
KeyGenerator implementation for the TLS PRF function. |
| public class | TlsRsaPremasterSecretGenerator
KeyGenerator implementation for the SSL/TLS RSA premaster secret. |