APIdia Launch Partner
Top Interfaces Classes
module java.naming

Package com.sun.jndi.ldap


Interface Summary

Modifier and TypeInterface and Description
pack-priv interface

Class Summary

Modifier and TypeClass and Description
pack-priv abstract class
AbstractLdapNamingEnumeration<T extends NameClassPair>

Basic enumeration for NameClassPair, Binding, and SearchResults.

public class
BasicControl

This class provides a basic implementation of the Control interface.

public abstract class
Ber

Base class that defines common fields, constants, and debug method.

public class
BerDecoder

A BER decoder.

public class
BerEncoder

A BER encoder.

pack-priv class
pack-priv class
ClientId

Represents identity information about an anonymous LDAP connection.

public class
Connection

A thread that creates a connection to an LDAP server.

public class
public class
DefaultResponseControlFactory

This class represents a factory for creating LDAPv3 response controls.

pack-priv class
DigestClientId

Extends SimpleClientId to add property values specific for Digest-MD5.

public class
EntryChangeResponseControl

This class implements the LDAPv3 Response Control for entry-change notification as defined in draft-ietf-ldapext-psearch-02.txt.

pack-priv class
EventQueue

Package private class used by EventSupport to dispatch events.

pack-priv class
EventSupport

This is a utility class that can be used by a context that supports event notification.

pack-priv class
Filter

LDAP (RFC-1960) and LDAPv3 (RFC-2254) search filters.

pack-priv class
LdapAttribute

This subclass is used by LDAP to implement the schema calls.

pack-priv class
public class
LdapClient

LDAP (RFC-1777) and LDAPv3 (RFC-2251) compliant client This class represents a connection to an LDAP client.

pack-priv class
LdapClientFactory

Creates an LdapClient.

public class
LdapCtx

The LDAP context implementation.

public class
pack-priv class
LdapDnsProviderService

The LdapDnsProviderService is responsible for creating and providing access to the registered LdapDnsProviders.

pack-priv class
LdapEntry

A holder for an LDAP entry read from an LDAP server.

public class
LdapName

LdapName implements compound names for LDAP v3 as specified by RFC 2253.

pack-priv class
pack-priv class
public class
LdapPoolManager

Contains utilities for managing connection pools of LdapClient.

pack-priv class
LdapReferralContext

A context for handling referrals.

public class
LdapReferralException

This exception is raised when a referral to an alternative context is encountered.

pack-priv class
public class
LdapResult

%%% public for use by LdapSasl %%%

pack-priv class
LdapSchemaCtx

This is the class used to implement LDAP's GetSchema call.

pack-priv class
LdapSchemaParser

Netscape's 3.1 servers have some schema bugs: - It puts quotes around OIDs (such as those for SUP, SYNTAX).

pack-priv class
public class
public class
ManageReferralControl

This class implements the LDAPv3 Request Control for manageDsaIT as defined in draft-ietf-ldapext-namedref-00.txt.

pack-priv class
pack-priv class
NamingEventNotifier

Gathers information to generate events by using the Persistent Search control.

pack-priv class
NotifierArgs

This class holds the information in an event registration/deregistration request.

pack-priv class
Obj

Class containing static methods and constants for dealing with encoding/decoding JNDI References and Serialized Objects in LDAP.

public class
PersistentSearchControl

This class implements the LDAPv3 Request Control for the persistent search mechanism as defined in draft-ietf-ldapext-psearch-02.txt.

pack-priv class
pack-priv class
ServiceLocator

This class discovers the location of LDAP services by querying DNS.

pack-priv class
SimpleClientId

Represents the identity of a 'simple' authenticated LDAP connection.

pack-priv class
UnsolicitedResponseImpl

A concrete implementation of an UnsolicitedNotification.