Aside from some minor deviations noted below, an instance of this class represents a URI reference as defined by RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax, amended by RFC 2732: Format for Literal IPv6 Addresses in URLs. The Literal IPv6 address format also supports scope_ids. The syntax and usage of scope_ids is described here. This class provides constructors for creating URI instances from their components or by parsing their string forms, methods for accessing the various components of an instance, and methods for normalizing, resolving, and relativizing URI instances. Instances of this class are immutable.
[schemewhere square brackets [...] delineate optional components and the characters:]scheme-specific-part[#fragment]
: and # stand for themselves.
An absolute URI specifies a scheme; a URI that is not absolute is said to be relative. URIs are also classified according to whether they are opaque or hierarchical.
An opaque URI is an absolute URI whose scheme-specific part does
not begin with a slash character ('/'). Opaque URIs are not
subject to further parsing. Some examples of opaque URIs are:
mailto:java-net@www.example.comnews:comp.lang.javaurn:isbn:096139210x
A hierarchical URI is either an absolute URI whose scheme-specific part begins with a slash character, or a relative URI, that is, a URI that does not specify a scheme. Some examples of hierarchical URIs are:
http://example.com/languages/java/
sample/a/index.html#28
../../demo/b/index.html
file:///~/calendar
A hierarchical URI is subject to further parsing according to the syntax
[schemewhere the characters:][//authority][path][?query][#fragment]
:, /,
?, and # stand for themselves. The
scheme-specific part of a hierarchical URI consists of the characters
between the scheme and fragment components.
The authority component of a hierarchical URI is, if specified, either server-based or registry-based. A server-based authority parses according to the familiar syntax
[user-infowhere the characters@]host[:port]
@ and : stand for
themselves. Nearly all URI schemes currently in use are server-based. An
authority component that does not parse in this way is considered to be
registry-based.
The path component of a hierarchical URI is itself said to be absolute
if it begins with a slash character ('/'); otherwise it is
relative. The path of a hierarchical URI that is either absolute or
specifies an authority is always absolute.
All told, then, a URI instance has the following nine components:
| Component | Type |
|---|---|
| scheme | String |
| scheme-specific-part | String |
| authority | String |
| user-info | String |
| host | String |
| port | int |
| path | String |
| query | String |
| fragment | String |
null, while undefined integer components are
represented by -1. A string component may be defined to have the
empty string as its value; this is not equivalent to that component being
undefined.
Whether a particular component is or is not defined in an instance depends upon the type of the URI being represented. An absolute URI has a scheme component. An opaque URI has a scheme, a scheme-specific part, and possibly a fragment, but has no other components. A hierarchical URI always has a path (though it may be empty) and a scheme-specific-part (which at least contains the path), and may have any of the other components. If the authority component is present and is server-based then the host component will be defined and the user-information and port components may be defined.
Normalization is the process of removing unnecessary "."
and ".." segments, and redundant "/" (empty segments) from
the path component of a hierarchical URI. Each "." and empty segment
is simply removed. A ".." segment is removed only if it is preceded
by a non-".." segment. Normalization has no effect upon opaque URIs.
Resolution is the process of resolving one URI against another, base URI. The resulting URI is constructed from components of both URIs in the manner specified by RFC 2396, taking components from the base URI for those not specified in the original. For hierarchical URIs, the path of the original is resolved against the path of the base and then normalized. The result, for example, of resolving
sample/a/index.html#28
(1)
against the base URI http://example.com/languages/java/ is the result
URI
http://example.com/languages/java/sample/a/index.html#28
Resolving the relative URI
../../demo/b/index.html (2)
against this result yields, in turn,
http://example.com/languages/java/demo/b/index.html
Resolution of both absolute and relative URIs, and of both absolute and
relative paths in the case of hierarchical URIs, is supported. Resolving
the URI file:///~calendar against any other URI simply yields the
original URI, since it is absolute. Resolving the relative URI (2) above
against the relative base URI (1) yields the normalized, but still relative,
URI
demo/b/index.html
Relativization, finally, can be regarded as the inverse of resolution.
Let u be any normalized absolute URI ending with a slash character ('/')
and v be any normalized relative URI not beginning with a period character ('.')
or slash character ('/'). Then, the following statement is true:
uLet u be any normalized absolute URI ending with a slash character (.relativize(u.resolve(v)).equals(v)
'/')
and v be any normalized absolute URI. Then, the following statement is true:
uThis operation is often useful when constructing a document containing URIs that must be made relative to the base URI of the document wherever possible. For example, relativizing the URI.resolve(u.relativize(v)).equals(v)
http://example.com/languages/java/sample/a/index.html#28
against the base URI
http://example.com/languages/java/
yields the relative URI sample/a/index.html#28.
| Category | Description |
|---|---|
| alpha | The US-ASCII alphabetic characters,
'A' through 'Z'
and 'a' through 'z' |
| digit | The US-ASCII decimal digit characters,
'0' through '9' |
| alphanum | All alpha and digit characters |
| unreserved | All alphanum characters together with those in the string
"_-!.~'()*" |
| punct | The characters in the string ",;:$&+=" |
| reserved | All punct characters together with those in the string
"?/[]@" |
| escaped | Escaped octets, that is, triplets consisting of the percent
character ('%') followed by two hexadecimal digits
('0'-'9', 'A'-'F', and
'a'-'f') |
| other | The Unicode characters that are not in the US-ASCII character set,
are not control characters (according to the Character.
method), and are not space characters (according to the Character.
method) (Deviation from RFC 2396, which is
limited to US-ASCII) |
The set of all legal URI characters consists of the unreserved, reserved, escaped, and other characters.
To encode non-US-ASCII characters when a URI is required to conform strictly to RFC 2396 by not containing any other characters.
To quote characters that are otherwise illegal in a component. The user-info, path, query, and fragment components differ slightly in terms of which characters are considered legal and illegal.
A character is encoded by replacing it
with the sequence of escaped octets that represent that character in the
UTF-8 character set. The Euro currency symbol ('\u20AC'),
for example, is encoded as "%E2%82%AC". (Deviation from
RFC 2396, which does not specify any particular character
set.)
An illegal character is quoted simply by
encoding it. The space character, for example, is quoted by replacing it
with "%20". UTF-8 contains US-ASCII, hence for US-ASCII
characters this transformation has exactly the effect required by
RFC 2396.
A sequence of escaped octets is decoded by
replacing it with the sequence of characters that it represents in the
UTF-8 character set. UTF-8 contains US-ASCII, hence decoding has the
effect of de-quoting any quoted US-ASCII characters as well as that of
decoding any encoded non-US-ASCII characters. If a decoding error occurs
when decoding the escaped octets then the erroneous octets are replaced by
'\uFFFD', the Unicode replacement character.
The single-argument constructor requires any illegal characters in its argument to be quoted and preserves any escaped octets and other characters that are present.
The multi-argument constructors quote illegal characters as
required by the components in which they appear. The percent character
('%') is always quoted by these constructors. Any other
characters are preserved.
The getRawUserInfo, getRawPath, getRawQuery, getRawFragment, getRawAuthority, and getRawSchemeSpecificPart methods return the
values of their corresponding components in raw form, without interpreting
any escaped octets. The strings returned by these methods may contain
both escaped octets and other characters, and will not contain any
illegal characters.
The getUserInfo, getPath, getQuery, getFragment, getAuthority, and getSchemeSpecificPart methods decode any escaped
octets in their corresponding components. The strings returned by these
methods may contain both other characters and illegal characters,
and will not contain any escaped octets.
The toString method returns a URI string with
all necessary quotation but which may contain other characters.
The toASCIIString method returns a fully
quoted and encoded URI string that does not contain any other
characters.
For any URI u that does not contain redundant syntax such as two slashes before an empty authority (as innew URI(u.toString()).equals(u).
file:///tmp/ ) or a
colon following a host name but no port (as in
http://www.example.com: ), and that does not encode characters
except those that must be quoted, the following identities also hold:
new URI(u.getScheme(),
u.getSchemeSpecificPart(),
u.getFragment())
.equals(u)
in all cases,
new URI(u.getScheme(),
u.getAuthority(),
u.getPath(), u.getQuery(),
u.getFragment())
.equals(u)
if u is hierarchical, and
new URI(u.getScheme(),
u.getUserInfo(), u.getHost(), u.getPort(),
u.getPath(), u.getQuery(),
u.getFragment())
.equals(u)
if u is hierarchical and has either no authority or a server-based
authority.
mailto, news, and
isbn URIs shown above are examples of URNs.
The conceptual distinction between URIs and URLs is reflected in the
differences between this class and the URL class.
An instance of this class represents a URI reference in the syntactic sense defined by RFC 2396. A URI may be either absolute or relative. A URI string is parsed according to the generic syntax without regard to the scheme, if any, that it specifies. No lookup of the host, if any, is performed, and no scheme-dependent stream handler is constructed. Equality, hashing, and comparison are defined strictly in terms of the character content of the instance. In other words, a URI instance is little more than a structured string that supports the syntactic, scheme-independent operations of comparison, normalization, resolution, and relativization.
An instance of the URL class, by contrast, represents the
syntactic components of a URL together with some of the information required
to access the resource that it describes. A URL must be absolute, that is,
it must always specify a scheme. A URL string is parsed according to its
scheme. A stream handler is always established for a URL, and in fact it is
impossible to create a URL instance for a scheme for which no handler is
available. Equality and hashing depend upon both the scheme and the
Internet address of the host, if any; comparison is not defined. In other
words, a URL is a structured string that supports the syntactic operation of
resolution as well as the network I/O operations of looking up the host and
opening a connection to the specified resource.
API Note
Applications working with file paths and file URIs should take great
care to use the appropriate methods to convert between the two.
The Path#of(URI) factory method and the File#File(URI)
constructor can be used to create Path or File
objects from a file URI. Path#toUri() and File#toURI()
can be used to create a URI from a file path.
Applications should never try to construct, parse, or
resolve a URI
from the direct string representation of a File or Path
instance.
Some components of a URL or URI, such as userinfo, may be abused to construct misleading URLs or URIs. Applications that deal with URLs or URIs should take into account the recommendations advised in RFC3986, Section 7, Security Considerations.
| Modifier and Type | Class and Description |
|---|---|
| private class |
| Modifier and Type | Field and Description |
|---|---|
| private transient String | |
| private transient String | |
| private transient String | |
| private transient String | |
| private transient String | |
| private transient String | |
| private transient String | |
| private transient String | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private transient int | |
| private static final char[] | |
| private transient String | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private static final long | |
| private transient String | |
| private transient int | |
| private transient String | |
| private transient String | |
| private transient String | |
| pack-priv static final long | |
| private volatile String | string
The string form of this URI. |
| private transient String |
| Access | Constructor and Description |
|---|---|
| private | |
| public | |
| public | |
| public | |
| public | |
| public | |
| pack-priv |
| Modifier and Type | Method and Description |
|---|---|
| private void | |
| private static void | |
| private static void | |
| private void | |
| private void | appendSchemeSpecificPart(StringBuilder sb, String opaquePart, String authority, String userInfo, String host, int port, String path, String query)
|
| private static void | |
| private static int | |
| private static int | |
| public int | Returns: A negative integer, zero, or a positive integer as this URI is less than, equal to, or greater than the given URIThe object to which this URI is to be compared that)Implements java. Compares this URI to another object, which must be a URI. |
| public static URI | |
| private static int | |
| private static byte | |
| private static String | |
| private static String | |
| private String | |
| private static String | |
| private static boolean | |
| private static boolean | |
| public boolean | Returns: true if, and only if, the given object is a URI that
is identical to this URIThe object to which this object is to be compared ob)Overrides java. Tests this URI for equality with another object. |
| public String | Returns: The decoded authority component of this URI, ornull if the authority is undefinedReturns the decoded authority component of this URI. |
| public String | Returns: The decoded fragment component of this URI, ornull if the fragment is undefinedReturns the decoded fragment component of this URI. |
| public String | Returns: The host component of this URI, ornull if the host is undefinedReturns the host component of this URI. |
| public String | Returns: The decoded path component of this URI, ornull if the path is undefinedReturns the decoded path component of this URI. |
| public int | Returns: The port component of this URI, or-1 if the port is undefinedReturns the port number of this URI. |
| public String | Returns: The decoded query component of this URI, ornull if the query is undefinedReturns the decoded query component of this URI. |
| public String | Returns: The raw authority component of this URI, ornull if the authority is undefinedReturns the raw authority component of this URI. |
| public String | Returns: The raw fragment component of this URI, ornull if the fragment is undefinedReturns the raw fragment component of this URI. |
| public String | Returns: The path component of this URI, ornull if the path is undefinedReturns the raw path component of this URI. |
| public String | Returns: The raw query component of this URI, ornull if the query is undefinedReturns the raw query component of this URI. |
| public String | Returns: The raw scheme-specific part of this URI (nevernull)Returns the raw scheme-specific part of this URI. |
| public String | Returns: The raw user-information component of this URI, ornull if the user information is undefinedReturns the raw user-information component of this URI. |
| public String | Returns: The scheme component of this URI, ornull if the scheme is undefinedReturns the scheme component of this URI. |
| public String | Returns: The decoded scheme-specific part of this URI (nevernull)Returns the decoded scheme-specific part of this URI. |
| public String | Returns: The decoded user-information component of this URI, ornull if the user information is undefinedReturns the decoded user-information component of this URI. |
| private static int | |
| public int | Returns: A hash-code value for this URIOverrides java. Returns a hash-code value for this URI. |
| private static int | |
| public boolean | Returns: true if, and only if, this URI is absoluteTells whether or not this URI is absolute. |
| public boolean | |
| private static int | |
| private static boolean | |
| private static void | |
| private static int | |
| public URI | Returns: A URI equivalent to this URI, but whose path is in normal formNormalizes this URI's path. |
| private static URI | |
| private static String | |
| private static int | |
| public URI | Returns: A URI whose authority field has been parsed as a server-based authorityAttempts to parse this URI's authority component, if defined, into user-information, host, and port components. |
| private static int | |
| private static String | |
| private void | readObject(ObjectInputStream
The object-input stream from which this object
is being read is)Reconstitutes a URI from the given serial stream. |
| public URI | Returns: The resulting URIThe URI to be relativized against this URI uri)Relativizes the given URI against this URI. |
| private static URI | |
| private static void | |
| public URI | |
| public URI | |
| private static URI | |
| private static String | |
| private static void | |
| public String | Returns: The string form of this URI, encoded as needed so that it only contains characters in the US-ASCII charsetReturns the content of this URI as a US-ASCII string. |
| private static int | |
| public String | Returns: The string form of this URIOverrides java. Returns the content of this URI as a string. |
| private String | |
| private static int | |
| public URL | |
| private static boolean | |
| private void | writeObject(ObjectOutputStream
The object-output stream to which this object
is to be written os)Saves the content of this URI to the given serial stream. |