| Modifier and Type | Class and Description |
|---|---|
| public class | AesDkCrypto
This class provides the implementation of AES Encryption for Kerberos as defined RFC 3962. |
| public class | AesSha2DkCrypto
This class provides the implementation of AES Encryption with HMAC-SHA2 for Kerberos 5 https://tools.ietf.org/html/rfc8009 Algorithm profile described in [KCRYPTO]: +--------------------------------------------------------------------+ | protocol key format 128- or 256-bit string | | | | string-to-key function PBKDF2+DK with variable | | iteration count (see | | above) | | | | default string-to-key parameters 00 00 80 00 | | | | key-generation seed length key size | | | | random-to-key function identity function | | | | hash function, H SHA-256 / SHA-384 | | | | HMAC output size, h 16/24 octets | | | | message block size, m 1 octet | | | | encryption/decryption functions, AES in CBC-CTS mode | | E and D (cipher block size 16 | | octets), with next to | | last block as CBC-style | | ivec | +--------------------------------------------------------------------+ Supports aes128-cts-hmac-sha256-128 and aes256-cts-hmac-sha384-192 |
| public class | ArcFourCrypto
Support for ArcFour in Kerberos as defined in RFC 4757. |
| public class | |
| public abstract class | DkCrypto
Implements Derive Key cryptography functionality as defined in RFC 3961. |