[RFC 5280 4.2.1.6 Subject Alternative Name] When the subjectAltName extension contains an iPAddress, the address MUST be stored in the octet string in "network byte order", as specified in [RFC791]. The least significant bit (LSB) of each octet is the LSB of the corresponding byte in the network address. For IP version 4, as specified in [RFC791], the octet string MUST contain exactly four octets. For IP version 6, as specified in [RFC 2460], the octet string MUST contain exactly sixteen octets.
[RFC 5280 4.2.1.10 Name Constraints] The syntax of iPAddress MUST be as described in Section 4.2.1.6 with the following additions specifically for name constraints. For IPv4 addresses, the iPAddress field of GeneralName MUST contain eight (8) octets, encoded in the style of RFC 4632 (CIDR) to represent an address range [RFC 4632]. For IPv6 addresses, the iPAddress field MUST contain 32 octets similarly encoded. For example, a name constraint for "class C" subnet 192.0.2.0 is represented as the octets C0 00 02 00 FF FF FF 00, representing the CIDR notation 192.0.2.0/24 (mask 255.255.255.0).
GeneralName, GeneralNameInterface, GeneralNames
| Modifier and Type | Field and Description |
|---|---|
| private byte[] | |
| private final boolean | |
| private static final int | MASKSIZE
Parse an IPv6 address. |
| private String |
| Access | Constructor and Description |
|---|---|
| public | IPAddressName(DerValue
the encoded DER IPAddressName. derValue)Create the IPAddressName object from the passed encoded Der value. |
| public | IPAddressName(byte[]
the IP address address)Create the IPAddressName object with the specified octets. |
| public |
| Modifier and Type | Method and Description |
|---|---|
| public int | Returns: constraint type aboveto be checked for being constrained inputName)Implements sun. Return type of constraint inputName places on this name:
|
| public void | encode(DerOutputStream
the DER stream to encode the IPAddressName to. out)Implements sun. Encode the IPAddress name into the DerOutputStream. |
| public boolean | Returns: true iff the names are identical.Overrides java. Compares this name with another, for equality. |
| public byte[] | |
| public String | |
| public int | getType()
Implements sun. Return the type of the GeneralName. |
| public int | Returns: the hash code value for this objectOverrides java. Returns the hash code value for this object. |
| private void | |
| private void | |
| public int | Returns: distance of name from rootImplements sun. Return subtree depth of this name for purposes of determining NameConstraints minimum and maximum bounds and for calculating path lengths in name subtrees. |
| public String |
| address | back to summary |
|---|---|
| private byte[] address | |
| isIPv4 | back to summary |
|---|---|
| private final boolean isIPv4 | |
| MASKSIZE | back to summary |
|---|---|
| private static final int MASKSIZE Parse an IPv6 address. | |
| name | back to summary |
|---|---|
| private String name | |
| IPAddressName | back to summary |
|---|---|
| public IPAddressName(DerValue derValue) throws IOException Create the IPAddressName object from the passed encoded Der value.
| |
| IPAddressName | back to summary |
|---|---|
| public IPAddressName(byte[] address) throws IOException Create the IPAddressName object with the specified octets.
| |
| IPAddressName | back to summary |
|---|---|
| public IPAddressName(String name) throws IOException Create an IPAddressName from a String. [IETF RFC1338 Supernetting & IETF RFC1519 Classless Inter-Domain Routing (CIDR)] For IPv4 addresses, the forms are "b1.b2.b3.b4" or "b1.b2.b3.b4/m1.m2.m3.m4", where b1 - b4 are decimal byte values 0-255 and m1 - m4 are decimal mask values 0 - 255. [IETF RFC2373 IP Version 6 Addressing Architecture] For IPv6 addresses, the forms are "a1:a2:...:a8" or "a1:a2:...:a8/n", where a1-a8 are hexadecimal values representing the eight 16-bit pieces of the address. If /n is used, n is a decimal number indicating how many of the leftmost contiguous bits of the address comprise the prefix for this subnet. Internally, a mask value is created using the prefix length.
| |
| constrains | back to summary |
|---|---|
| public int constrains(GeneralNameInterface inputName) throws UnsupportedOperationException Implements sun. Return type of constraint inputName places on this name:
[RFC 5280 4.2.1.10 Name Constraints] The syntax of iPAddress MUST be as described in Section 4.2.1.6 with the following additions specifically for name constraints. For IPv4 addresses, the iPAddress field of GeneralName MUST contain eight (8) octets, encoded in the style of RFC 4632 (CIDR) to represent an address range [RFC 4632]. For IPv6 addresses, the iPAddress field MUST contain 32 octets similarly encoded. For example, a name constraint for "class C" subnet 192.0.2.0 is represented as the octets C0 00 02 00 FF FF FF 00, representing the CIDR notation 192.0.2.0/24 (mask 255.255.255.0).
| |
| encode | back to summary |
|---|---|
| public void encode(DerOutputStream out) Implements sun. Encode the IPAddress name into the DerOutputStream.
| |
| equals | back to summary |
|---|---|
| public boolean equals(Object obj) Overrides java. Compares this name with another, for equality.
| |
| getBytes | back to summary |
|---|---|
| public byte[] getBytes() Returns this IPAddress name as a byte array. | |
| getName | back to summary |
|---|---|
| public String getName() throws IOException Return a standard String representation of IPAddress. See IPAddressName(String) for the formats used for IPv4 and IPv6 addresses.
| |
| getType | back to summary |
|---|---|
| public int getType() Implements sun. Return the type of the GeneralName. | |
| hashCode | back to summary |
|---|---|
| public int hashCode() Overrides java. Returns the hash code value for this object.
| |
| parseIPv4 | back to summary |
|---|---|
| private void parseIPv4(String name) throws IOException Parse an IPv4 address.
| |
| parseIPv6 | back to summary |
|---|---|
| private void parseIPv6(String name) throws IOException | |
| subtreeDepth | back to summary |
|---|---|
| public int subtreeDepth() throws UnsupportedOperationException Implements sun. Return subtree depth of this name for purposes of determining NameConstraints minimum and maximum bounds and for calculating path lengths in name subtrees.
| |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Return a printable string of IPaddress | |