| Modifier and Type | Field and Description |
|---|---|
| public static final String | AcceptRanges
What partial content range types this server supports. |
| public static final String | AccessControlAllowOrigin
Specifying which web sites can participate in cross-origin resource sharing. |
| public static final String | Age
The age the object has been in a proxy cache in seconds. |
| public static final String | Allow
Valid actions for a specified resource. |
| public static final String | CacheControl
Tells all caching mechanisms from server to client whether they may cache this object. |
| public static final String | Connection
Options that are desired for the connection. |
| public static final String | ContentDisposition
An opportunity to raise a "File Download" dialogue box for a known MIME type with binary format or suggest a filename for dynamic content. |
| public static final String | ContentEncoding
The type of encoding used on the data. |
| public static final String | |
| public static final String | ContentLength
The length of the response body in octets (8-bit bytes). |
| public static final String | ContentLocation
An alternate location for the returned data. |
| public static final String | ContentMD5
A Base64-encoded binary MD5 sum of the content of the response. |
| public static final String | ContentRange
Where in a full body message this partial message belongs. |
| public static final String | ContentType
The MIME type of this content. |
| public static final String | Date
The date and time that the message was sent (in "HTTP-date" format as defined by RFC 7231). |
| public static final String | ETag
An identifier for a specific version of a resource, often a message digest. |
| public static final String | Expires
Gives the date/time after which the response is considered stale. |
| public static final String | LastModified
The last modified date for the requested object (in "HTTP-date" format as defined by RFC 7231). |
| public static final String | Link
Used to express a typed relationship with another resource, where the relation type is defined by RFC 5988.</feed> |
| public static final String | Location
Used in redirection, or when a new resource has been created. |
| public static final String | P3P
This field is supposed to set P3P policy, in the form of P3P:CP="your_compact_policy". |
| public static final String | Pragma
Implementation-specific fields that may have various effects anywhere along the request-response chain. |
| public static final String | ProxyAuthenticate
Request authentication to access the proxy. |
| public static final String | Refresh
Used in redirection, or when a new resource has been created. |
| public static final String | RetryAfter
If an entity is temporarily unavailable, this instructs the client to try again later. |
| public static final String | Server
A name for the server. |
| public static final String | SetCookie
An HTTP cookie. |
| public static final String | Status
CGI header field specifying the status of the HTTP response. |
| public static final String | StrictTransportSecurity
A HSTS Policy informing the HTTP client how long to cache the HTTPS only policy and whether this applies to subdomains. |
| public static final String | Trailer
The Trailer general field value indicates that the given set of header fields is present in the trailer of a message encoded with chunked transfer coding. |
| public static final String | TransferEncoding
The form of encoding used to safely transfer the entity to the user. |
| public static final String | Upgrade
Ask the client to upgrade to another protocol. |
| public static final String | Vary
Tells downstream proxies how to match future request headers to decide whether the cached response can be used rather than requesting a fresh one from the origin server. |
| public static final String | Via
Informs the client of proxies through which the response was sent. |
| public static final String | Warning
A general warning about possible problems with the entity body. |
| public static final String | WWWAuthenticate
Indicates the authentication scheme that should be used to access the requested entity. |
| AcceptRanges | back to summary |
|---|---|
| public static final String AcceptRanges What partial content range types this server supports. Example: Accept-Ranges: bytes | |
| AccessControlAllowOrigin | back to summary |
|---|---|
| public static final String AccessControlAllowOrigin Specifying which web sites can participate in cross-origin resource sharing. Example: Access-Control-Allow-Origin: * | |
| Age | back to summary |
|---|---|
| public static final String Age The age the object has been in a proxy cache in seconds. Example: Age: 12 | |
| Allow | back to summary |
|---|---|
| public static final String Allow Valid actions for a specified resource. To be used for a 405 Method not allowed. Example: Allow: GET, HEAD | |
| CacheControl | back to summary |
|---|---|
| public static final String CacheControl Tells all caching mechanisms from server to client whether they may cache this object. It is measured in seconds. Example: Cache-Control: max-age=3600 | |
| Connection | back to summary |
|---|---|
| public static final String Connection Options that are desired for the connection. Example: Connection: close | |
| ContentDisposition | back to summary |
|---|---|
| public static final String ContentDisposition An opportunity to raise a "File Download" dialogue box for a known MIME type with binary format or suggest a filename for dynamic content. Quotes are necessary with special characters. Example: Content-Disposition: attachment; filename="fname.ext" | |
| ContentEncoding | back to summary |
|---|---|
| public static final String ContentEncoding The type of encoding used on the data. See HTTP compression. Example: Content-Encoding: gzip | |
| ContentLanguage | back to summary |
|---|---|
| public static final String ContentLanguage The language the content is in. Example: Content-Language: da | |
| ContentLength | back to summary |
|---|---|
| public static final String ContentLength The length of the response body in octets (8-bit bytes). Example: Content-Length: 348 | |
| ContentLocation | back to summary |
|---|---|
| public static final String ContentLocation An alternate location for the returned data. Example: Content-Location: /index.htm | |
| ContentMD5 | back to summary |
|---|---|
| public static final String ContentMD5 A Base64-encoded binary MD5 sum of the content of the response. Example: Content-MD5: Q2hlY2sgSW50ZWdyaXR5IQ== | |
| ContentRange | back to summary |
|---|---|
| public static final String ContentRange Where in a full body message this partial message belongs. Example: Content-Range: bytes 21010-47021/47022 | |
| ContentType | back to summary |
|---|---|
| public static final String ContentType The MIME type of this content. Example: Content-Type: text/html; charset=utf-8 | |
| Date | back to summary |
|---|---|
| public static final String Date The date and time that the message was sent (in "HTTP-date" format as defined by RFC 7231). Example: Date: Tue, 15 Nov 1994 08:12:31 GMT | |
| ETag | back to summary |
|---|---|
| public static final String ETag An identifier for a specific version of a resource, often a message digest. Example: ETag: "737060cd8c284d8af7ad3082f209582d" | |
| Expires | back to summary |
|---|---|
| public static final String Expires Gives the date/time after which the response is considered stale. Example: Expires: Thu, 01 Dec 1994 16:00:00 GMT | |
| LastModified | back to summary |
|---|---|
| public static final String LastModified The last modified date for the requested object (in "HTTP-date" format as defined by RFC 7231). Example: Last-Modified: Tue, 15 Nov 1994 12:45:26 GMT | |
| Link | back to summary |
|---|---|
| public static final String Link Used to express a typed relationship with another resource, where the relation type is defined by RFC 5988. Example: Link: ; rel="alternate" | |
| Location | back to summary |
|---|---|
| public static final String Location Used in redirection, or when a new resource has been created. Example: Location: http://www.w3.org/pub/WWW/People.html | |
| P3P | back to summary |
|---|---|
| public static final String P3P This field is supposed to set P3P policy, in the form of P3P:CP="your_compact_policy". However, P3P did not take off, most browsers have never fully implemented it, a lot of websites set this field with fake policy text, that was enough to fool browsers the existence of P3P policy and grant permissions for third party cookies. Example: P3P: CP= "This is not a P3P policy! See http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=151657 for more info." | |
| Pragma | back to summary |
|---|---|
| public static final String Pragma Implementation-specific fields that may have various effects anywhere along the request-response chain. Example: Pragma: no-cache | |
| ProxyAuthenticate | back to summary |
|---|---|
| public static final String ProxyAuthenticate Request authentication to access the proxy. Example: Proxy-Authenticate: Basic | |
| Refresh | back to summary |
|---|---|
| public static final String Refresh Used in redirection, or when a new resource has been created. This refresh redirects after 5 seconds. Example: Refresh: 5; url=http://www.w3.org/pub/WWW/People.html | |
| RetryAfter | back to summary |
|---|---|
| public static final String RetryAfter If an entity is temporarily unavailable, this instructs the client to try again later. Value could be a specified period of time (in seconds) or a HTTP-date. Example: Example 1: Retry-After: 120Example 2: Retry-After: Fri, 07 Nov 2014 23:59:59 GMT | |
| Server | back to summary |
|---|---|
| public static final String Server A name for the server. Example: Server: Apache/2.4.1 (Unix) | |
| SetCookie | back to summary |
|---|---|
| public static final String SetCookie An HTTP cookie. Example: Set-Cookie: UserID=JohnDoe; Max-Age=3600; Version=1 | |
| Status | back to summary |
|---|---|
| public static final String Status CGI header field specifying the status of the HTTP response. Normal HTTP responses use a separate "Status-Line" instead, defined by RFC 7230. Example: Status: 200 OK | |
| StrictTransportSecurity | back to summary |
|---|---|
| public static final String StrictTransportSecurity A HSTS Policy informing the HTTP client how long to cache the HTTPS only policy and whether this applies to subdomains. Example: Strict-Transport-Security: max-age=16070400; includeSubDomains | |
| Trailer | back to summary |
|---|---|
| public static final String Trailer The Trailer general field value indicates that the given set of header fields is present in the trailer of a message encoded with chunked transfer coding. Example: Trailer: Max-Forwards | |
| TransferEncoding | back to summary |
|---|---|
| public static final String TransferEncoding The form of encoding used to safely transfer the entity to the user. Currently defined methods are: chunked, compress, deflate, gzip, identity. Example: Transfer-Encoding: chunked | |
| Upgrade | back to summary |
|---|---|
| public static final String Upgrade Ask the client to upgrade to another protocol. Example: Upgrade: HTTP/2.0, SHTTP/1.3, IRC/6.9, RTA/x11 | |
| Vary | back to summary |
|---|---|
| public static final String Vary Tells downstream proxies how to match future request headers to decide whether the cached response can be used rather than requesting a fresh one from the origin server. Example: Vary: * | |
| Via | back to summary |
|---|---|
| public static final String Via Informs the client of proxies through which the response was sent. Example: Via: 1.0 fred, 1.1 example.com (Apache/1.1) | |
| Warning | back to summary |
|---|---|
| public static final String Warning A general warning about possible problems with the entity body. Example: Warning: 199 Miscellaneous warning | |
| WWWAuthenticate | back to summary |
|---|---|
| public static final String WWWAuthenticate Indicates the authentication scheme that should be used to access the requested entity. Example: WWW-Authenticate: Basic | |