APIdia Launch Partner
Top Description Fields Constructors Methods
com.badlogic.gdx.net

public Class HttpStatus

extends Object
Class Inheritance
Imports
com.badlogic.gdx.Net.HttpRequest, .Net.HttpResponse

This implementation is widely based Apache's HttpStatus which uses license (Apache license 2.0) - http://www.apache.org/licenses/LICENSE-2.0 For more information on the Apache Software Foundation, please see https://www.apache.org. Contains information about the HTTP status line returned with the HttpResponse after a HttpRequest was performed. Also contains constants enumerating the HTTP Status Codes. All status codes defined in RFC1945 (HTTP/1.0), RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are listed.

Field Summary

Modifier and TypeField and Description
public static final int
SC_ACCEPTED

202 Accepted (HTTP/1.0 - RFC 1945)

public static final int
SC_BAD_GATEWAY

502 Bad Gateway (HTTP/1.0 - RFC 1945)

public static final int
SC_BAD_REQUEST

400 Bad Request (HTTP/1.1 - RFC 2616)

public static final int
SC_CONFLICT

409 Conflict (HTTP/1.1 - RFC 2616)

public static final int
SC_CONTINUE

100 Continue (HTTP/1.1 - RFC 2616)

public static final int
SC_CREATED

201 Created (HTTP/1.0 - RFC 1945)

public static final int
SC_EXPECTATION_FAILED

417 Expectation Failed (HTTP/1.1 - RFC 2616)

public static final int
SC_FAILED_DEPENDENCY

424 Failed Dependency (WebDAV - RFC 2518)

public static final int
SC_FORBIDDEN

403 Forbidden (HTTP/1.0 - RFC 1945)

public static final int
SC_GATEWAY_TIMEOUT

504 Gateway Timeout (HTTP/1.1 - RFC 2616)

public static final int
SC_GONE

410 Gone (HTTP/1.1 - RFC 2616)

public static final int
SC_HTTP_VERSION_NOT_SUPPORTED

505 HTTP Version Not Supported (HTTP/1.1 - RFC 2616)

public static final int
SC_INSUFFICIENT_SPACE_ON_RESOURCE

Static constant for a 419 error.

public static final int
SC_INSUFFICIENT_STORAGE

507 Insufficient Storage (WebDAV - RFC 2518)

public static final int
SC_INTERNAL_SERVER_ERROR

500 Server Error (HTTP/1.0 - RFC 1945)

public static final int
SC_LENGTH_REQUIRED

411 Length Required (HTTP/1.1 - RFC 2616)

public static final int
SC_LOCKED

423 Locked (WebDAV - RFC 2518)

public static final int
SC_METHOD_FAILURE

Static constant for a 420 error.

public static final int
SC_METHOD_NOT_ALLOWED

405 Method Not Allowed (HTTP/1.1 - RFC 2616)

public static final int
SC_MOVED_PERMANENTLY

301 Moved Permanently (HTTP/1.0 - RFC 1945)

public static final int
SC_MOVED_TEMPORARILY

302 Moved Temporarily (Sometimes Found) (HTTP/1.0 - RFC 1945)

public static final int
SC_MULTI_STATUS

207 Multi-Status (WebDAV - RFC 2518) or 207 Partial Update OK (HTTP/1.1 - draft-ietf-http-v11-spec-rev-01?)

public static final int
SC_MULTIPLE_CHOICES

300 Mutliple Choices (HTTP/1.1 - RFC 2616)

public static final int
SC_NO_CONTENT

204 No Content (HTTP/1.0 - RFC 1945)

public static final int
SC_NON_AUTHORITATIVE_INFORMATION

203 Non Authoritative Information (HTTP/1.1 - RFC 2616)

public static final int
SC_NOT_ACCEPTABLE

406 Not Acceptable (HTTP/1.1 - RFC 2616)

public static final int
SC_NOT_FOUND

404 Not Found (HTTP/1.0 - RFC 1945)

public static final int
SC_NOT_IMPLEMENTED

501 Not Implemented (HTTP/1.0 - RFC 1945)

public static final int
SC_NOT_MODIFIED

304 Not Modified (HTTP/1.0 - RFC 1945)

public static final int
SC_OK

200 OK (HTTP/1.0 - RFC 1945)

public static final int
SC_PARTIAL_CONTENT

206 Partial Content (HTTP/1.1 - RFC 2616)

public static final int
SC_PAYMENT_REQUIRED

402 Payment Required (HTTP/1.1 - RFC 2616)

public static final int
SC_PRECONDITION_FAILED

412 Precondition Failed (HTTP/1.1 - RFC 2616)

public static final int
SC_PROCESSING

102 Processing (WebDAV - RFC 2518)

public static final int
SC_PROXY_AUTHENTICATION_REQUIRED

407 Proxy Authentication Required (HTTP/1.1 - RFC 2616)

public static final int
SC_REQUEST_TIMEOUT

408 Request Timeout (HTTP/1.1 - RFC 2616)

public static final int
SC_REQUEST_TOO_LONG

413 Request Entity Too Large (HTTP/1.1 - RFC 2616)

public static final int
SC_REQUEST_URI_TOO_LONG

414 Request-URI Too Long (HTTP/1.1 - RFC 2616)

public static final int
SC_REQUESTED_RANGE_NOT_SATISFIABLE

416 Requested Range Not Satisfiable (HTTP/1.1 - RFC 2616)

public static final int
SC_RESET_CONTENT

205 Reset Content (HTTP/1.1 - RFC 2616)

public static final int
SC_SEE_OTHER

303 See Other (HTTP/1.1 - RFC 2616)

public static final int
SC_SERVICE_UNAVAILABLE

503 Service Unavailable (HTTP/1.0 - RFC 1945)

public static final int
SC_SWITCHING_PROTOCOLS

101 Switching Protocols (HTTP/1.1 - RFC 2616)

public static final int
SC_TEMPORARY_REDIRECT

307 Temporary Redirect (HTTP/1.1 - RFC 2616)

public static final int
SC_UNAUTHORIZED

401 Unauthorized (HTTP/1.0 - RFC 1945)

public static final int
SC_UNPROCESSABLE_ENTITY

422 Unprocessable Entity (WebDAV - RFC 2518)

public static final int
SC_UNSUPPORTED_MEDIA_TYPE

415 Unsupported Media Type (HTTP/1.1 - RFC 2616)

public static final int
SC_USE_PROXY

305 Use Proxy (HTTP/1.1 - RFC 2616)

pack-priv int

Constructor Summary

AccessConstructor and Description
public
HttpStatus(int statusCode)

Method Summary

Modifier and TypeMethod and Description
public int
getStatusCode()

Returns the status code of the HTTP response, normally 2xx status codes indicate success while 4xx and 5xx indicate client and server errors, respectively (see HTTP/1.1: Status Code Definitions for more information about HTTP status codes).

Inherited from java.lang.Object:
cloneequalsfinalizegetClasshashCodenotifynotifyAlltoStringwaitwaitwait

Field Detail

SC_ACCEPTEDback to summary
public static final int SC_ACCEPTED

202 Accepted (HTTP/1.0 - RFC 1945)

SC_BAD_GATEWAYback to summary
public static final int SC_BAD_GATEWAY

502 Bad Gateway (HTTP/1.0 - RFC 1945)

SC_BAD_REQUESTback to summary
public static final int SC_BAD_REQUEST

400 Bad Request (HTTP/1.1 - RFC 2616)

SC_CONFLICTback to summary
public static final int SC_CONFLICT

409 Conflict (HTTP/1.1 - RFC 2616)

SC_CONTINUEback to summary
public static final int SC_CONTINUE

100 Continue (HTTP/1.1 - RFC 2616)

SC_CREATEDback to summary
public static final int SC_CREATED

201 Created (HTTP/1.0 - RFC 1945)

SC_EXPECTATION_FAILEDback to summary
public static final int SC_EXPECTATION_FAILED

417 Expectation Failed (HTTP/1.1 - RFC 2616)

SC_FAILED_DEPENDENCYback to summary
public static final int SC_FAILED_DEPENDENCY

424 Failed Dependency (WebDAV - RFC 2518)

SC_FORBIDDENback to summary
public static final int SC_FORBIDDEN

403 Forbidden (HTTP/1.0 - RFC 1945)

SC_GATEWAY_TIMEOUTback to summary
public static final int SC_GATEWAY_TIMEOUT

504 Gateway Timeout (HTTP/1.1 - RFC 2616)

SC_GONEback to summary
public static final int SC_GONE

410 Gone (HTTP/1.1 - RFC 2616)

SC_HTTP_VERSION_NOT_SUPPORTEDback to summary
public static final int SC_HTTP_VERSION_NOT_SUPPORTED

505 HTTP Version Not Supported (HTTP/1.1 - RFC 2616)

SC_INSUFFICIENT_SPACE_ON_RESOURCEback to summary
public static final int SC_INSUFFICIENT_SPACE_ON_RESOURCE

Static constant for a 419 error. 419 Insufficient Space on Resource (WebDAV - draft-ietf-webdav-protocol-05?) or 419 Proxy Reauthentication Required (HTTP/1.1 drafts?)

SC_INSUFFICIENT_STORAGEback to summary
public static final int SC_INSUFFICIENT_STORAGE

507 Insufficient Storage (WebDAV - RFC 2518)

SC_INTERNAL_SERVER_ERRORback to summary
public static final int SC_INTERNAL_SERVER_ERROR

500 Server Error (HTTP/1.0 - RFC 1945)

SC_LENGTH_REQUIREDback to summary
public static final int SC_LENGTH_REQUIRED

411 Length Required (HTTP/1.1 - RFC 2616)

SC_LOCKEDback to summary
public static final int SC_LOCKED

423 Locked (WebDAV - RFC 2518)

SC_METHOD_FAILUREback to summary
public static final int SC_METHOD_FAILURE

Static constant for a 420 error. 420 Method Failure (WebDAV - draft-ietf-webdav-protocol-05?)

SC_METHOD_NOT_ALLOWEDback to summary
public static final int SC_METHOD_NOT_ALLOWED

405 Method Not Allowed (HTTP/1.1 - RFC 2616)

SC_MOVED_PERMANENTLYback to summary
public static final int SC_MOVED_PERMANENTLY

301 Moved Permanently (HTTP/1.0 - RFC 1945)

SC_MOVED_TEMPORARILYback to summary
public static final int SC_MOVED_TEMPORARILY

302 Moved Temporarily (Sometimes Found) (HTTP/1.0 - RFC 1945)

SC_MULTI_STATUSback to summary
public static final int SC_MULTI_STATUS

207 Multi-Status (WebDAV - RFC 2518) or 207 Partial Update OK (HTTP/1.1 - draft-ietf-http-v11-spec-rev-01?)

SC_MULTIPLE_CHOICESback to summary
public static final int SC_MULTIPLE_CHOICES

300 Mutliple Choices (HTTP/1.1 - RFC 2616)

SC_NO_CONTENTback to summary
public static final int SC_NO_CONTENT

204 No Content (HTTP/1.0 - RFC 1945)

SC_NON_AUTHORITATIVE_INFORMATIONback to summary
public static final int SC_NON_AUTHORITATIVE_INFORMATION

203 Non Authoritative Information (HTTP/1.1 - RFC 2616)

SC_NOT_ACCEPTABLEback to summary
public static final int SC_NOT_ACCEPTABLE

406 Not Acceptable (HTTP/1.1 - RFC 2616)

SC_NOT_FOUNDback to summary
public static final int SC_NOT_FOUND

404 Not Found (HTTP/1.0 - RFC 1945)

SC_NOT_IMPLEMENTEDback to summary
public static final int SC_NOT_IMPLEMENTED

501 Not Implemented (HTTP/1.0 - RFC 1945)

SC_NOT_MODIFIEDback to summary
public static final int SC_NOT_MODIFIED

304 Not Modified (HTTP/1.0 - RFC 1945)

SC_OKback to summary
public static final int SC_OK

200 OK (HTTP/1.0 - RFC 1945)

SC_PARTIAL_CONTENTback to summary
public static final int SC_PARTIAL_CONTENT

206 Partial Content (HTTP/1.1 - RFC 2616)

SC_PAYMENT_REQUIREDback to summary
public static final int SC_PAYMENT_REQUIRED

402 Payment Required (HTTP/1.1 - RFC 2616)

SC_PRECONDITION_FAILEDback to summary
public static final int SC_PRECONDITION_FAILED

412 Precondition Failed (HTTP/1.1 - RFC 2616)

SC_PROCESSINGback to summary
public static final int SC_PROCESSING

102 Processing (WebDAV - RFC 2518)

SC_PROXY_AUTHENTICATION_REQUIREDback to summary
public static final int SC_PROXY_AUTHENTICATION_REQUIRED

407 Proxy Authentication Required (HTTP/1.1 - RFC 2616)

SC_REQUEST_TIMEOUTback to summary
public static final int SC_REQUEST_TIMEOUT

408 Request Timeout (HTTP/1.1 - RFC 2616)

SC_REQUEST_TOO_LONGback to summary
public static final int SC_REQUEST_TOO_LONG

413 Request Entity Too Large (HTTP/1.1 - RFC 2616)

SC_REQUEST_URI_TOO_LONGback to summary
public static final int SC_REQUEST_URI_TOO_LONG

414 Request-URI Too Long (HTTP/1.1 - RFC 2616)

SC_REQUESTED_RANGE_NOT_SATISFIABLEback to summary
public static final int SC_REQUESTED_RANGE_NOT_SATISFIABLE

416 Requested Range Not Satisfiable (HTTP/1.1 - RFC 2616)

SC_RESET_CONTENTback to summary
public static final int SC_RESET_CONTENT

205 Reset Content (HTTP/1.1 - RFC 2616)

SC_SEE_OTHERback to summary
public static final int SC_SEE_OTHER

303 See Other (HTTP/1.1 - RFC 2616)

SC_SERVICE_UNAVAILABLEback to summary
public static final int SC_SERVICE_UNAVAILABLE

503 Service Unavailable (HTTP/1.0 - RFC 1945)

SC_SWITCHING_PROTOCOLSback to summary
public static final int SC_SWITCHING_PROTOCOLS

101 Switching Protocols (HTTP/1.1 - RFC 2616)

SC_TEMPORARY_REDIRECTback to summary
public static final int SC_TEMPORARY_REDIRECT

307 Temporary Redirect (HTTP/1.1 - RFC 2616)

SC_UNAUTHORIZEDback to summary
public static final int SC_UNAUTHORIZED

401 Unauthorized (HTTP/1.0 - RFC 1945)

SC_UNPROCESSABLE_ENTITYback to summary
public static final int SC_UNPROCESSABLE_ENTITY

422 Unprocessable Entity (WebDAV - RFC 2518)

SC_UNSUPPORTED_MEDIA_TYPEback to summary
public static final int SC_UNSUPPORTED_MEDIA_TYPE

415 Unsupported Media Type (HTTP/1.1 - RFC 2616)

SC_USE_PROXYback to summary
public static final int SC_USE_PROXY

305 Use Proxy (HTTP/1.1 - RFC 2616)

statusCodeback to summary
pack-priv int statusCode

Constructor Detail

HttpStatusback to summary
public HttpStatus(int statusCode)

Method Detail

getStatusCodeback to summary
public int getStatusCode()

Returns the status code of the HTTP response, normally 2xx status codes indicate success while 4xx and 5xx indicate client and server errors, respectively (see HTTP/1.1: Status Code Definitions for more information about HTTP status codes).