Top Deprecated
Netty/Codec/HTTP 4.1.107.Final

Deprecated API


No API in this release is deprecated for removal.

Deprecated Item Summary

SinceDeprecated Item and Description

Returns:

a Rfc6265 style Cookie header value
io.netty.handler.codec.http.ClientCookieEncoder.encode
(String
the cookie name
name
,
String
the cookie value
value
)

Returns:

a Rfc6265 style Cookie header value
io.netty.handler.codec.http.ClientCookieEncoder.encode
(Cookie
the specified cookie
cookie
)

Returns:

a Rfc6265 style Cookie header value, null if no cookies are passed.
io.netty.handler.codec.http.ClientCookieEncoder.encode
(Cookie...
some cookies
cookies
)

Returns:

a Rfc6265 style Cookie header value, null if no cookies are passed.
io.netty.handler.codec.http.ClientCookieEncoder.encode
(Iterable<Cookie>
some cookies
cookies
)

io.netty.handler.codec.http.CombinedHttpHeaders.CombinedHttpHeaders(boolean
Should Netty validate header values to ensure they aren't malicious.
validate
)

Prefer instead to configuring a HttpHeadersFactory by calling withCombiningHeaders(true) on DefaultHttpHeadersFactory#headersFactory().

Returns:

The comment of this Cookie
io.netty.handler.codec.http.Cookie.comment
()

Not part of RFC6265

Returns:

The comment URL of this Cookie
io.netty.handler.codec.http.Cookie.commentUrl
()

Not part of RFC6265

Returns:

True if this Cookie is to be discarded, otherwise false
io.netty.handler.codec.http.Cookie.isDiscard
()

Not part of RFC6265

Returns:

The maximum age of this Cookie
io.netty.handler.codec.http.Cookie.maxAge
()

Not part of RFC6265

Returns:

The Set of ports that this Cookie can use
io.netty.handler.codec.http.Cookie.ports
()

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setComment(String
The comment to use
comment
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setCommentUrl(String
The comment URL to use
commentUrl
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setDiscard(boolean
True if the Cookie is to be discarded
discard
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setMaxAge(long
The maximum age of this Cookie in seconds
maxAge
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setPorts(int...
The ports that this Cookie can be accessed on
ports
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setPorts(Iterable<Integer>
The Iterable collection of ports that this Cookie can be accessed on.
ports
)

Not part of RFC6265

io.netty.handler.codec.http.Cookie.setVersion(int
The new version to use
version
)

Not part of RFC6265

Returns:

The version of this Cookie
io.netty.handler.codec.http.Cookie.version
()

Not part of RFC6265

io.netty.handler.codec.http.CookieDecoder

Use io.netty.handler.codec.http.cookie.ClientCookieDecoder or io.netty.handler.codec.http.cookie.ServerCookieDecoder instead. Decodes an HTTP header value into Cookies. This decoder can decode the HTTP cookie version 0, 1, and 2.

HttpRequest req = ...;
String value = req.getHeader("Cookie");
Set<Cookie> cookies = CookieDecoder.decode(value);
io.netty.handler.codec.http.CookieDecoder.LAX

Deprecated as a consequence of CookieDecoder being deprecated. See corresponding docs for further information.

io.netty.handler.codec.http.CookieDecoder.STRICT

Deprecated as a consequence of CookieDecoder being deprecated. See corresponding docs for further information.

io.netty.handler.codec.http.CookieDecoder.initCookie(String name, String value)

Deprecated as a consequence of DefaultCookie being deprecated. See corresponding docs for further information.

io.netty.handler.codec.http.DefaultCookie.setDiscard(boolean
True if the Cookie is to be discarded
discard
)

io.netty.handler.codec.http.DefaultCookie.setPorts(int...
The ports that this Cookie can be accessed on
ports
)

io.netty.handler.codec.http.DefaultCookie.setPorts(Iterable<Integer>
The Iterable collection of ports that this Cookie can be accessed on.
ports
)

io.netty.handler.codec.http.DefaultCookie.setVersion(int
The new version to use
version
)

io.netty.handler.codec.http.DefaultHttpHeaders.DefaultHttpHeaders(boolean
Should Netty validate header values to ensure they aren't malicious.
validate
)

Prefer using the DefaultHttpHeaders() constructor instead, to always have validation enabled.

io.netty.handler.codec.http.DefaultHttpMessage.DefaultHttpMessage(final HttpVersion version, boolean validateHeaders, boolean singleFieldHeaders)

Use the DefaultHttpMessage(HttpVersion, HttpHeadersFactory) constructor instead, ideally using the DefaultHttpHeadersFactory#headersFactory(), or a factory that otherwise has validation enabled.

io.netty.handler.codec.http.DefaultHttpRequest.DefaultHttpRequest(HttpVersion
the HTTP version of the request
httpVersion
,
HttpMethod
the HTTP method of the request
method
,
String
the URI or path of the request
uri
,
boolean
validate the header names and values when adding them to the HttpHeaders
validateHeaders
)

Prefer the DefaultHttpRequest(HttpVersion, HttpMethod, String) constructor instead, to always have header validation enabled.

io.netty.handler.codec.http.DefaultHttpResponse.DefaultHttpResponse(HttpVersion
the HTTP version of this response
version
,
HttpResponseStatus
the status of this response
status
,
boolean
validate the header names and values when adding them to the HttpHeaders
validateHeaders
)

Use the DefaultHttpResponse(HttpVersion, HttpResponseStatus, HttpHeadersFactory) constructor instead.

io.netty.handler.codec.http.DefaultHttpResponse.DefaultHttpResponse(HttpVersion
the HTTP version of this response
version
,
HttpResponseStatus
the status of this response
status
,
boolean
validate the header names and values when adding them to the HttpHeaders
validateHeaders
,
boolean
true to check and enforce that headers with the same name are appended to the same entry and comma separated. See RFC 7230, 3.2.2. false to allow multiple header entries with the same name to coexist.
singleFieldHeaders
)

Use the DefaultHttpResponse(HttpVersion, HttpResponseStatus, HttpHeadersFactory) constructor instead.

io.netty.handler.codec.http.DefaultLastHttpContent.DefaultLastHttpContent(ByteBuf content, boolean validateHeaders)

Prefer the DefaultLastHttpContent(ByteBuf) constructor instead, to always have header validation enabled.

io.netty.handler.codec.http.EmptyHttpHeaders.instance()

Use EmptyHttpHeaders#INSTANCE

This is needed to break a cyclic static initialization loop between HttpHeaders and EmptyHttpHeaders.

io.netty.handler.codec.http.HttpChunkedInput.readChunk(ChannelHandlerContext
The context which provides a ByteBufAllocator if buffer allocation is necessary.
ctx
)

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders)

Prefer the HttpClientCodec(int, int, int, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders, boolean parseHttpAfterConnectRequest)

Prefer the HttpClientCodec(HttpDecoderConfig, boolean, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders, int initialBufferSize)

Prefer the HttpClientCodec(HttpDecoderConfig, boolean, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders, int initialBufferSize, boolean parseHttpAfterConnectRequest)

Prefer the HttpClientCodec(HttpDecoderConfig, boolean, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders, int initialBufferSize, boolean parseHttpAfterConnectRequest, boolean allowDuplicateContentLengths)

Prefer the HttpClientCodec(HttpDecoderConfig, boolean, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpClientCodec.HttpClientCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean failOnMissingResponse, boolean validateHeaders, int initialBufferSize, boolean parseHttpAfterConnectRequest, boolean allowDuplicateContentLengths, boolean allowPartialChunks)

Prefer the HttpClientCodec(HttpDecoderConfig, boolean, boolean) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpContentCompressor.HttpContentCompressor(int
1 yields the fastest compression and 9 yields the best compression. 0 means no compression. The default compression level is 6.
compressionLevel
)

io.netty.handler.codec.http.HttpContentCompressor.HttpContentCompressor(int
1 yields the fastest compression and 9 yields the best compression. 0 means no compression. The default compression level is 6.
compressionLevel
,
int
The base two logarithm of the size of the history buffer. The value should be in the range 9 to 15 inclusive. Larger values result in better compression at the expense of memory usage. The default value is 15.
windowBits
,
int
How much memory should be allocated for the internal compression state. 1 uses minimum memory and 9 uses maximum memory. Larger values result in better and faster compression at the expense of memory usage. The default value is 8
memLevel
)

io.netty.handler.codec.http.HttpContentCompressor.HttpContentCompressor(int
1 yields the fastest compression and 9 yields the best compression. 0 means no compression. The default compression level is 6.
compressionLevel
,
int
The base two logarithm of the size of the history buffer. The value should be in the range 9 to 15 inclusive. Larger values result in better compression at the expense of memory usage. The default value is 15.
windowBits
,
int
How much memory should be allocated for the internal compression state. 1 uses minimum memory and 9 uses maximum memory. Larger values result in better and faster compression at the expense of memory usage. The default value is 8
memLevel
,
int
The response body is compressed when the size of the response body exceeds the threshold. The value should be a non negative number. 0 will enable compression for all responses.
contentSizeThreshold
)

io.netty.handler.codec.http.HttpHeaderDateFormat.get()

Deprecated as a consequence of HttpHeaderDateFormat being deprecated. See corresponding docs for further information.

io.netty.handler.codec.http.HttpHeaders.EMPTY_HEADERS

Use EmptyHttpHeaders#INSTANCE.

The instance is instantiated here to break the cyclic static initialization between EmptyHttpHeaders and HttpHeaders. The issue is that if someone accesses EmptyHttpHeaders#INSTANCE before HttpHeaders#EMPTY_HEADERS then HttpHeaders#EMPTY_HEADERS will be null.

io.netty.handler.codec.http.HttpHeaders.Names

Use HttpHeaderNames instead. Standard HTTP header names.

io.netty.handler.codec.http.HttpHeaders.Values

Use HttpHeaderValues instead. Standard HTTP header values.

io.netty.handler.codec.http.HttpHeaders.addDateHeader(HttpMessage message, CharSequence name, Date value)

Use add(CharSequence, Object) instead. Adds a new date header with the specified name and value. The specified value is formatted as defined in RFC2616

io.netty.handler.codec.http.HttpHeaders.addHeader(HttpMessage message, CharSequence name, Object value)

Use add(CharSequence, Object) instead. Adds a new header with the specified name and value. If the specified value is not a String, it is converted into a String by Object#toString(), except for Date and Calendar which are formatted to the date format defined in RFC2616.

io.netty.handler.codec.http.HttpHeaders.addIntHeader(HttpMessage message, CharSequence name, int value)

Use addInt(CharSequence, int) instead. Adds a new integer header with the specified name and value.

io.netty.handler.codec.http.HttpHeaders.clearHeaders(HttpMessage message)

Use clear() instead. Removes all headers from the specified message.

Returns:

the content length
io.netty.handler.codec.http.HttpHeaders.getContentLength
(HttpMessage message)

Use HttpUtil#getContentLength(HttpMessage) instead. Returns the length of the content. Please note that this value is not retrieved from HttpContent#content() but from the "Content-Length" header, and thus they are independent from each other.

Returns:

the content length or defaultValue if this message does not have the "Content-Length" header or its value is not a number
io.netty.handler.codec.http.HttpHeaders.getContentLength
(HttpMessage message, long defaultValue)

Use HttpUtil#getContentLength(HttpMessage, long) instead. Returns the length of the content. Please note that this value is not retrieved from HttpContent#content() but from the "Content-Length" header, and thus they are independent from each other.

io.netty.handler.codec.http.HttpHeaders.getDate(HttpMessage message)

Use getTimeMillis(CharSequence) instead. Returns the value of the "Date" header.

io.netty.handler.codec.http.HttpHeaders.getDate(HttpMessage message, Date defaultValue)

Use getTimeMillis(CharSequence, long) instead. Returns the value of the "Date" header. If there is no such header or the header is not a formatted date, the defaultValue is returned.

Returns:

the header value
io.netty.handler.codec.http.HttpHeaders.getDateHeader
(HttpMessage message, CharSequence name)

Use getTimeMillis(CharSequence) instead. Returns the date header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

Returns:

the header value or the defaultValue if there is no such header or the header value is not a formatted date
io.netty.handler.codec.http.HttpHeaders.getDateHeader
(HttpMessage message, CharSequence name, Date defaultValue)

Use getTimeMillis(CharSequence, long) instead. Returns the date header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

Returns:

the header value or null if there is no such header
io.netty.handler.codec.http.HttpHeaders.getHeader
(HttpMessage message, CharSequence name)

Use get(CharSequence) instead. Returns the header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

Returns:

the header value or the defaultValue if there is no such header
io.netty.handler.codec.http.HttpHeaders.getHeader
(HttpMessage message, CharSequence name, String defaultValue)

Use get(CharSequence, String) instead. Returns the header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

io.netty.handler.codec.http.HttpHeaders.getHost(HttpMessage message)

Use get(CharSequence) instead. Returns the value of the "Host" header.

io.netty.handler.codec.http.HttpHeaders.getHost(HttpMessage message, String defaultValue)

Use get(CharSequence, String) instead. Returns the value of the "Host" header. If there is no such header, the defaultValue is returned.

Returns:

the header value
io.netty.handler.codec.http.HttpHeaders.getIntHeader
(HttpMessage message, CharSequence name)

Use getInt(CharSequence) instead. Returns the integer header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

Returns:

the header value or the defaultValue if there is no such header or the header value is not a number
io.netty.handler.codec.http.HttpHeaders.getIntHeader
(HttpMessage message, CharSequence name, int defaultValue)

Use getInt(CharSequence, int) instead. Returns the integer header value with the specified header name. If there are more than one header value for the specified header name, the first value is returned.

io.netty.handler.codec.http.HttpHeaders.is100ContinueExpected(HttpMessage message)

Use HttpUtil#is100ContinueExpected(HttpMessage) instead. Returns true if and only if the specified message contains the "Expect: 100-continue" header.

io.netty.handler.codec.http.HttpHeaders.isKeepAlive(HttpMessage message)

Use HttpUtil#isKeepAlive(HttpMessage) instead. Returns true if and only if the connection can remain open and thus 'kept alive'. This methods respects the value of the "Connection" header first and then the return value of HttpVersion#isKeepAliveDefault().

Returns:

True if transfer encoding is chunked, otherwise false
io.netty.handler.codec.http.HttpHeaders.isTransferEncodingChunked
(HttpMessage
The message to check
message
)

Use HttpUtil#isTransferEncodingChunked(HttpMessage) instead. Checks to see if the transfer encoding in a specified HttpMessage is chunked

io.netty.handler.codec.http.HttpHeaders.iterator()

It is preferred to use iteratorCharSequence() unless you need String. If String is required then use iteratorAsString().

io.netty.handler.codec.http.HttpHeaders.newEntity(String name)

Use AsciiString instead.

Create a new CharSequence which is optimized for reuse as HttpHeaders name or value. So if you have a Header name or value that you want to reuse you should make use of this.

io.netty.handler.codec.http.HttpHeaders.removeHeader(HttpMessage message, CharSequence name)

Use remove(CharSequence) instead. Removes the header with the specified name.

io.netty.handler.codec.http.HttpHeaders.set100ContinueExpected(HttpMessage message)

Use HttpUtil#set100ContinueExpected(HttpMessage, boolean) instead. Sets the "Expect: 100-continue" header to the specified message. If there is any existing "Expect" header, they are replaced with the new one.

io.netty.handler.codec.http.HttpHeaders.set100ContinueExpected(HttpMessage message, boolean set)

Use HttpUtil#set100ContinueExpected(HttpMessage, boolean) instead. Sets or removes the "Expect: 100-continue" header to / from the specified message. If set is true, the "Expect: 100-continue" header is set and all other previous "Expect" headers are removed. Otherwise, all "Expect" headers are removed completely.

io.netty.handler.codec.http.HttpHeaders.setDateHeader(HttpMessage message, CharSequence name, Date value)

Use set(CharSequence, Object) instead. Sets a new date header with the specified name and value. If there is an existing header with the same name, the existing header is removed. The specified value is formatted as defined in RFC2616

io.netty.handler.codec.http.HttpHeaders.setDateHeader(HttpMessage message, CharSequence name, Iterable<Date> values)

Use set(CharSequence, Iterable) instead. Sets a new date header with the specified name and values. If there is an existing header with the same name, the existing header is removed. The specified values are formatted as defined in RFC2616

io.netty.handler.codec.http.HttpHeaders.setHeader(HttpMessage message, CharSequence name, Object value)

Use set(CharSequence, Object) instead. Sets a new header with the specified name and value. If there is an existing header with the same name, the existing header is removed. If the specified value is not a String, it is converted into a String by Object#toString(), except for Date and Calendar which are formatted to the date format defined in RFC2616.

io.netty.handler.codec.http.HttpHeaders.setHeader(HttpMessage message, CharSequence name, Iterable<?> values)

Use set(CharSequence, Iterable) instead. Sets a new header with the specified name and values. If there is an existing header with the same name, the existing header is removed. This getMethod can be represented approximately as the following code:

removeHeader(message, name);
for (Object v: values) {
    if (v == null) {
        break;
    }
    addHeader(message, name, v);
}
io.netty.handler.codec.http.HttpHeaders.setIntHeader(HttpMessage message, CharSequence name, int value)

Use setInt(CharSequence, int) instead. Sets a new integer header with the specified name and value. If there is an existing header with the same name, the existing header is removed.

io.netty.handler.codec.http.HttpHeaders.setIntHeader(HttpMessage message, CharSequence name, Iterable<Integer> values)

Use set(CharSequence, Iterable) instead. Sets a new integer header with the specified name and values. If there is an existing header with the same name, the existing header is removed.

io.netty.handler.codec.http.HttpHeaders.setKeepAlive(HttpMessage message, boolean keepAlive)

Use HttpUtil#setKeepAlive(HttpMessage, boolean) instead. Sets the value of the "Connection" header depending on the protocol version of the specified message. This getMethod sets or removes the "Connection" header depending on what the default keep alive mode of the message's protocol version is, as specified by HttpVersion#isKeepAliveDefault().

  • If the connection is kept alive by default:
    • set to "close" if keepAlive is false.
    • remove otherwise.
  • If the connection is closed by default:
    • set to "keep-alive" if keepAlive is true.
    • remove otherwise.
io.netty.handler.codec.http.HttpObjectDecoder.HttpObjectDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean chunkedSupported)

Use HttpObjectDecoder(HttpDecoderConfig) instead.

io.netty.handler.codec.http.HttpObjectDecoder.HttpObjectDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean chunkedSupported, boolean validateHeaders)

Use HttpObjectDecoder(HttpDecoderConfig) instead.

io.netty.handler.codec.http.HttpObjectDecoder.HttpObjectDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean chunkedSupported, boolean validateHeaders, int initialBufferSize)

Use HttpObjectDecoder(HttpDecoderConfig) instead.

io.netty.handler.codec.http.HttpObjectDecoder.HttpObjectDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean chunkedSupported, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths)

Use HttpObjectDecoder(HttpDecoderConfig) instead.

io.netty.handler.codec.http.HttpObjectDecoder.HttpObjectDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean chunkedSupported, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths, boolean allowPartialChunks)

Use HttpObjectDecoder(HttpDecoderConfig) instead.

io.netty.handler.codec.http.HttpRequestDecoder.HttpRequestDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders)

Prefer the HttpRequestDecoder(HttpDecoderConfig) constructor, to always have header validation enabled.

io.netty.handler.codec.http.HttpRequestDecoder.HttpRequestDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize)

Prefer the HttpRequestDecoder(HttpDecoderConfig) constructor, to always have header validation enabled.

io.netty.handler.codec.http.HttpRequestDecoder.HttpRequestDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths)

Prefer the HttpRequestDecoder(HttpDecoderConfig) constructor, to always have header validation enabled.

io.netty.handler.codec.http.HttpRequestDecoder.HttpRequestDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths, boolean allowPartialChunks)

Prefer the HttpRequestDecoder(HttpDecoderConfig) constructor, to always have header validation enabled.

io.netty.handler.codec.http.HttpResponseDecoder.HttpResponseDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders)

Prefer the HttpResponseDecoder(HttpDecoderConfig) constructor.

io.netty.handler.codec.http.HttpResponseDecoder.HttpResponseDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize)

Prefer the HttpResponseDecoder(HttpDecoderConfig) constructor.

io.netty.handler.codec.http.HttpResponseDecoder.HttpResponseDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths)

Prefer the HttpResponseDecoder(HttpDecoderConfig) constructor.

io.netty.handler.codec.http.HttpResponseDecoder.HttpResponseDecoder(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths, boolean allowPartialChunks)

Prefer the HttpResponseDecoder(HttpDecoderConfig) constructor.

io.netty.handler.codec.http.HttpServerCodec.HttpServerCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders)

Prefer the HttpServerCodec(HttpDecoderConfig) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpServerCodec.HttpServerCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize)

Prefer the HttpServerCodec(HttpDecoderConfig) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpServerCodec.HttpServerCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths)

Prefer the HttpServerCodec(HttpDecoderConfig) constructor, to always enable header validation.

io.netty.handler.codec.http.HttpServerCodec.HttpServerCodec(int maxInitialLineLength, int maxHeaderSize, int maxChunkSize, boolean validateHeaders, int initialBufferSize, boolean allowDuplicateContentLengths, boolean allowPartialChunks)

Prefer the HttpServerCodec(HttpDecoderConfig) constructor, to always enable header validation.

Returns:

the CharSequence with charset from message's Content-Type header or null if charset is not presented
io.netty.handler.codec.http.HttpUtil.getCharsetAsString
(HttpMessage
entity to fetch Content-Type header from
message
)

use getCharsetAsSequence(HttpMessage)

Returns:

a single Set-Cookie header value
io.netty.handler.codec.http.ServerCookieEncoder.encode
(String
the cookie name
name
,
String
the cookie value
value
)

Returns:

a single Set-Cookie header value
io.netty.handler.codec.http.ServerCookieEncoder.encode
(Cookie
the cookie
cookie
)

Returns:

the corresponding bunch of Set-Cookie headers
io.netty.handler.codec.http.ServerCookieEncoder.encode
(Cookie...
a bunch of cookies
cookies
)

Returns:

the corresponding bunch of Set-Cookie headers
io.netty.handler.codec.http.ServerCookieEncoder.encode
(Collection<Cookie>
a bunch of cookies
cookies
)

Returns:

the corresponding bunch of Set-Cookie headers
io.netty.handler.codec.http.ServerCookieEncoder.encode
(Iterable<Cookie>
a bunch of cookies
cookies
)

Returns:

the trimmed, validated attribute value
io.netty.handler.codec.http.cookie.DefaultCookie.validateValue
(String
attribute name
name
,
String
attribute value
value
)

CookieUtil is package private, will be removed once old Cookie API is dropped

Returns:

WebSocketFrame contain chunk of data
io.netty.handler.codec.http.websocketx.WebSocketChunkedInput.readChunk
(ChannelHandlerContext
ChannelHandlerContext context of channelHandler
ctx
)

Use readChunk(ByteBufAllocator). Fetches a chunked data from the stream. Once this method returns the last chunk and thus the stream has reached at its end, any subsequent isEndOfInput() call must return true.

io.netty.handler.codec.rtsp.RtspDecoder.RtspDecoder(final int
The max allowed length of initial line
maxInitialLineLength
,
final int
The max allowed size of header
maxHeaderSize
,
final int
The max allowed content length
maxContentLength
,
final boolean
Set to true if headers should be validated
validateHeaders
)

Use the RtspDecoder(HttpDecoderConfig) constructor instead, or the RtspDecoder(int, int, int) to always enable header validation.

io.netty.handler.codec.rtsp.RtspHeaders

Use RtspHeaderNames or RtspHeaderValues instead. Standard RTSP header names and values.

io.netty.handler.codec.rtsp.RtspHeaders.Names

Use RtspHeaderNames instead. Standard RTSP header names.

io.netty.handler.codec.rtsp.RtspHeaders.Values

Use RtspHeaderValues instead. Standard RTSP header values.

io.netty.handler.codec.spdy.SpdyHeaderBlockJZlibEncoder.z

Deprecated as a consequence of Deflater being deprecated. See corresponding docs for further information.

io.netty.handler.codec.spdy.SpdyHttpCodec.SpdyHttpCodec(SpdyVersion version, int maxContentLength, boolean validateHttpHeaders)

io.netty.handler.codec.spdy.SpdyHttpDecoder.SpdyHttpDecoder(SpdyVersion
the protocol version
version
,
int
the maximum length of the message content. If the length of the message content exceeds this value, a TooLongFrameException will be raised.
maxContentLength
,
boolean
true if http headers should be validated
validateHeaders
)

Use the SpdyHttpDecoder(SpdyVersion, int, Map, HttpHeadersFactory, HttpHeadersFactory) constructor instead.

io.netty.handler.codec.spdy.SpdyHttpDecoder.SpdyHttpDecoder(SpdyVersion
the protocol version
version
,
int
the maximum length of the message content. If the length of the message content exceeds this value, a TooLongFrameException will be raised.
maxContentLength
,
Map<Integer, FullHttpMessage>
the Map used to hold partially received messages.
messageMap
,
boolean
true if http headers should be validated
validateHeaders
)

Use the SpdyHttpDecoder(SpdyVersion, int, Map, HttpHeadersFactory, HttpHeadersFactory) constructor instead.