{ iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) 1 }
| Modifier and Type | Field and Description |
|---|---|
| public static final ASN1ObjectIdentifier | bagtypes
PKCS#12: 1.2.840.113549.1.12.10.1 |
| public static final ASN1ObjectIdentifier | canNotDecryptAny
PKCS#9: 1.2.840.113549.1.9.15.2 -- smime capability |
| public static final ASN1ObjectIdentifier | certBag
PKCS#12: 1.2.840.113549.1.12.10.1.3 |
| public static final ASN1ObjectIdentifier | certTypes
PKCS#9: 1.2.840.113549.1.9.22 |
| public static final ASN1ObjectIdentifier | crlBag
PKCS#12: 1.2.840.113549.1.12.10.1.4 |
| public static final ASN1ObjectIdentifier | crlTypes
PKCS#9: 1.2.840.113549.1.9.23 |
| public static final ASN1ObjectIdentifier | data
PKCS#7: 1.2.840.113549.1.7.1 |
| public static final ASN1ObjectIdentifier | des_EDE3_CBC
1.2.840.113549.3.7 |
| public static final ASN1ObjectIdentifier | dhKeyAgreement
PKCS#3: 1.2.840.113549.1.3.1 |
| public static final ASN1ObjectIdentifier | digestAlgorithm
1.2.840.113549.2 |
| public static final ASN1ObjectIdentifier | digestedData
PKCS#7: 1.2.840.113549.1.7.5 |
| public static final ASN1ObjectIdentifier | encryptedData
PKCS#7: 1.2.840.113549.1.7.76 |
| public static final ASN1ObjectIdentifier | encryptionAlgorithm
1.2.840.113549.3 |
| public static final ASN1ObjectIdentifier | envelopedData
PKCS#7: 1.2.840.113549.1.7.3 |
| public static final ASN1ObjectIdentifier | id_aa
PKCS#9: 1.2.840.113549.1.9.16.6.2 - smime attributes |
| public static final ASN1ObjectIdentifier | id_aa_asymmDecryptKeyID
PKCS#9: 1.2.840.113549.1.9.16.2.54 RFC7030 |
| public static final ASN1ObjectIdentifier | id_aa_cmsAlgorithmProtect
RFC 6211 - id-aa-cmsAlgorithmProtect OBJECT IDENTIFIER ::= { iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs9(9) 52 } |
| public static final ASN1ObjectIdentifier | id_aa_commitmentType
Deprecated
use id_aa_ets_commitmentType instead
|
| public static final ASN1ObjectIdentifier | id_aa_communityIdentifiers
PKCS#9: 1.2.840.113549.1.9.16.2.40 RFC7030 |
| public static final ASN1ObjectIdentifier | id_aa_contentHint
PKCS#9: 1.2.840.113549.1.9.16.6.2.4 - See RFC 2634 |
| public static final ASN1ObjectIdentifier | id_aa_contentIdentifier
PKCS#9: 1.2.840.113549.1.9.16.6.2.7 - See RFC 2634 |
| public static final ASN1ObjectIdentifier | id_aa_contentReference
PKCS#9: 1.2.840.113549.1.9.16.6.2.10 |
| public static final ASN1ObjectIdentifier | id_aa_decryptKeyID
PKCS#9: 1.2.840.113549.1.9.16.6.2.37 - RFC 4108 |
| public static final ASN1ObjectIdentifier | id_aa_encrypKeyPref
PKCS#9: 1.2.840.113549.1.9.16.6.2.11 |
| public static final ASN1ObjectIdentifier | id_aa_ets_archiveTimestamp
PKCS#9: 1.2.840.113549.1.9.16.6.2.27 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_certCRLTimestamp
PKCS#9: 1.2.840.113549.1.9.16.6.2.26 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_certificateRefs
PKCS#9: 1.2.840.113549.1.9.16.6.2.21 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_certValues
PKCS#9: 1.2.840.113549.1.9.16.6.2.23 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_commitmentType
PKCS#9: 1.2.840.113549.1.9.16.6.2.16 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_contentTimestamp
PKCS#9: 1.2.840.113549.1.9.16.6.2.20 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_escTimeStamp
PKCS#9: 1.2.840.113549.1.9.16.6.2.25 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_otherSigCert
PKCS#9: 1.2.840.113549.1.9.16.6.2.19 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_revocationRefs
PKCS#9: 1.2.840.113549.1.9.16.6.2.22 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_revocationValues
PKCS#9: 1.2.840.113549.1.9.16.6.2.24 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_signerAttr
PKCS#9: 1.2.840.113549.1.9.16.6.2.18 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_signerLocation
PKCS#9: 1.2.840.113549.1.9.16.6.2.17 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_ets_sigPolicyId
PKCS#9: 1.2.840.113549.1.9.16.6.2.15 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_implCompressAlgs
PKCS#9: 1.2.840.113549.1.9.16.2.43 RFC7030 |
| public static final ASN1ObjectIdentifier | id_aa_implCryptoAlgs
PKCS#9: 1.2.840.113549.1.9.16.6.2.38 - RFC 4108 |
| public static final ASN1ObjectIdentifier | id_aa_msgSigDigest
PKCS#9: 1.2.840.113549.1.9.16.6.2.5 |
| public static final ASN1ObjectIdentifier | id_aa_otherSigCert
Deprecated
use id_aa_ets_otherSigCert instead
|
| public static final ASN1ObjectIdentifier | id_aa_receiptRequest
PKCS#9: 1.2.840.113549.1.9.16.6.2.1 -- smime attribute receiptRequest |
| public static final ASN1ObjectIdentifier | id_aa_signatureTimeStampToken
PKCS#9: 1.2.840.113549.1.9.16.6.2.14 - RFC 3126 |
| public static final ASN1ObjectIdentifier | id_aa_signerLocation
Deprecated
use id_aa_ets_signerLocation instead
|
| public static final ASN1ObjectIdentifier | id_aa_signingCertificate
PKCS#9: 1.2.840.113549.1.9.16.6.2.12 |
| public static final ASN1ObjectIdentifier | id_aa_signingCertificateV2
PKCS#9: 1.2.840.113549.1.9.16.6.2.47 |
| public static final ASN1ObjectIdentifier | id_aa_sigPolicyId
Deprecated
use id_aa_ets_sigPolicyId instead
|
| public static final ASN1ObjectIdentifier | id_alg
S/MIME: Algorithm Identifiers ; 1.2.840.113549.1.9.16.3 |
| public static final ASN1ObjectIdentifier | id_alg_CMS3DESwrap
PKCS#9: 1.2.840.113549.1.9.16.3.6 |
| public static final ASN1ObjectIdentifier | id_alg_CMSRC2wrap
PKCS#9: 1.2.840.113549.1.9.16.3.7 |
| public static final ASN1ObjectIdentifier | id_alg_ESDH
PKCS#9: 1.2.840.113549.1.9.16.3.5 |
| public static final ASN1ObjectIdentifier | id_alg_PWRI_KEK
PKCS#9: 1.2.840.113549.1.9.16.3.9 |
| public static final ASN1ObjectIdentifier | id_alg_SSDH
PKCS#9: 1.2.840.113549.1.9.16.3.10 |
| public static final ASN1ObjectIdentifier | id_ct
PKCS#9: 1.2.840.113549.1.9.16.1 -- smime ct |
| public static final ASN1ObjectIdentifier | id_ct_authData
PKCS#9: 1.2.840.113549.1.9.16.1.2 -- smime ct authData |
| public static final ASN1ObjectIdentifier | id_ct_authEnvelopedData
PKCS#9: 1.2.840.113549.1.9.16.1.23 -- smime ct authEnvelopedData |
| public static final ASN1ObjectIdentifier | id_ct_compressedData
PKCS#9: 1.2.840.113549.1.9.16.1.9 -- smime ct compressedData |
| public static final ASN1ObjectIdentifier | id_ct_timestampedData
PKCS#9: 1.2.840.113549.1.9.16.1.31 -- smime ct timestampedData |
| public static final ASN1ObjectIdentifier | id_ct_TSTInfo
PKCS#9: 1.2.840.113549.1.9.16.1.4 -- smime ct TSTInfo |
| public static final ASN1ObjectIdentifier | id_cti
PKCS#9: 1.2.840.113549.1.9.16.6 -- smime cti |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfApproval
PKCS#9: 1.2.840.113549.1.9.16.6.5 -- smime cti proofOfApproval |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfCreation
PKCS#9: 1.2.840.113549.1.9.16.6.6 -- smime cti proofOfCreation |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfDelivery
PKCS#9: 1.2.840.113549.1.9.16.6.3 -- smime cti proofOfDelivery |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfOrigin
PKCS#9: 1.2.840.113549.1.9.16.6.1 -- smime cti proofOfOrigin |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfReceipt
PKCS#9: 1.2.840.113549.1.9.16.6.2 -- smime cti proofOfReceipt |
| public static final ASN1ObjectIdentifier | id_cti_ets_proofOfSender
PKCS#9: 1.2.840.113549.1.9.16.6.4 -- smime cti proofOfSender |
| public static final ASN1ObjectIdentifier | id_hmacWithSHA1
1.2.840.113549.2.7 |
| public static final ASN1ObjectIdentifier | id_hmacWithSHA224
1.2.840.113549.2.8 |
| public static final ASN1ObjectIdentifier | id_hmacWithSHA256
1.2.840.113549.2.9 |
| public static final ASN1ObjectIdentifier | id_hmacWithSHA384
1.2.840.113549.2.10 |
| public static final ASN1ObjectIdentifier | id_hmacWithSHA512
1.2.840.113549.2.11 |
| public static final ASN1ObjectIdentifier | id_mgf1
PKCS#1: 1.2.840.113549.1.1.8 |
| public static final ASN1ObjectIdentifier | id_PBES2
PKCS#5: 1.2.840.113549.1.5.13 |
| public static final ASN1ObjectIdentifier | id_PBKDF2
PKCS#5: 1.2.840.113549.1.5.12 |
| public static final ASN1ObjectIdentifier | id_pSpecified
PKCS#1: 1.2.840.113549.1.1.9 |
| public static final ASN1ObjectIdentifier | id_rsa_KEM
-- RSA-KEM Key Transport Algorithm RFC 5990
id-rsa-kem OID ::= {
iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1)
pkcs-9(9) smime(16) alg(3) 14
}
|
| public static final ASN1ObjectIdentifier | id_RSAES_OAEP
PKCS#1: 1.2.840.113549.1.1.7 |
| public static final ASN1ObjectIdentifier | id_RSASSA_PSS
PKCS#1: 1.2.840.113549.1.1.10 |
| public static final ASN1ObjectIdentifier | id_smime
PKCS#9: 1.2.840.113549.1.9.16 |
| public static final String | id_spq
id-spq OBJECT IDENTIFIER ::= {iso(1) member-body(2) usa(840) rsadsi(113549) pkcs(1) pkcs-9(9) smime(16) id-spq(5)}; 1.2.840.113549.1.9.16.5 |
| public static final ASN1ObjectIdentifier | id_spq_ets_unotice
SMIME SPQ UNOTICE: 1.2.840.113549.1.9.16.5.2 |
| public static final ASN1ObjectIdentifier | id_spq_ets_uri
SMIME SPQ URI: 1.2.840.113549.1.9.16.5.1 |
| public static final ASN1ObjectIdentifier | keyBag
PKCS#12: 1.2.840.113549.1.12.10.1.1 |
| public static final ASN1ObjectIdentifier | md2
1.2.840.113549.2.2 |
| public static final ASN1ObjectIdentifier | md2WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.2 |
| public static final ASN1ObjectIdentifier | md4
1.2.840.113549.2.4 |
| public static final ASN1ObjectIdentifier | md4WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.3 |
| public static final ASN1ObjectIdentifier | md5
1.2.840.113549.2.5 |
| public static final ASN1ObjectIdentifier | md5WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.4 |
| public static final ASN1ObjectIdentifier | pbeUnknownGost
PKCS#12: 1.2.840.113549.1.12.1.80 |
| public static final ASN1ObjectIdentifier | pbeWithMD2AndDES_CBC
PKCS#5: 1.2.840.113549.1.5.1 |
| public static final ASN1ObjectIdentifier | pbeWithMD2AndRC2_CBC
PKCS#5: 1.2.840.113549.1.5.4 |
| public static final ASN1ObjectIdentifier | pbeWithMD5AndDES_CBC
PKCS#5: 1.2.840.113549.1.5.3 |
| public static final ASN1ObjectIdentifier | pbeWithMD5AndRC2_CBC
PKCS#5: 1.2.840.113549.1.5.6 |
| public static final ASN1ObjectIdentifier | pbeWithSHA1AndDES_CBC
PKCS#5: 1.2.840.113549.1.5.10 |
| public static final ASN1ObjectIdentifier | pbeWithSHA1AndRC2_CBC
PKCS#5: 1.2.840.113549.1.5.11 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd128BitRC2_CBC
PKCS#12: 1.2.840.113549.1.12.1.5 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd128BitRC4
PKCS#12: 1.2.840.113549.1.12.1.1 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd2_KeyTripleDES_CBC
PKCS#12: 1.2.840.113549.1.12.1.4 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd3_KeyTripleDES_CBC
PKCS#12: 1.2.840.113549.1.12.1.3 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd40BitRC2_CBC
PKCS#12: 1.2.840.113549.1.12.1.6 |
| public static final ASN1ObjectIdentifier | pbeWithSHAAnd40BitRC4
PKCS#12: 1.2.840.113549.1.12.1.2 |
| public static final ASN1ObjectIdentifier | pkcs8ShroudedKeyBag
PKCS#12: 1.2.840.113549.1.12.10.1.2 |
| public static final ASN1ObjectIdentifier | pkcs_1
PKCS#1: 1.2.840.113549.1.1 |
| public static final ASN1ObjectIdentifier | pkcs_12
PKCS#12: 1.2.840.113549.1.12 |
| public static final ASN1ObjectIdentifier | pkcs_12PbeIds
PKCS#12: 1.2.840.113549.1.12.1 |
| public static final ASN1ObjectIdentifier | pkcs_3
PKCS#3: 1.2.840.113549.1.3 |
| public static final ASN1ObjectIdentifier | pkcs_5
PKCS#5: 1.2.840.113549.1.5 |
| public static final ASN1ObjectIdentifier | pkcs_7
pkcs#7: 1.2.840.113549.1.7 |
| public static final ASN1ObjectIdentifier | pkcs_9
PKCS#9: 1.2.840.113549.1.9 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_challengePassword
PKCS#9: 1.2.840.113549.1.9.7 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_contentType
PKCS#9: 1.2.840.113549.1.9.3 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_counterSignature
PKCS#9: 1.2.840.113549.1.9.6 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_emailAddress
PKCS#9: 1.2.840.113549.1.9.1 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_extendedCertificateAttributes
PKCS#9: 1.2.840.113549.1.9.9 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_extensionRequest
PKCS#9: 1.2.840.113549.1.9.14 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_friendlyName
PKCS#9: 1.2.840.113549.1.9.20 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_localKeyId
PKCS#9: 1.2.840.113549.1.9.21 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_messageDigest
PKCS#9: 1.2.840.113549.1.9.4 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_signingDescription
PKCS#9: 1.2.840.113549.1.9.13 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_signingTime
PKCS#9: 1.2.840.113549.1.9.5 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_smimeCapabilities
PKCS#9: 1.2.840.113549.1.9.15 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_unstructuredAddress
PKCS#9: 1.2.840.113549.1.9.8 |
| public static final ASN1ObjectIdentifier | pkcs_9_at_unstructuredName
PKCS#9: 1.2.840.113549.1.9.2 |
| public static final ASN1ObjectIdentifier | preferSignedData
PKCS#9: 1.2.840.113549.1.9.15.1 -- smime capability |
| public static final ASN1ObjectIdentifier | RC2_CBC
1.2.840.113549.3.2 |
| public static final ASN1ObjectIdentifier | rc4
1.2.840.113549.3.4 |
| public static final ASN1ObjectIdentifier | rsaEncryption
PKCS#1: 1.2.840.113549.1.1.1 |
| public static final ASN1ObjectIdentifier | safeContentsBag
PKCS#12: 1.2.840.113549.1.12.10.1.6 |
| public static final ASN1ObjectIdentifier | sdsiCertificate
PKCS#9: 1.2.840.113549.1.9.22.2 |
| public static final ASN1ObjectIdentifier | secretBag
PKCS#12: 1.2.840.113549.1.12.10.1.5 |
| public static final ASN1ObjectIdentifier | sha1WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.5 |
| public static final ASN1ObjectIdentifier | sha224WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.14 |
| public static final ASN1ObjectIdentifier | sha256WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.11 |
| public static final ASN1ObjectIdentifier | sha384WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.12 |
| public static final ASN1ObjectIdentifier | sha512_224WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.15 |
| public static final ASN1ObjectIdentifier | sha512_256WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.16 |
| public static final ASN1ObjectIdentifier | sha512WithRSAEncryption
PKCS#1: 1.2.840.113549.1.1.13 |
| public static final ASN1ObjectIdentifier | signedAndEnvelopedData
PKCS#7: 1.2.840.113549.1.7.4 |
| public static final ASN1ObjectIdentifier | signedData
PKCS#7: 1.2.840.113549.1.7.2 |
| public static final ASN1ObjectIdentifier | sMIMECapabilitiesVersions
PKCS#9: 1.2.840.113549.1.9.15.3 -- smime capability |
| public static final ASN1ObjectIdentifier | srsaOAEPEncryptionSET
PKCS#1: 1.2.840.113549.1.1.6 |
| public static final ASN1ObjectIdentifier | x509Certificate
PKCS#9: 1.2.840.113549.1.9.22.1 |
| public static final ASN1ObjectIdentifier | x509certType
PKCS#9: 1.2.840.113549.1.9.22.1 |
| public static final ASN1ObjectIdentifier | x509Crl
PKCS#9: 1.2.840.113549.1.9.23.1 |
| bagtypes | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier bagtypes PKCS#12: 1.2.840.113549.1.12.10.1 | |
| canNotDecryptAny | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier canNotDecryptAny PKCS#9: 1.2.840.113549.1.9.15.2 -- smime capability | |
| certBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier certBag PKCS#12: 1.2.840.113549.1.12.10.1.3 | |
| certTypes | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier certTypes PKCS#9: 1.2.840.113549.1.9.22 | |
| crlBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier crlBag PKCS#12: 1.2.840.113549.1.12.10.1.4 | |
| crlTypes | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier crlTypes PKCS#9: 1.2.840.113549.1.9.23 | |
| data | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier data PKCS#7: 1.2.840.113549.1.7.1 | |
| des_EDE3_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier des_EDE3_CBC 1.2.840.113549.3.7 | |
| dhKeyAgreement | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier dhKeyAgreement PKCS#3: 1.2.840.113549.1.3.1 | |
| digestAlgorithm | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier digestAlgorithm 1.2.840.113549.2 | |
| digestedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier digestedData PKCS#7: 1.2.840.113549.1.7.5 | |
| encryptedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier encryptedData PKCS#7: 1.2.840.113549.1.7.76 | |
| encryptionAlgorithm | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier encryptionAlgorithm 1.2.840.113549.3 | |
| envelopedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier envelopedData PKCS#7: 1.2.840.113549.1.7.3 | |
| id_aa | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa PKCS#9: 1.2.840.113549.1.9.16.6.2 - smime attributes | |
| id_aa_asymmDecryptKeyID | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_asymmDecryptKeyID PKCS#9: 1.2.840.113549.1.9.16.2.54 RFC7030 | |
| id_aa_cmsAlgorithmProtect | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_cmsAlgorithmProtect RFC 6211 - id-aa-cmsAlgorithmProtect OBJECT IDENTIFIER ::= { iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1) pkcs9(9) 52 } | |
| id_aa_commitmentType | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_commitmentType
Deprecated use id_aa_ets_commitmentType instead | |
| id_aa_communityIdentifiers | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_communityIdentifiers PKCS#9: 1.2.840.113549.1.9.16.2.40 RFC7030 | |
| id_aa_contentHint | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_contentHint PKCS#9: 1.2.840.113549.1.9.16.6.2.4 - See RFC 2634 | |
| id_aa_contentIdentifier | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_contentIdentifier PKCS#9: 1.2.840.113549.1.9.16.6.2.7 - See RFC 2634 | |
| id_aa_contentReference | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_contentReference PKCS#9: 1.2.840.113549.1.9.16.6.2.10 | |
| id_aa_decryptKeyID | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_decryptKeyID PKCS#9: 1.2.840.113549.1.9.16.6.2.37 - RFC 4108 | |
| id_aa_encrypKeyPref | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_encrypKeyPref PKCS#9: 1.2.840.113549.1.9.16.6.2.11 | |
| id_aa_ets_archiveTimestamp | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_archiveTimestamp PKCS#9: 1.2.840.113549.1.9.16.6.2.27 - RFC 3126 | |
| id_aa_ets_certCRLTimestamp | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_certCRLTimestamp PKCS#9: 1.2.840.113549.1.9.16.6.2.26 - RFC 3126 | |
| id_aa_ets_certificateRefs | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_certificateRefs PKCS#9: 1.2.840.113549.1.9.16.6.2.21 - RFC 3126 | |
| id_aa_ets_certValues | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_certValues PKCS#9: 1.2.840.113549.1.9.16.6.2.23 - RFC 3126 | |
| id_aa_ets_commitmentType | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_commitmentType PKCS#9: 1.2.840.113549.1.9.16.6.2.16 - RFC 3126 | |
| id_aa_ets_contentTimestamp | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_contentTimestamp PKCS#9: 1.2.840.113549.1.9.16.6.2.20 - RFC 3126 | |
| id_aa_ets_escTimeStamp | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_escTimeStamp PKCS#9: 1.2.840.113549.1.9.16.6.2.25 - RFC 3126 | |
| id_aa_ets_otherSigCert | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_otherSigCert PKCS#9: 1.2.840.113549.1.9.16.6.2.19 - RFC 3126 | |
| id_aa_ets_revocationRefs | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_revocationRefs PKCS#9: 1.2.840.113549.1.9.16.6.2.22 - RFC 3126 | |
| id_aa_ets_revocationValues | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_revocationValues PKCS#9: 1.2.840.113549.1.9.16.6.2.24 - RFC 3126 | |
| id_aa_ets_signerAttr | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_signerAttr PKCS#9: 1.2.840.113549.1.9.16.6.2.18 - RFC 3126 | |
| id_aa_ets_signerLocation | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_signerLocation PKCS#9: 1.2.840.113549.1.9.16.6.2.17 - RFC 3126 | |
| id_aa_ets_sigPolicyId | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_ets_sigPolicyId PKCS#9: 1.2.840.113549.1.9.16.6.2.15 - RFC 3126 | |
| id_aa_implCompressAlgs | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_implCompressAlgs PKCS#9: 1.2.840.113549.1.9.16.2.43 RFC7030 | |
| id_aa_implCryptoAlgs | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_implCryptoAlgs PKCS#9: 1.2.840.113549.1.9.16.6.2.38 - RFC 4108 | |
| id_aa_msgSigDigest | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_msgSigDigest PKCS#9: 1.2.840.113549.1.9.16.6.2.5 | |
| id_aa_otherSigCert | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_otherSigCert
Deprecated use id_aa_ets_otherSigCert instead | |
| id_aa_receiptRequest | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_receiptRequest PKCS#9: 1.2.840.113549.1.9.16.6.2.1 -- smime attribute receiptRequest | |
| id_aa_signatureTimeStampToken | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_signatureTimeStampToken PKCS#9: 1.2.840.113549.1.9.16.6.2.14 - RFC 3126 | |
| id_aa_signerLocation | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_signerLocation
Deprecated use id_aa_ets_signerLocation instead | |
| id_aa_signingCertificate | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_signingCertificate PKCS#9: 1.2.840.113549.1.9.16.6.2.12 | |
| id_aa_signingCertificateV2 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_signingCertificateV2 PKCS#9: 1.2.840.113549.1.9.16.6.2.47 | |
| id_aa_sigPolicyId | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_aa_sigPolicyId
Deprecated use id_aa_ets_sigPolicyId instead | |
| id_alg | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg S/MIME: Algorithm Identifiers ; 1.2.840.113549.1.9.16.3 | |
| id_alg_CMS3DESwrap | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg_CMS3DESwrap PKCS#9: 1.2.840.113549.1.9.16.3.6 | |
| id_alg_CMSRC2wrap | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg_CMSRC2wrap PKCS#9: 1.2.840.113549.1.9.16.3.7 | |
| id_alg_ESDH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg_ESDH PKCS#9: 1.2.840.113549.1.9.16.3.5 | |
| id_alg_PWRI_KEK | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg_PWRI_KEK PKCS#9: 1.2.840.113549.1.9.16.3.9 | |
| id_alg_SSDH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_alg_SSDH PKCS#9: 1.2.840.113549.1.9.16.3.10 | |
| id_ct | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct PKCS#9: 1.2.840.113549.1.9.16.1 -- smime ct | |
| id_ct_authData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct_authData PKCS#9: 1.2.840.113549.1.9.16.1.2 -- smime ct authData | |
| id_ct_authEnvelopedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct_authEnvelopedData PKCS#9: 1.2.840.113549.1.9.16.1.23 -- smime ct authEnvelopedData | |
| id_ct_compressedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct_compressedData PKCS#9: 1.2.840.113549.1.9.16.1.9 -- smime ct compressedData | |
| id_ct_timestampedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct_timestampedData PKCS#9: 1.2.840.113549.1.9.16.1.31 -- smime ct timestampedData | |
| id_ct_TSTInfo | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_ct_TSTInfo PKCS#9: 1.2.840.113549.1.9.16.1.4 -- smime ct TSTInfo | |
| id_cti | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti PKCS#9: 1.2.840.113549.1.9.16.6 -- smime cti | |
| id_cti_ets_proofOfApproval | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfApproval PKCS#9: 1.2.840.113549.1.9.16.6.5 -- smime cti proofOfApproval | |
| id_cti_ets_proofOfCreation | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfCreation PKCS#9: 1.2.840.113549.1.9.16.6.6 -- smime cti proofOfCreation | |
| id_cti_ets_proofOfDelivery | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfDelivery PKCS#9: 1.2.840.113549.1.9.16.6.3 -- smime cti proofOfDelivery | |
| id_cti_ets_proofOfOrigin | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfOrigin PKCS#9: 1.2.840.113549.1.9.16.6.1 -- smime cti proofOfOrigin | |
| id_cti_ets_proofOfReceipt | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfReceipt PKCS#9: 1.2.840.113549.1.9.16.6.2 -- smime cti proofOfReceipt | |
| id_cti_ets_proofOfSender | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_cti_ets_proofOfSender PKCS#9: 1.2.840.113549.1.9.16.6.4 -- smime cti proofOfSender | |
| id_hmacWithSHA1 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_hmacWithSHA1 1.2.840.113549.2.7 | |
| id_hmacWithSHA224 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_hmacWithSHA224 1.2.840.113549.2.8 | |
| id_hmacWithSHA256 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_hmacWithSHA256 1.2.840.113549.2.9 | |
| id_hmacWithSHA384 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_hmacWithSHA384 1.2.840.113549.2.10 | |
| id_hmacWithSHA512 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_hmacWithSHA512 1.2.840.113549.2.11 | |
| id_mgf1 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_mgf1 PKCS#1: 1.2.840.113549.1.1.8 | |
| id_PBES2 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_PBES2 PKCS#5: 1.2.840.113549.1.5.13 | |
| id_PBKDF2 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_PBKDF2 PKCS#5: 1.2.840.113549.1.5.12 | |
| id_pSpecified | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_pSpecified PKCS#1: 1.2.840.113549.1.1.9 | |
| id_rsa_KEM | back to summary |
|---|---|
public static final ASN1ObjectIdentifier id_rsa_KEM
-- RSA-KEM Key Transport Algorithm RFC 5990
id-rsa-kem OID ::= {
iso(1) member-body(2) us(840) rsadsi(113549) pkcs(1)
pkcs-9(9) smime(16) alg(3) 14
}
| |
| id_RSAES_OAEP | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_RSAES_OAEP PKCS#1: 1.2.840.113549.1.1.7 | |
| id_RSASSA_PSS | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_RSASSA_PSS PKCS#1: 1.2.840.113549.1.1.10 | |
| id_smime | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_smime PKCS#9: 1.2.840.113549.1.9.16 | |
| id_spq | back to summary |
|---|---|
| public static final String id_spq id-spq OBJECT IDENTIFIER ::= {iso(1) member-body(2) usa(840) rsadsi(113549) pkcs(1) pkcs-9(9) smime(16) id-spq(5)}; 1.2.840.113549.1.9.16.5 | |
| id_spq_ets_unotice | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_spq_ets_unotice SMIME SPQ UNOTICE: 1.2.840.113549.1.9.16.5.2 | |
| id_spq_ets_uri | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier id_spq_ets_uri SMIME SPQ URI: 1.2.840.113549.1.9.16.5.1 | |
| keyBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier keyBag PKCS#12: 1.2.840.113549.1.12.10.1.1 | |
| md2 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md2 1.2.840.113549.2.2 | |
| md2WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md2WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.2 | |
| md4 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md4 1.2.840.113549.2.4 | |
| md4WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md4WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.3 | |
| md5 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md5 1.2.840.113549.2.5 | |
| md5WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier md5WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.4 | |
| pbeUnknownGost | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeUnknownGost PKCS#12: 1.2.840.113549.1.12.1.80 | |
| pbeWithMD2AndDES_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithMD2AndDES_CBC PKCS#5: 1.2.840.113549.1.5.1 | |
| pbeWithMD2AndRC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithMD2AndRC2_CBC PKCS#5: 1.2.840.113549.1.5.4 | |
| pbeWithMD5AndDES_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithMD5AndDES_CBC PKCS#5: 1.2.840.113549.1.5.3 | |
| pbeWithMD5AndRC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithMD5AndRC2_CBC PKCS#5: 1.2.840.113549.1.5.6 | |
| pbeWithSHA1AndDES_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHA1AndDES_CBC PKCS#5: 1.2.840.113549.1.5.10 | |
| pbeWithSHA1AndRC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHA1AndRC2_CBC PKCS#5: 1.2.840.113549.1.5.11 | |
| pbeWithSHAAnd128BitRC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd128BitRC2_CBC PKCS#12: 1.2.840.113549.1.12.1.5 | |
| pbeWithSHAAnd128BitRC4 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd128BitRC4 PKCS#12: 1.2.840.113549.1.12.1.1 | |
| pbeWithSHAAnd2_KeyTripleDES_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd2_KeyTripleDES_CBC PKCS#12: 1.2.840.113549.1.12.1.4 | |
| pbeWithSHAAnd3_KeyTripleDES_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd3_KeyTripleDES_CBC PKCS#12: 1.2.840.113549.1.12.1.3 | |
| pbeWithSHAAnd40BitRC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd40BitRC2_CBC PKCS#12: 1.2.840.113549.1.12.1.6 | |
| pbeWithSHAAnd40BitRC4 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pbeWithSHAAnd40BitRC4 PKCS#12: 1.2.840.113549.1.12.1.2 | |
| pkcs8ShroudedKeyBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs8ShroudedKeyBag PKCS#12: 1.2.840.113549.1.12.10.1.2 | |
| pkcs_1 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_1 PKCS#1: 1.2.840.113549.1.1 | |
| pkcs_12 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_12 PKCS#12: 1.2.840.113549.1.12 | |
| pkcs_12PbeIds | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_12PbeIds PKCS#12: 1.2.840.113549.1.12.1 | |
| pkcs_3 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_3 PKCS#3: 1.2.840.113549.1.3 | |
| pkcs_5 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_5 PKCS#5: 1.2.840.113549.1.5 | |
| pkcs_7 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_7 pkcs#7: 1.2.840.113549.1.7 | |
| pkcs_9 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9 PKCS#9: 1.2.840.113549.1.9 | |
| pkcs_9_at_challengePassword | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_challengePassword PKCS#9: 1.2.840.113549.1.9.7 | |
| pkcs_9_at_contentType | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_contentType PKCS#9: 1.2.840.113549.1.9.3 | |
| pkcs_9_at_counterSignature | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_counterSignature PKCS#9: 1.2.840.113549.1.9.6 | |
| pkcs_9_at_emailAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_emailAddress PKCS#9: 1.2.840.113549.1.9.1 | |
| pkcs_9_at_extendedCertificateAttributes | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_extendedCertificateAttributes PKCS#9: 1.2.840.113549.1.9.9 | |
| pkcs_9_at_extensionRequest | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_extensionRequest PKCS#9: 1.2.840.113549.1.9.14 | |
| pkcs_9_at_friendlyName | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_friendlyName PKCS#9: 1.2.840.113549.1.9.20 | |
| pkcs_9_at_localKeyId | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_localKeyId PKCS#9: 1.2.840.113549.1.9.21 | |
| pkcs_9_at_messageDigest | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_messageDigest PKCS#9: 1.2.840.113549.1.9.4 | |
| pkcs_9_at_signingDescription | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_signingDescription PKCS#9: 1.2.840.113549.1.9.13 | |
| pkcs_9_at_signingTime | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_signingTime PKCS#9: 1.2.840.113549.1.9.5 | |
| pkcs_9_at_smimeCapabilities | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_smimeCapabilities PKCS#9: 1.2.840.113549.1.9.15 | |
| pkcs_9_at_unstructuredAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_unstructuredAddress PKCS#9: 1.2.840.113549.1.9.8 | |
| pkcs_9_at_unstructuredName | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier pkcs_9_at_unstructuredName PKCS#9: 1.2.840.113549.1.9.2 | |
| preferSignedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier preferSignedData PKCS#9: 1.2.840.113549.1.9.15.1 -- smime capability | |
| RC2_CBC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier RC2_CBC 1.2.840.113549.3.2 | |
| rc4 | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier rc4 1.2.840.113549.3.4 | |
| rsaEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier rsaEncryption PKCS#1: 1.2.840.113549.1.1.1 | |
| safeContentsBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier safeContentsBag PKCS#12: 1.2.840.113549.1.12.10.1.6 | |
| sdsiCertificate | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sdsiCertificate PKCS#9: 1.2.840.113549.1.9.22.2 | |
| secretBag | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier secretBag PKCS#12: 1.2.840.113549.1.12.10.1.5 | |
| sha1WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha1WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.5 | |
| sha224WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha224WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.14 | |
| sha256WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha256WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.11 | |
| sha384WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha384WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.12 | |
| sha512_224WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha512_224WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.15 | |
| sha512_256WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha512_256WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.16 | |
| sha512WithRSAEncryption | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sha512WithRSAEncryption PKCS#1: 1.2.840.113549.1.1.13 | |
| signedAndEnvelopedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier signedAndEnvelopedData PKCS#7: 1.2.840.113549.1.7.4 | |
| signedData | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier signedData PKCS#7: 1.2.840.113549.1.7.2 | |
| sMIMECapabilitiesVersions | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier sMIMECapabilitiesVersions PKCS#9: 1.2.840.113549.1.9.15.3 -- smime capability | |
| srsaOAEPEncryptionSET | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier srsaOAEPEncryptionSET PKCS#1: 1.2.840.113549.1.1.6 | |
| x509Certificate | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier x509Certificate PKCS#9: 1.2.840.113549.1.9.22.1 | |
| x509certType | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier x509certType
Deprecated use x509Certificate instead PKCS#9: 1.2.840.113549.1.9.22.1 | |
| x509Crl | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier x509Crl PKCS#9: 1.2.840.113549.1.9.23.1 | |