Top Description Packages

Bouncy Castle Provider (FIPS Distribution) 1.0.2.5

Resources
Homepage, Development, Bug Tracker, License (Bouncy Castle Licence)
Dependencies
java.base, java.logging
Maven Central
Group ID:org.bouncycastle
Artifacts:bc-fips

Project Bouncy Castle Provider (FIPS Distribution)

The FIPS 140-2 Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms certified to FIPS 140-2 level 1. This jar contains JCE provider and low-level API for the BC-FJA version 1.0.2.5, FIPS Certificate #4616. Please see certificate for certified platform details.

Release 1.0.2.5

Release Date
2024-04-26
Developers
The Legion of the Bouncy Castle Inc.

Package Summary

Modifier and TypePackage and Description
package
org.bouncycastle

The top level package with the license file.

package
org.bouncycastle.asn1

A library for parsing and writing ASN.1 objects.

package
org.bouncycastle.asn1.anssi

Object Identifiers and curves belong to the French Agency, ANSSI.

package
org.bouncycastle.asn1.bc

BC specific object identifiers and classes for the BCFKS key store.

package
org.bouncycastle.asn1.bsi

Classes and object identifiers related to the German BSI standard BSI-TR-03111.

package
org.bouncycastle.asn1.cmp

Support classes useful for encoding and supporting PKIX-CMP as described RFC 2510.

package
org.bouncycastle.asn1.cms

Support classes useful for encoding and supporting Cryptographic Message Syntax as described in PKCS#7 and RFC 3369 (formerly RFC 2630).

package
org.bouncycastle.asn1.cms.ecc

Classes specific to RFC 5753 "Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax."

package
org.bouncycastle.asn1.crmf

Classes and object identifiers specific to RFC 4211 "Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)."

package
org.bouncycastle.asn1.cryptopro

Support classes for CRYPTO-PRO related objects - such as GOST identifiers.

package
org.bouncycastle.asn1.dvcs

Support classes useful for encoding and processing Data Validation and Certification Server (DVCS) protocols as described in RFC 3029.

package
org.bouncycastle.asn1.eac

Classes and object identifiers related to the German BSI standard BSI TR-03110.

package
package
org.bouncycastle.asn1.esf

Support classes useful for encoding and supporting [ESF] RFC3126 Electronic Signature Formats for long term electronic signatures.

package
org.bouncycastle.asn1.ess

Support classes useful for encoding and supporting Enhanced Security Services for S/MIME as described RFC 2634 and RFC 5035.

package
package
org.bouncycastle.asn1.gnu

Classes and object identifiers related to the GNU project.

package
org.bouncycastle.asn1.iana

General object identifiers related to definitions created by the IETF.

package
org.bouncycastle.asn1.icao

ICAO ASN.1 classes for electronic passport.

package
org.bouncycastle.asn1.isismtt

Classes and object identifiers related to ISISMT -- the Industrial Signature Interoperability Specification.

package
org.bouncycastle.asn1.isismtt.ocsp

OCSP request extensions related to ISISMT -- the Industrial Signature Interoperability Specification.

package
org.bouncycastle.asn1.isismtt.x509

X.509 attribute classes related to ISISMT -- the Industrial Signature Interoperability Specification.

package
org.bouncycastle.asn1.iso

Classes and object identifiers related to ISO standards.

package
org.bouncycastle.asn1.kisa

Classes and object identifiers related to the Korea Information Security Agency (KISA) and the use of the SEED encryption algorithm in RFC 4010 and RFC 4269.

package
org.bouncycastle.asn1.microsoft

Classes and object identifiers related to Microsoft standards and functionality.

package
org.bouncycastle.asn1.misc

Miscellaneous object identifiers and objects.

package
org.bouncycastle.asn1.mozilla

Support classes useful for encoding objects used by mozilla.

package
org.bouncycastle.asn1.nist

Support classes for NIST related objects.

package
package
org.bouncycastle.asn1.ntt

object identifiers related to the use of the Camellia encryption algorithm (RFC 3657) from the NTT Software Corporation.

package
org.bouncycastle.asn1.ocsp

Support classes useful for encoding and supporting OCSP objects.

package
org.bouncycastle.asn1.oiw

Objects and OID for the support of ISO OIW.

package
org.bouncycastle.asn1.pkcs

Support classes useful for encoding and supporting the various RSA PKCS documents.

package
package
org.bouncycastle.asn1.sec

Classes for support of the SEC standard for Elliptic Curve.

package
org.bouncycastle.asn1.smime

Support classes useful for encoding and supporting S/MIME.

package
org.bouncycastle.asn1.teletrust

Support classes for TeleTrust related objects.

package
org.bouncycastle.asn1.tsp

Support classes useful for encoding and supporting Time Stamp Protocol as described RFC 3161.

package
org.bouncycastle.asn1.ua

Classes and object identifiers related to Ukranian DTSU4145 signature standard.

package
org.bouncycastle.asn1.util

An ASN.1 dump utility.

package
org.bouncycastle.asn1.x500

The base classes for defining an X.500 name.

package
org.bouncycastle.asn1.x500.style

A package of "style" templates for produce X.500 names and converting them to and from strings.

package
org.bouncycastle.asn1.x509

Support classes useful for encoding and processing X.509 certificates.

package
org.bouncycastle.asn1.x509.qualified

Support classes useful for encoding and processing messages based around RFC3739

package
org.bouncycastle.asn1.x509.sigi

Classes and object identifiers related to the SigI specifciation (German Signature Law Interoperability specification).

package
org.bouncycastle.asn1.x9

Support classes useful for encoding and supporting X9.62 elliptic curve.

package
org.bouncycastle.crypto

Lower level cryptography API that supports the JCA/JCE provider as well as allowing access to more primitive functionality.

package
org.bouncycastle.crypto.asymmetric

Keys and parameter classes for asymmetric (public/private) key algorithms.

package
org.bouncycastle.crypto.fips

Classes for FIPS approved mode algorithms

package
org.bouncycastle.crypto.general

Classes for general encryption algorithms and non-FIPS approved variants.

package
package
package
package
package
package
package
package
package
package
package
package
package
package
org.bouncycastle.crypto.util

Utility classes for supporting the crypto APIs - entropy provision and SP 800-56A OtherInfo and MacData.

package
org.bouncycastle.jcajce

Key and algorithm parameters classes for supporting provider specific algorithms and modes.

package
org.bouncycastle.jcajce.interfaces

Key interfaces for supporting provider specific algorithms.

package
org.bouncycastle.jcajce.io

Input and output stream classes designed to work with the JCA and the JCE.

package
org.bouncycastle.jcajce.provider

Package holding the Bouncy Castle FIPS provider.

package
org.bouncycastle.jcajce.spec

Key and algorithm parameters specifications for supporting provider specific algorithms and modes.

package
org.bouncycastle.jcajce.util

General utility classes for working with the JCA and JCE.

package
org.bouncycastle.math.ec

Low-level API for performing calculations on elliptic curves, in particular point addition, point doubling, and efficient scalar multiplication.

package
org.bouncycastle.math.ec.custom.sec

Custom, optimized implementations of the SEC curves.

package
org.bouncycastle.math.ec.endo

Provide support for using the GLV method to take advantage of the efficiently computable endomorphisms on "Koblitz" curves e.g. secp256k1.

package
package
package
org.bouncycastle.math.field

Classes for describing finite fields (not for performing calculations in them).

package
org.bouncycastle.math.internal

Low-level math operations directly on arrays (to replace the slow, immutable, BigInteger).

package
package
org.bouncycastle.util

General utility classes.

package
org.bouncycastle.util.encoders

Classes for producing a range of common binary encodings such as Hex and Base64.

package
org.bouncycastle.util.io

Utility classes providing zeroizing buffering and pass through streams similar to the tee command in Unix.

package
org.bouncycastle.util.io.pem

Classes for parsing and writing basic PEM format with binary data.

package
org.bouncycastle.util.test

Classes for providing "fixed entropy" and "fixed randomness" for testing purposes.