| Modifier and Type | Interface and Description |
|---|---|
| public interface | |
| public interface | |
| public interface |
| Modifier and Type | Class and Description |
|---|---|
| public class | AccessDescription
The AccessDescription object. |
| public class | |
| public class | |
| public class | |
| public class | |
| public class | |
| public class | |
| public class | AuthorityInformationAccess
The AuthorityInformationAccess object. |
| public class | AuthorityKeyIdentifier
The AuthorityKeyIdentifier object. |
| public class | |
| public class | Certificate
an X509Certificate structure. |
| public class | CertificateList
PKIX RFC-2459 The X.509 v2 CRL syntax is as follows. |
| public class | CertificatePair
This class helps to support crossCerfificatePairs in a LDAP directory according RFC 2587
crossCertificatePairATTRIBUTE::={
WITH SYNTAX CertificatePair
EQUALITY MATCHING RULE certificatePairExactMatch
ID joint-iso-ccitt(2) ds(5) attributeType(4) crossCertificatePair(40)}
|
| public class | |
| public class | CertPolicyId
CertPolicyId, used in the CertificatePolicies and PolicyMappings X509V3 Extensions. |
| public class | |
| public class | CRLNumber
The CRLNumber object. |
| public class | CRLReason
The CRLReason enumeration. |
| public class | DigestInfo
The DigestInfo object. |
| public class | DisplayText
|
| public class | DistributionPoint
The DistributionPoint object. |
| public class | DistributionPointName
The DistributionPointName object. |
| public class | |
| public class | ExtendedKeyUsage
The extendedKeyUsage object. |
| public class | Extension
an object for the elements in the X.509 V3 extension block. |
| public class | |
| public class | ExtensionsGenerator
Generator for X.509 extensions |
| public class | GeneralName
The GeneralName object. |
| public class | |
| public class | |
| public class | GeneralSubtree
Class for containing a restriction object subtrees in NameConstraints. |
| public class | Holder
The Holder object. |
| public class | IetfAttrSyntax
Implementation of |
| public class | |
| public class | IssuingDistributionPoint
IssuingDistributionPoint ::= SEQUENCE {
distributionPoint [0] DistributionPointName OPTIONAL,
onlyContainsUserCerts [1] BOOLEAN DEFAULT FALSE,
onlyContainsCACerts [2] BOOLEAN DEFAULT FALSE,
onlySomeReasons [3] ReasonFlags OPTIONAL,
indirectCRL [4] BOOLEAN DEFAULT FALSE,
onlyContainsAttributeCerts [5] BOOLEAN DEFAULT FALSE }
|
| public class | KeyPurposeId
The KeyPurposeId object. |
| public class | KeyUsage
The KeyUsage object. |
| public class | |
| public class | |
| public class | NoticeReference
|
| public class | ObjectDigestInfo
ObjectDigestInfo ASN.1 structure used in v2 attribute certificates. |
| public class | OtherName
The OtherName object. |
| public class | |
| public class | PolicyConstraints
PKIX RFC 5280
id-ce-policyConstraints OBJECT IDENTIFIER ::= { id-ce 36 }
PolicyConstraints ::= SEQUENCE {
requireExplicitPolicy [0] SkipCerts OPTIONAL,
inhibitPolicyMapping [1] SkipCerts OPTIONAL }
SkipCerts ::= INTEGER (0..MAX)
|
| public class | |
| public class | PolicyMappings
PolicyMappings V3 extension, described in RFC3280. |
| public class | PolicyQualifierId
PolicyQualifierId, used in the CertificatePolicies X509V3 extension. |
| public class | PolicyQualifierInfo
Policy qualifiers, used in the X509V3 CertificatePolicies extension. |
| public class | PrivateKeyUsagePeriod
PrivateKeyUsagePeriod ::= SEQUENCE {
notBefore [0] GeneralizedTime OPTIONAL,
notAfter [1] GeneralizedTime OPTIONAL }
|
| public class | ReasonFlags
The ReasonFlags object. |
| public class | RoleSyntax
Implementation of the RoleSyntax object as specified by the RFC3281. |
| public class | SubjectDirectoryAttributes
This extension may contain further X.500 attributes of the subject. |
| public class | SubjectKeyIdentifier
The SubjectKeyIdentifier object. |
| public class | SubjectPublicKeyInfo
The object that contains the public key stored in a certficate. |
| public class | Target
Target structure used in target information extension for attribute certificates from RFC 3281. |
| public class | TargetInformation
Target information extension for attributes certificates according to RFC 3281. |
| public class | Targets
Targets structure used in target information extension for attribute certificates from RFC 3281. |
| public class | TBSCertificate
The TBSCertificate object. |
| public class | TBSCertList
PKIX RFC-2459 - TBSCertList object. |
| public class | |
| public class | UserNotice
|
| public class | V1TBSCertificateGenerator
Generator for Version 1 TBSCertificateStructures. |
| public class | V2AttributeCertificateInfoGenerator
Generator for Version 2 AttributeCertificateInfo
AttributeCertificateInfo ::= SEQUENCE {
version AttCertVersion -- version is v2,
holder Holder,
issuer AttCertIssuer,
signature AlgorithmIdentifier,
serialNumber CertificateSerialNumber,
attrCertValidityPeriod AttCertValidityPeriod,
attributes SEQUENCE OF Attribute,
issuerUniqueID UniqueIdentifier OPTIONAL,
extensions Extensions OPTIONAL
}
|
| public class | |
| public class | V2TBSCertListGenerator
Generator for Version 2 TBSCertList structures. |
| public class | V3TBSCertificateGenerator
Generator for Version 3 TBSCertificateStructures. |