GeneralName ::= CHOICE {
otherName [0] OtherName,
rfc822Name [1] IA5String,
dNSName [2] IA5String,
x400Address [3] ORAddress,
directoryName [4] Name,
ediPartyName [5] EDIPartyName,
uniformResourceIdentifier [6] IA5String,
iPAddress [7] OCTET STRING,
registeredID [8] OBJECT IDENTIFIER}
OtherName ::= SEQUENCE {
type-id OBJECT IDENTIFIER,
value [0] EXPLICIT ANY DEFINED BY type-id }
EDIPartyName ::= SEQUENCE {
nameAssigner [0] DirectoryString OPTIONAL,
partyName [1] DirectoryString }
Name ::= CHOICE { RDNSequence }
| Modifier and Type | Field and Description |
|---|---|
| public static final int | |
| public static final int | |
| public static final int | |
| public static final int | |
| private ASN1Encodable | |
| public static final int | |
| public static final int | |
| public static final int | |
| private int | |
| public static final int | |
| public static final int |
| Access | Constructor and Description |
|---|---|
| public | |
| public | |
| public | GeneralName(int tag, ASN1Encodable name)
When the subjectAltName extension contains an Internet mail address, the address MUST be included as an rfc822Name. |
| public | GeneralName(int
tag number tag, String string representation of name name)Create a GeneralName for the given tag from the passed in String. |
| Modifier and Type | Method and Description |
|---|---|
| private void | |
| public static GeneralName | |
| public static GeneralName | |
| public ASN1Encodable | |
| public int | |
| private void | |
| private void | |
| private int[] | |
| private int[] | |
| public ASN1Primitive | toASN1Primitive()
Implements abstract org. Implements org. |
| private byte[] | |
| public String |
| directoryName | back to summary |
|---|---|
| public static final int directoryName | |
| dNSName | back to summary |
|---|---|
| public static final int dNSName | |
| ediPartyName | back to summary |
|---|---|
| public static final int ediPartyName | |
| iPAddress | back to summary |
|---|---|
| public static final int iPAddress | |
| obj | back to summary |
|---|---|
| private ASN1Encodable obj | |
| otherName | back to summary |
|---|---|
| public static final int otherName | |
| registeredID | back to summary |
|---|---|
| public static final int registeredID | |
| rfc822Name | back to summary |
|---|---|
| public static final int rfc822Name | |
| tag | back to summary |
|---|---|
| private int tag | |
| uniformResourceIdentifier | back to summary |
|---|---|
| public static final int uniformResourceIdentifier | |
| x400Address | back to summary |
|---|---|
| public static final int x400Address | |
| GeneralName | back to summary |
|---|---|
| public GeneralName(X509Name dirName)
Deprecated use X500Name constructor. | |
| GeneralName | back to summary |
|---|---|
| public GeneralName(X500Name dirName) | |
| GeneralName | back to summary |
|---|---|
| public GeneralName(int tag, ASN1Encodable name) When the subjectAltName extension contains an Internet mail address, the address MUST be included as an rfc822Name. The format of an rfc822Name is an "addr-spec" as defined in RFC 822 [RFC 822]. When the subjectAltName extension contains a domain name service label, the domain name MUST be stored in the dNSName (an IA5String). The name MUST be in the "preferred name syntax," as specified by RFC 1034 [RFC 1034]. When the subjectAltName extension contains a URI, the name MUST be stored in the uniformResourceIdentifier (an IA5String). The name MUST be a non-relative URL, and MUST follow the URL syntax and encoding rules specified in [RFC 1738]. The name must include both a scheme (e.g., "http" or "ftp") and a scheme-specific-part. The scheme- specific-part must include a fully qualified domain name or IP address as the host. When the subjectAltName extension contains a iPAddress, the address MUST be stored in the octet string in "network byte order," as specified in RFC 791 [RFC 791]. The least significant bit (LSB) of each octet is the LSB of the corresponding byte in the network address. For IP Version 4, as specified in RFC 791, the octet string MUST contain exactly four octets. For IP Version 6, as specified in RFC 1883, the octet string MUST contain exactly sixteen octets [RFC 1883]. | |
| GeneralName | back to summary |
|---|---|
| public GeneralName(int tag, String name) Create a GeneralName for the given tag from the passed in String. This constructor can handle:
Note A directory name can be encoded in different ways into a byte representation. Be aware of this if the byte representation is used for comparing results.
| |
| copyInts | back to summary |
|---|---|
| private void copyInts(int[] parsedIp, byte[] addr, int offSet) | |
| getInstance | back to summary |
|---|---|
| public static GeneralName getInstance(Object obj) | |
| getInstance | back to summary |
|---|---|
| public static GeneralName getInstance(ASN1TaggedObject tagObj, boolean explicit) | |
| getName | back to summary |
|---|---|
| public ASN1Encodable getName() | |
| getTagNo | back to summary |
|---|---|
| public int getTagNo() | |
| parseIPv4 | back to summary |
|---|---|
| private void parseIPv4(String ip, byte[] addr, int offset) | |
| parseIPv4Mask | back to summary |
|---|---|
| private void parseIPv4Mask(String mask, byte[] addr, int offset) | |
| parseIPv6 | back to summary |
|---|---|
| private int[] parseIPv6(String ip) | |
| parseMask | back to summary |
|---|---|
| private int[] parseMask(String mask) | |
| toASN1Primitive | back to summary |
|---|---|
| public ASN1Primitive toASN1Primitive() Implements abstract org. Implements org. Doc from org. Method providing a primitive representation of this object suitable for encoding.
| |
| toGeneralNameEncoding | back to summary |
|---|---|
| private byte[] toGeneralNameEncoding(String ip) | |
| toString | back to summary |
|---|---|
| public String toString() Overrides java. Doc from java. Returns a string representation of the object.
| |