| Modifier and Type | Class and Description |
|---|---|
| public abstract class | GenericURLContext
This abstract class is a generic URL context that accepts as the name argument either a string URL or a Name whose first component is a URL. |
| public abstract class | GenericURLDirContext
This abstract class is a generic URL DirContext that accepts as the name argument either a string URL or a Name whose first component is a URL. |
| public class | Uri
A Uri object represents an absolute Uniform Resource Identifier (URI) as defined by RFC 2396 and updated by RFC 2373 and RFC 2732. |
| public class | UrlUtil
Utilities for dealing with URLs. |