APIdia Launch Partner
Top Description Constructors Methods
javax.net.ssl

public abstract Class ExtendedSSLSession

extends Object
implements SSLSession
Class Inheritance
All Implemented Interfaces
javax.net.ssl.SSLSession
Known Direct Subclasses
sun.security.ssl.SSLSessionImpl
Imports
java.util.List, javax.crypto.SecretKey

Extends the SSLSession interface to support additional session attributes.
Since
1.7

Constructor Summary

AccessConstructor and Description
public
ExtendedSSLSession()

Constructor for subclasses to call.

Method Summary

Modifier and TypeMethod and Description
public byte[]

Returns:

a byte array of size length that contains the EKM material
exportKeyingMaterialData
(String
the label bytes used in the EKM calculation. label will be converted to a byte[] before the operation begins.
label
,
byte[]
the context bytes used in the EKM calculation, or null
context
,
int
the number of bytes of EKM material needed
length
)

Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.

public SecretKey

Returns:

a SecretKey that contains length bytes of the EKM material
exportKeyingMaterialKey
(String
the algorithm of the resultant SecretKey object. See the SecretKey Algorithms section in the Java Security Standard Algorithm Names Specification for information about standard secret key algorithm names.
keyAlg
,
String
the label bytes used in the EKM calculation. label will be converted to a byte[] before the operation begins.
label
,
byte[]
the context bytes used in the EKM calculation, or null
context
,
int
the number of bytes of EKM material needed
length
)

Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.

public abstract String[]

Returns:

An array of supported signature algorithms, in descending order of preference. The return value is an empty array if no signature algorithm is supported.
getLocalSupportedSignatureAlgorithms
()

Obtains an array of supported signature algorithms that the local side is willing to use.

public abstract String[]

Returns:

An array of supported signature algorithms, in descending order of preference. The return value is an empty array if the peer has not sent the supported signature algorithms.
getPeerSupportedSignatureAlgorithms
()

Obtains an array of supported signature algorithms that the peer is able to use.

public List<SNIServerName>

Returns:

a non-null immutable list of SNIServerNames of the requested server name indications. The returned list may be empty if no server name indications were requested.
getRequestedServerNames
()

Obtains a List containing all SNIServerNames of the requested Server Name Indication (SNI) extension.

public List<byte[]>

Returns:

a non-null unmodifiable list of byte arrays, each entry containing a DER-encoded OCSP response (using the ASN.1 type OCSPResponse defined in RFC 6960). The order of the responses must match the order of the certificates presented by the server in its Certificate message (See SSLSession#getLocalCertificates() for server mode, and SSLSession#getPeerCertificates() for client mode). It is possible that fewer response entries may be returned than the number of presented certificates. If an entry in the list is a zero-length byte array, it should be treated by the caller as if the OCSP entry for the corresponding certificate is missing. The returned list may be empty if no OCSP responses were presented during handshaking or if OCSP stapling is not supported by either endpoint for this handshake.
getStatusResponses
()

Returns a List containing DER-encoded OCSP responses (using the ASN.1 type OCSPResponse defined in RFC 6960) for the client to verify status of the server's certificate during handshaking.

Inherited from java.lang.Object:
cloneequalsfinalizegetClasshashCodenotifynotifyAlltoStringwaitwaitwait

Constructor Detail

ExtendedSSLSessionback to summary
public ExtendedSSLSession()

Constructor for subclasses to call.

Method Detail

exportKeyingMaterialDataback to summary
public byte[] exportKeyingMaterialData(String label, byte[] context, int length) throws SSLKeyException

Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.

RFC 5705 (for (D)TLSv1.2 and earlier) calculates different EKM values depending on whether context is null or non-null/empty. RFC 8446 (TLSv1.3) treats a null context as non-null/empty.

label will be converted to bytes using the java.nio.charset.StandardCharsets#UTF_8 character encoding.

Depending on the chosen underlying key derivation mechanism, the raw bytes might not be extractable/exportable. In such cases, the exportKeyingMaterialKey(String, String, byte[], int) method should be used instead to access the generated key material.

Implementation Specification

The default implementation throws UnsupportedOperationException.

Parameters
label:String

the label bytes used in the EKM calculation. label will be converted to a byte[] before the operation begins.

context:byte[]

the context bytes used in the EKM calculation, or null

length:int

the number of bytes of EKM material needed

Returns:byte[]

a byte array of size length that contains the EKM material

Exceptions
SSLKeyException:
if the key cannot be generated
IllegalArgumentException:
if length is non-positive, or if the label or context length can not be accommodated
NullPointerException:
if label is null
IllegalStateException:
if this session does not have the necessary key generation material (for example, a session under construction during handshaking)
UnsupportedOperationException:
if the underlying provider does not implement the operation, or if the derived keying material is not extractable
Since
25
External Specification
https://www.rfc-editor.org/info/rfc5705, https://www.rfc-editor.org/info/rfc8446
exportKeyingMaterialKeyback to summary
public SecretKey exportKeyingMaterialKey(String keyAlg, String label, byte[] context, int length) throws SSLKeyException

Generates Exported Keying Material (EKM) calculated according to the algorithms defined in RFCs 5705/8446.

RFC 5705 (for (D)TLSv1.2 and earlier) calculates different EKM values depending on whether context is null or non-null/empty. RFC 8446 (TLSv1.3) treats a null context as non-null/empty.

label will be converted to bytes using the java.nio.charset.StandardCharsets#UTF_8 character encoding.

Implementation Specification

The default implementation throws UnsupportedOperationException.

Parameters
keyAlg:String

the algorithm of the resultant SecretKey object. See the SecretKey Algorithms section in the Java Security Standard Algorithm Names Specification for information about standard secret key algorithm names.

label:String

the label bytes used in the EKM calculation. label will be converted to a byte[] before the operation begins.

context:byte[]

the context bytes used in the EKM calculation, or null

length:int

the number of bytes of EKM material needed

Returns:SecretKey

a SecretKey that contains length bytes of the EKM material

Exceptions
SSLKeyException:
if the key cannot be generated
IllegalArgumentException:
if keyAlg is empty, length is non-positive, or if the label or context length can not be accommodated
NullPointerException:
if keyAlg or label is null
IllegalStateException:
if this session does not have the necessary key generation material (for example, a session under construction during handshaking)
UnsupportedOperationException:
if the underlying provider does not implement the operation
Since
25
External Specification
https://www.rfc-editor.org/info/rfc5705, https://www.rfc-editor.org/info/rfc8446
getLocalSupportedSignatureAlgorithmsback to summary
public abstract String[] getLocalSupportedSignatureAlgorithms()

Obtains an array of supported signature algorithms that the local side is willing to use.

Note

this method is used to indicate to the peer which signature algorithms may be used for digital signatures in TLS/DTLS 1.2. It is not meaningful for TLS/DTLS versions prior to 1.2.

The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See the Java Security Standard Algorithm Names document for information about standard algorithm names.

Note

the local supported signature algorithms should conform to the algorithm constraints specified by getAlgorithmConstraints() method in SSLParameters.

Returns:String[]

An array of supported signature algorithms, in descending order of preference. The return value is an empty array if no signature algorithm is supported.

External Specification
Java Security Standard Algorithm Names
See Also
SSLParameters#getAlgorithmConstraints
getPeerSupportedSignatureAlgorithmsback to summary
public abstract String[] getPeerSupportedSignatureAlgorithms()

Obtains an array of supported signature algorithms that the peer is able to use.

Note

this method is used to indicate to the local side which signature algorithms may be used for digital signatures in TLS/DTLS 1.2. It is not meaningful for TLS/DTLS versions prior to 1.2.

The signature algorithm name must be a standard Java Security name (such as "SHA1withRSA", "SHA256withECDSA", and so on). See the Java Security Standard Algorithm Names document for information about standard algorithm names.

Returns:String[]

An array of supported signature algorithms, in descending order of preference. The return value is an empty array if the peer has not sent the supported signature algorithms.

External Specification
Java Security Standard Algorithm Names
See Also
X509KeyManager, X509ExtendedKeyManager
getRequestedServerNamesback to summary
public List<SNIServerName> getRequestedServerNames()

Obtains a List containing all SNIServerNames of the requested Server Name Indication (SNI) extension.

In server mode, unless the return List is empty, the server should use the requested server names to guide its selection of an appropriate authentication certificate, and/or other aspects of security policy.

In client mode, unless the return List is empty, the client should use the requested server names to guide its endpoint identification of the peer's identity, and/or other aspects of security policy.

Returns:List<SNIServerName>

a non-null immutable list of SNIServerNames of the requested server name indications. The returned list may be empty if no server name indications were requested.

Exceptions
UnsupportedOperationException:
if the underlying provider does not implement the operation
Since
1.8
See Also
SNIServerName, X509ExtendedTrustManager, X509ExtendedKeyManager
getStatusResponsesback to summary
public List<byte[]> getStatusResponses()

Returns a List containing DER-encoded OCSP responses (using the ASN.1 type OCSPResponse defined in RFC 6960) for the client to verify status of the server's certificate during handshaking.

This method only applies to certificate-based server authentication. An X509ExtendedTrustManager will use the returned value for server certificate validation.

Implementation Specification

This method throws UnsupportedOperationException by default. Classes derived from ExtendedSSLSession must implement this method.

Returns:List<byte[]>

a non-null unmodifiable list of byte arrays, each entry containing a DER-encoded OCSP response (using the ASN.1 type OCSPResponse defined in RFC 6960). The order of the responses must match the order of the certificates presented by the server in its Certificate message (See SSLSession#getLocalCertificates() for server mode, and SSLSession#getPeerCertificates() for client mode). It is possible that fewer response entries may be returned than the number of presented certificates. If an entry in the list is a zero-length byte array, it should be treated by the caller as if the OCSP entry for the corresponding certificate is missing. The returned list may be empty if no OCSP responses were presented during handshaking or if OCSP stapling is not supported by either endpoint for this handshake.

Exceptions
UnsupportedOperationException:
if the underlying provider does not implement the operation
Since
9
See Also
X509ExtendedTrustManager