| Modifier and Type | Field and Description |
|---|---|
| public static final ASN1ObjectIdentifier | BUSINESS_CATEGORY
businessCategory - DirectoryString(SIZE(1..128) |
| public static final ASN1ObjectIdentifier | C
country code - StringType(SIZE(2)) |
| public static final ASN1ObjectIdentifier | CN
common name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | COUNTRY_OF_CITIZENSHIP
RFC 3039 CountryOfCitizenship - PrintableString (SIZE (2)) -- ISO 3166 codes only |
| public static final ASN1ObjectIdentifier | COUNTRY_OF_RESIDENCE
RFC 3039 CountryOfResidence - PrintableString (SIZE (2)) -- ISO 3166 codes only |
| public static final ASN1ObjectIdentifier | DATE_OF_BIRTH
RFC 3039 DateOfBirth - GeneralizedTime - YYYYMMDD000000Z |
| public static final ASN1ObjectIdentifier | |
| private static final Hashtable | DefaultLookUp
look up table translating common symbols into their OIDS. |
| protected final Hashtable | |
| private static final Hashtable | DefaultSymbols
default look up table translating OID values into their common symbols following the convention in RFC 2253 with a few extras |
| protected final Hashtable | |
| public static final ASN1ObjectIdentifier | DMD_NAME
RFC 2256 dmdName |
| public static final ASN1ObjectIdentifier | DN_QUALIFIER
dnQualifier - DirectoryString(SIZE(1..64) |
| public static final ASN1ObjectIdentifier | E
email address in Verisign certificates |
| public static final ASN1ObjectIdentifier | EmailAddress
Email address (RSA PKCS#9 extension) - IA5String. |
| public static final ASN1ObjectIdentifier | GENDER
RFC 3039 Gender - PrintableString (SIZE(1)) -- "M", "F", "m" or "f" |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | |
| public static final X500NameStyle | INSTANCE
Singleton instance. |
| public static final ASN1ObjectIdentifier | L
locality name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | NAME
id-at-name |
| public static final ASN1ObjectIdentifier | NAME_AT_BIRTH
ISIS-MTT NameAtBirth - DirectoryString(SIZE(1..64) |
| public static final ASN1ObjectIdentifier | O
organization - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | OU
organizational unit name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | PLACE_OF_BIRTH
RFC 3039 PlaceOfBirth - DirectoryString(SIZE(1..128) |
| public static final ASN1ObjectIdentifier | POSTAL_ADDRESS
RFC 3039 PostalAddress - SEQUENCE SIZE (1..6) OF DirectoryString(SIZE(1..30)) |
| public static final ASN1ObjectIdentifier | POSTAL_CODE
postalCode - DirectoryString(SIZE(1..40) |
| public static final ASN1ObjectIdentifier | PSEUDONYM
RFC 3039 Pseudonym - DirectoryString(SIZE(1..64) |
| public static final ASN1ObjectIdentifier | SERIALNUMBER
device serial number name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | SN
device serial number name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | ST
state, or province name - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | STREET
street - StringType(SIZE(1..64)) |
| public static final ASN1ObjectIdentifier | SURNAME
Naming attributes of type X520name |
| public static final ASN1ObjectIdentifier | T
Title |
| public static final ASN1ObjectIdentifier | TELEPHONE_NUMBER
id-at-telephoneNumber |
| public static final ASN1ObjectIdentifier | UID
LDAP User id. |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | |
| public static final ASN1ObjectIdentifier | UnstructuredName
more from PKCS#9 |
| Access | Constructor and Description |
|---|---|
| protected |
| Modifier and Type | Method and Description |
|---|---|
| public ASN1ObjectIdentifier | attrNameToOID(String
the string to match. attrName)Implements org. |
| protected ASN1Encodable | encodeStringValue(ASN1ObjectIdentifier
the DN oid of the value oid, String the String representation of the value value)Overrides org. |
| public RDN[] | fromString(String
the String representation. dirName)Implements org. |
| public String[] | oidToAttrNames(ASN1ObjectIdentifier
the OID of interest. oid)Implements org. |
| public String | oidToDisplayName(ASN1ObjectIdentifier
the OID of interest. oid)Implements org. |
| public String | toString(X500Name
the name to convert. name)Implements org. |
| BUSINESS_CATEGORY | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier BUSINESS_CATEGORY businessCategory - DirectoryString(SIZE(1..128) | |
| C | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier C country code - StringType(SIZE(2)) | |
| CN | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier CN common name - StringType(SIZE(1..64)) | |
| COUNTRY_OF_CITIZENSHIP | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier COUNTRY_OF_CITIZENSHIP RFC 3039 CountryOfCitizenship - PrintableString (SIZE (2)) -- ISO 3166 codes only | |
| COUNTRY_OF_RESIDENCE | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier COUNTRY_OF_RESIDENCE RFC 3039 CountryOfResidence - PrintableString (SIZE (2)) -- ISO 3166 codes only | |
| DATE_OF_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DATE_OF_BIRTH RFC 3039 DateOfBirth - GeneralizedTime - YYYYMMDD000000Z | |
| DC | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DC | |
| DefaultLookUp | back to summary |
|---|---|
| private static final Hashtable<K, V> DefaultLookUp look up table translating common symbols into their OIDS. | |
| defaultLookUp | back to summary |
|---|---|
| protected final Hashtable<K, V> defaultLookUp | |
| DefaultSymbols | back to summary |
|---|---|
| private static final Hashtable<K, V> DefaultSymbols default look up table translating OID values into their common symbols following the convention in RFC 2253 with a few extras | |
| defaultSymbols | back to summary |
|---|---|
| protected final Hashtable<K, V> defaultSymbols | |
| DMD_NAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DMD_NAME RFC 2256 dmdName | |
| DN_QUALIFIER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier DN_QUALIFIER dnQualifier - DirectoryString(SIZE(1..64) | |
| E | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier E email address in Verisign certificates | |
| EmailAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier EmailAddress Email address (RSA PKCS#9 extension) - IA5String. Note if you're trying to be ultra orthodox, don't use this! It shouldn't be in here. | |
| GENDER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GENDER RFC 3039 Gender - PrintableString (SIZE(1)) -- "M", "F", "m" or "f" | |
| GENERATION | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GENERATION | |
| GIVENNAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier GIVENNAME | |
| INITIALS | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier INITIALS | |
| INSTANCE | back to summary |
|---|---|
| public static final X500NameStyle INSTANCE Singleton instance. | |
| L | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier L locality name - StringType(SIZE(1..64)) | |
| NAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier NAME id-at-name | |
| NAME_AT_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier NAME_AT_BIRTH ISIS-MTT NameAtBirth - DirectoryString(SIZE(1..64) | |
| O | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier O organization - StringType(SIZE(1..64)) | |
| OU | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier OU organizational unit name - StringType(SIZE(1..64)) | |
| PLACE_OF_BIRTH | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier PLACE_OF_BIRTH RFC 3039 PlaceOfBirth - DirectoryString(SIZE(1..128) | |
| POSTAL_ADDRESS | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier POSTAL_ADDRESS RFC 3039 PostalAddress - SEQUENCE SIZE (1..6) OF DirectoryString(SIZE(1..30)) | |
| POSTAL_CODE | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier POSTAL_CODE postalCode - DirectoryString(SIZE(1..40) | |
| PSEUDONYM | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier PSEUDONYM RFC 3039 Pseudonym - DirectoryString(SIZE(1..64) | |
| SERIALNUMBER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SERIALNUMBER device serial number name - StringType(SIZE(1..64)) | |
| SN | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SN device serial number name - StringType(SIZE(1..64)) | |
| ST | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier ST state, or province name - StringType(SIZE(1..64)) | |
| STREET | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier STREET street - StringType(SIZE(1..64)) | |
| SURNAME | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier SURNAME Naming attributes of type X520name | |
| T | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier T Title | |
| TELEPHONE_NUMBER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier TELEPHONE_NUMBER id-at-telephoneNumber | |
| UID | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UID LDAP User id. | |
| UNIQUE_IDENTIFIER | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UNIQUE_IDENTIFIER | |
| UnstructuredAddress | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UnstructuredAddress | |
| UnstructuredName | back to summary |
|---|---|
| public static final ASN1ObjectIdentifier UnstructuredName more from PKCS#9 | |
| BCStyle | back to summary |
|---|---|
| protected BCStyle() | |
| attrNameToOID | back to summary |
|---|---|
| public ASN1ObjectIdentifier attrNameToOID(String attrName) Implements org. Doc from org. Return the OID associated with the passed in name.
| |
| encodeStringValue | back to summary |
|---|---|
| protected ASN1Encodable encodeStringValue(ASN1ObjectIdentifier oid, String value) Overrides org. Doc from org. Encoded every value into a UTF8String. Subclasses should overwrite this method to change the encoding of specific types.
| |
| fromString | back to summary |
|---|---|
| public RDN[] fromString(String dirName) Implements org. Doc from org. Return an array of RDN generated from the passed in String. | |
| oidToAttrNames | back to summary |
|---|---|
| public String[] oidToAttrNames(ASN1ObjectIdentifier oid) Implements org. Doc from org. Return the acceptable names in a String DN that map to OID.
| |
| oidToDisplayName | back to summary |
|---|---|
| public String oidToDisplayName(ASN1ObjectIdentifier oid) Implements org. Doc from org. Return the display name for toString() associated with the OID.
| |
| toString | back to summary |
|---|---|
| public String toString(X500Name name) Implements org. Doc from org. Convert the passed in X500Name to a String. | |